Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 663830 - x11-drivers/nvidia-drivers requires X use flag to install various libraries which don't depend on X
Summary: x11-drivers/nvidia-drivers requires X use flag to install various libraries w...
Status: RESOLVED DUPLICATE of bug 561706
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 663834
  Show dependency tree
 
Reported: 2018-08-17 00:50 UTC by Nathaniel Lewis
Modified: 2018-08-23 21:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch demonstrating change (nvidia-drivers-396.45.ebuild.patch,2.98 KB, patch)
2018-08-17 00:50 UTC, Nathaniel Lewis
Details | Diff
patch demonstrating change (nvidia-drivers-396.45.ebuild.patch,3.06 KB, patch)
2018-08-23 21:29 UTC, Nathaniel Lewis
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nathaniel Lewis 2018-08-17 00:50:21 UTC
Created attachment 543746 [details, diff]
patch demonstrating change

Hello all,

I've been working on an application which uses CUDA in a headless server environment.  The cuda library, along with cuvid, nvenc, opencl, and nvidia-ml are installed via x11-drivers/nvidia-drivers, but require the X use flag to be set for them to be installed.  These libraries do not require X to be present on the system.

I've attached a patch which moves these out of the "if use X" statement of src_install-libs().  I also removed a redundant installation of cuvid and nvenc in src_install() (they are installed by src_install-libs() later on).  I also removed libnvidia-fbc from src_install() for the same reason, but also because it depends on X and was not guarded as such.

- Nathan
Comment 1 Marius Brehler 2018-08-17 07:52:25 UTC

*** This bug has been marked as a duplicate of bug 561706 ***
Comment 2 Nathaniel Lewis 2018-08-23 21:29:57 UTC
Created attachment 544730 [details, diff]
patch demonstrating change

forgot ptxjit and compiler.