Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 655170

Summary: media-libs/mediastreamer-2.9.0-r2 : videofilters/nowebcam.c:1743:49: error: FF_INPUT_BUFFER_PADDING_SIZE undeclared (first use in this function)
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Andrew Savchenko <bircoph>
Status: RESOLVED FIXED    
Severity: normal CC: atoth, bastien, candrews, devurandom, treecleaner
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 653678    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
media-libs:mediastreamer-2.9.0-r2:20180507-003942.log
temp.tbz2
Rename FF_INPUT_BUFFER_PADDING_SIZE to AV_INPUT_BUFFER_PADDING_SIZE
mediastreamer-2.9.0-ffmpeg4.patch

Description Toralf Förster gentoo-dev 2018-05-07 15:28:47 UTC
     ^~~~~~~~~~~~~~~~~~~~~
videofilters/nowebcam.c: In function ‘ms_load_jpeg_as_yuv’:
videofilters/nowebcam.c:1743:49: error: ‘FF_INPUT_BUFFER_PADDING_SIZE’ undeclared (first use in this function); did you mean ‘AV_INPUT_BUFFER_PADDING_SIZE’?
   jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + FF_INPUT_BUFFER_PADDING_SIZE);
                                                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                                 AV_INPUT_BUFFER_PADDING_SIZE

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma_ffmpeg4_20180501-112342

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
  [5]   pypy (fallback)
  [6]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv media-libs/mediastreamer
[nomerge      ] media-libs/mediastreamer-2.9.0-r2  USE="X alsa filters ipv6 opengl ortp sdl speex video x264 -amr -bindist (-coreaudio) -debug -doc -examples -g726 -g729 -gsm -ilbc -libav -ntp-timestamp -opus -oss -pcap -portaudio -pulseaudio -silk -static-libs {-test} -theora -upnp -v4l" 
[ebuild  N    ]  media-plugins/mediastreamer-x264-1.4.2-r1  USE="-libav" 
[ebuild  N    ]   media-libs/mediastreamer-2.9.0-r2  USE="X alsa filters ipv6 opengl ortp sdl speex video x264 -amr -bindist (-coreaudio) -debug -doc -examples -g726 -g729 -gsm -ilbc -libav -ntp-timestamp -opus -oss -pcap -portaudio -pulseaudio -silk -static-libs {-test} -theora -upnp -v4l"
Comment 1 Toralf Förster gentoo-dev 2018-05-07 15:28:50 UTC
Created attachment 530310 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-05-07 15:28:53 UTC
Created attachment 530312 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-05-07 15:28:56 UTC
Created attachment 530314 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-05-07 15:29:00 UTC
Created attachment 530316 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-05-07 15:29:02 UTC
Created attachment 530318 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-05-07 15:29:06 UTC
Created attachment 530320 [details]
media-libs:mediastreamer-2.9.0-r2:20180507-003942.log
Comment 7 Toralf Förster gentoo-dev 2018-05-07 15:29:09 UTC
Created attachment 530322 [details]
temp.tbz2
Comment 8 Craig Andrews gentoo-dev 2018-11-05 22:37:21 UTC
Treecleaners,

Can you please considering last-riting this package?

The last release (as seen at http://download.savannah.nongnu.org/releases/linphone/mediastreamer/ ) was 12-Jun-2013. There's no upstream activity.
Comment 9 Andrew Savchenko gentoo-dev 2018-11-06 15:42:01 UTC
(In reply to Craig Andrews from comment #8)
> The last release (as seen at
> http://download.savannah.nongnu.org/releases/linphone/mediastreamer/ ) was
> 12-Jun-2013. There's no upstream activity.

The latest release is mediastreamer-2.14.0 from 13 Oct 2016:
http://public.p-knowledge.co.jp/Savannah-nongnu-mirror/linphone/mediastreamer/

and it is quite active in git:
git://git.linphone.org/mediastreamer2.git

commit 5de9bb4086b036bfe84e088c87211cdf48f37cd6 (HEAD -> master, origin/master, origin/fix/audio_units_bugs, origin/HEAD)
Author: Sylvain Berfini <sylvain.berfini@belledonne-communications.com>
Date:   Thu Oct 25 11:59:55 2018 +0200

Of course version in portage needs care.
Comment 10 Bastien Le Querrec 2018-11-13 15:13:00 UTC
Created attachment 555022 [details, diff]
Rename FF_INPUT_BUFFER_PADDING_SIZE to AV_INPUT_BUFFER_PADDING_SIZE
Comment 11 Attila Tóth 2018-11-27 16:51:56 UTC
Created attachment 556462 [details, diff]
mediastreamer-2.9.0-ffmpeg4.patch

Proposed user patch - works for me.
Comment 12 Dennis Schridde 2018-11-29 21:08:20 UTC
(In reply to Attila Tóth from comment #11)
> Created attachment 556462 [details, diff] [details, diff]
> mediastreamer-2.9.0-ffmpeg4.patch
> 
> Proposed user patch - works for me.

It's a duplicate of attachment #555022 [details, diff] in comment #10.
Comment 13 Andreas Sturmlechner gentoo-dev 2018-11-29 21:23:59 UTC
(In reply to Andrew Savchenko from comment #9)
> Of course version in portage needs care.
Are you still maintaining this package?
Comment 14 Larry the Git Cow gentoo-dev 2018-11-29 21:31:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6ea32cd71c72c4ed9b94ea474b0933294562adf7

commit 6ea32cd71c72c4ed9b94ea474b0933294562adf7
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-11-29 21:25:43 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-11-29 21:31:27 +0000

    media-libs/mediastreamer: Fix build with ffmpeg-4
    
    Tnanks-to: Bastien Le Querrec <bastien@silence.im>
    Closes: https://bugs.gentoo.org/655170
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/mediastreamer-2.9.0-ffmpeg4.patch        | 22 ++++++++++++++++++++++
 .../mediastreamer/mediastreamer-2.9.0-r2.ebuild    |  3 ++-
 2 files changed, 24 insertions(+), 1 deletion(-)
Comment 15 Andrew Savchenko gentoo-dev 2018-12-07 19:06:55 UTC
(In reply to Andreas Sturmlechner from comment #13)
> (In reply to Andrew Savchenko from comment #9)
> > Of course version in portage needs care.
> Are you still maintaining this package?

I'm trying to, but each time I allocate resources for this work some shit happens, e.g. I'm at hospital and dev away right now :/ So feel free to fix such stuff and thanks for your help.