Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 650248

Summary: media-libs/fontconfig-2.13.0: fonts are too small and ugly when using media-fonts/infinality-ultimate-meta
Product: Gentoo Linux Reporter: Viktor Levin <viklevin2>
Component: Current packagesAssignee: Gentoo Fonts Team <fonts>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bjh-gentoobt, devurandom, ilya.kashheev.82, kripton, rzubaly, viklevin2
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=652458
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: pretty_fontconfig_2.12.6.png
ugly_and_too_small_fontconfig_2.13.0.png

Description Viktor Levin 2018-03-11 19:54:33 UTC
I have the following packages installed:
- media-libs/fontconfig-infinality-20130404
- media-libs/fontconfig-ultimate-2015.08.01
- media-fonts/infinality-ultimate-meta-1

My fontconfig settings are default. The only setting I set in "eselect fontconfig list" is enabling 52-infinality.conf

"eselect lcdfilter list" is set to "[14]  ultimate".
"eselect infinality list" is set to "[7]   ultimate-combi".

All the fonts are nice and pretty when using these settings with stable media-libs/fontconfig-2.12.6. But the fonts become too small and ugly when using these settings with media-libs/fontconfig-2.13.0 (especially on Wikipedia website pages launched in Firefox). I had to p.mask 2.13.0 as a workaround.
Comment 1 Viktor Levin 2018-03-11 20:04:26 UTC
Created attachment 523534 [details]
pretty_fontconfig_2.12.6.png

pretty_fontconfig_2.12.6.png
Comment 2 Viktor Levin 2018-03-11 20:04:49 UTC
Created attachment 523536 [details]
ugly_and_too_small_fontconfig_2.13.0.png

ugly_and_too_small_fontconfig_2.12.0.png
Comment 3 Massimo Burcheri 2018-03-13 11:08:25 UTC
Similar here, but more ugly as your example. In your "ugly" example it seems just to switch to some MS font.

In my case, some Gtk applications (Palemoon) and websites (like this one here) switched to serif fonts instead of sans serif fonts.

Emerging =media-libs/fontconfig-2.12.6 back solved the whole issue.

Beside bug 650228 with xorg-server issues, I still had graphic errors and artifacts with x11-base/xorg-server-1.19.99.901-r1 and noticed these are also solved with the downgrade to =media-libs/fontconfig-2.12.6
Comment 4 Massimo Burcheri 2018-03-13 11:10:20 UTC
Having set
# eselect infinality set ultimate-free
# eselect lcdfilter set ultimate
Comment 5 Massimo Burcheri 2018-03-13 15:08:11 UTC
But eventhough Palemoon (or Firefox) has the correct font again, some others like Evolution still have the wrong font.
Comment 6 Viktor Levin 2018-03-14 02:39:56 UTC
(In reply to Massimo Burcheri from comment #3)
> In your "ugly" example it seems just to switch to some MS font.
I don't know which font name is used. However, on both my screenshots font names are equal.

> Beside bug 650228 with xorg-server issues, I still had graphic errors and
> artifacts with x11-base/xorg-server-1.19.99.901-r1 and noticed these are
> also solved with the downgrade to =media-libs/fontconfig-2.12.6
I see. By the way, my x11-base/xorg-server is 1.19.5-r1.
Comment 7 thunderrd 2018-03-14 03:54:44 UTC
I'm not sure if this is helpful, but I had to roll back media-libs/fontconfig because the new fontconfig-2.13.0 created boot time errors related to infinality.  The fonts also looked wrong.

Rolling it back to 2.12.6 eliminated the problem.

The boot time error I am talking about would be visible in a tty.  I've forgotten exactly what it said, but it was something related to not being able to read a file in /etc/fonts/infinality/conf.d
Comment 8 thunderrd 2018-03-14 03:57:23 UTC
If needed I could reproduce this error, but I'm sure you will see it [if it exists on your setup] by using Ctl-Alt-F1 after boot is finished.
Comment 9 Massimo Burcheri 2018-03-14 08:04:36 UTC
Running on media-libs/fontconfig-2.12.6 starting gvim for instance says:
> Fontconfig error: failed reading config file
> Fontconfig error: Cannot load config file "infinality/conf.d"

As for the graphic errors and artifacts (distorted panels, moving windows makes them disappear and not update anymore) mentioned in comment 3 I was able to reproduce that it is caused by fontconfig-2.13.0 and fixed with 2.12.6 after restarting X.
Comment 10 thunderrd 2018-03-14 08:30:16 UTC
(In reply to Massimo Burcheri from comment #9)
> Running on media-libs/fontconfig-2.12.6 starting gvim for instance says:
> > Fontconfig error: failed reading config file
> > Fontconfig error: Cannot load config file "infinality/conf.d"
> 
> As for the graphic errors and artifacts (distorted panels, moving windows
> makes them disappear and not update anymore) mentioned in comment 3 I was
> able to reproduce that it is caused by fontconfig-2.13.0 and fixed with
> 2.12.6 after restarting X.

Yes, I can confirm that is the message I was getting on startup.  It's gone now, after the downgrade to fontconfig-2.13.0
Comment 11 thunderrd 2018-03-14 14:20:58 UTC
(In reply to thunderrd from comment #10)
> (In reply to Massimo Burcheri from comment #9)
> > Running on media-libs/fontconfig-2.12.6 starting gvim for instance says:
> > > Fontconfig error: failed reading config file
> > > Fontconfig error: Cannot load config file "infinality/conf.d"
> > 
> > As for the graphic errors and artifacts (distorted panels, moving windows
> > makes them disappear and not update anymore) mentioned in comment 3 I was
> > able to reproduce that it is caused by fontconfig-2.13.0 and fixed with
> > 2.12.6 after restarting X.
> 
> Yes, I can confirm that is the message I was getting on startup.  It's gone
> now, after the downgrade to fontconfig-2.13.0

err...sorry for the noise, I meant the downgrade to 2.12.6
Comment 12 Massimo Burcheri 2018-03-15 11:40:50 UTC
Same issue with media-libs/fontconfig-2.13.0-r1
Comment 13 thunderrd 2018-03-15 16:26:41 UTC
(In reply to Massimo Burcheri from comment #12)
> Same issue with media-libs/fontconfig-2.13.0-r1

...AND -r2 as well.

Sigh.

Why has no dev checked in on this bug as yet?
Comment 14 Viktor Levin 2018-03-17 05:55:20 UTC
Maybe let's create a request to p.mask 2.13.0 and 2.13.0-r2 in Portage tree?
Comment 15 giskard 2018-03-19 01:58:59 UTC
also have problem with media-libs/fontconfig-2.13.0-r2

when open an gtk application in the terminal, it report errors like this:

Fontconfig error: failed reading config file
Fontconfig error: Cannot scan config file "infinality/conf.d"
Fontconfig warning: "/etc/fonts/conf.avail/69-odofonts.conf", line 14: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.avail/69-odofonts.conf", line 14: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.avail/69-odofonts.conf", line 14: Having multiple <family> in <alias> isn't supported and may not work as expected
..

switched back to media-libs/fontconfig-2.12.6, everything becomes fine.

There may be some change in the syntax for media-libs/fontconfig-2.13.0, but pay attention to the compliance with some fonts, though maybe the font itself need to be updated.
Comment 16 thunderrd 2018-03-19 05:52:10 UTC
I think the problem here is that infinality is pretty much *dead* upstream, and no one is particularly interested in maintaining it.

That said, I'll just mask fontconfig locally for now, as I'm not particularly interested in re-configuring my fonts just because fontconfig updated.
Comment 17 Viktor Levin 2018-03-21 10:11:38 UTC
infinality GitHub fork is probably required.
Comment 18 Il Kasch 2018-04-04 18:41:45 UTC
New x11-libs/pango 1.42.0 does not work with media-libs/fontconfig-2.12.6

Requirements:
>=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]

Please create new bug for adding fontconfig-2.12.92 to Portage tree.
Comment 19 Viktor Levin 2018-04-04 21:38:34 UTC
Done.

https://bugs.gentoo.org/652458
Comment 20 thunderrd 2018-04-11 04:36:43 UTC
Today's update to 2.13.0-r3 exhibits the same error:

>>> Original instance of package unmerged safely.
 * Cleaning broken symlinks in /etc/fonts/conf.d/
 * abi_x86_32.x86: running multilib_pkg_postinst
 * Creating global font cache for x86 ...
Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"                                                                                                                           [ ok ]
 * abi_x86_64.amd64: running multilib_pkg_postinst
 * Creating global font cache for amd64 ...
Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"                                                                                                                           [ ok ]
>>> media-libs/fontconfig-2.13.0-r3 merged.
>>> Regenerating /etc/ld.so.cache...
>>> Auto-cleaning packages...


Masking this version as well, until fixed.
Comment 21 Massimo Burcheri 2018-04-11 07:11:35 UTC
(In reply to thunderrd from comment #20)
> Today's update to 2.13.0-r3 exhibits the same error:
> ...
> Masking this version as well, until fixed.

Thanks for the information. I had
=media-libs/fontconfig-2.13.0*
masked anyway. But eventhough I get this error:

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by net-im/skypeforlinux-8.18.0.6::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/xall:
#*/*::overlay-name
#>=app-emulation/vmware-workstation-12
#>=app-office/libreoffice-4.4.3.2
#>www-client/chromium-39.0.2171.65
#app-emulation/open-vm-tools
#kde-apps/kate:5
=media-libs/fontconfig-2.13.0-r3

I wasn't aware that there is any fontconfig dependency from packages like skypeforlinux.
Comment 22 Massimo Burcheri 2018-04-11 12:32:28 UTC
The error message was misleading, actually caused by new  x11-libs/pango-1.42.0

For those who like to avoid media-libs/fontconfig-2.13* like me I would currently recommend these settings on a ~amd64 arch:

# /etc/portage/package.accept_keywords/all
media-libs/fontconfig -~amd64
x11-libs/pango -~amd64
Comment 23 Viktor Levin 2018-04-12 22:46:19 UTC
(In reply to Massimo Burcheri from comment #22)
> The error message was misleading, actually caused by new 
> x11-libs/pango-1.42.0

Sure. Please see similar bug:

https://bugs.gentoo.org/652458
Comment 24 Viktor Levin 2018-04-18 08:59:12 UTC
Could anyone please test 2.13.0-r4?
Comment 25 thunderrd 2018-04-18 13:27:30 UTC
-r4 does not work, same error:

Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"
Comment 26 Guilherme Amadio gentoo-dev 2018-08-02 06:07:48 UTC
This bug seems related to https://bugs.gentoo.org/659772, which has been recently closed. If you have updated eselect-infinality to 1.1, please re-run eselect infinality and select the same configuration to fix any old relative links that break with recent fontconfig. If that alone fixes the problem reported here, please let us know so we can close this bug as well. Thank you.
Comment 27 Viktor Levin 2018-08-02 14:53:55 UTC
(In reply to Guilherme Amadio from comment #26)
> This bug seems related to https://bugs.gentoo.org/659772, which has been
> recently closed. If you have updated eselect-infinality to 1.1, please
> re-run eselect infinality and select the same configuration to fix any old
> relative links that break with recent fontconfig. If that alone fixes the
> problem reported here, please let us know so we can close this bug as well.
> Thank you.

Yes, this bug is fixed and can be closed. Thank you.
Comment 28 thunderrd 2018-08-02 14:56:49 UTC
Agreed, I followed Guilherme's instructions yesterday and the error message is gone.  All fonts are rendered correctly as intended.

Thanks for the effort.
Comment 29 Guilherme Amadio gentoo-dev 2018-08-02 15:04:28 UTC

*** This bug has been marked as a duplicate of bug 659772 ***