Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 634276

Summary: dev-util/systemtap-3.1-r1: stable request
Product: Gentoo Linux Reporter: Andrius Štikonas <andrius>
Component: StabilizationAssignee: Sven Wegener <swegener>
Status: RESOLVED FIXED    
Severity: normal Keywords: STABLEREQ
Priority: Normal Flags: stable-bot: sanity-check+
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
dev-util/systemtap-3.1-r1
Runtime testing required: ---
Bug Depends on: 522908    
Bug Blocks: 630844    
Attachments:
Description Flags
build.log.xz none

Description Andrius Štikonas 2017-10-14 21:03:22 UTC
Can we stabilize any newer version of systemtap?

Current version does not compile with GCC6.
Comment 1 Andreas K. Hüttel gentoo-dev 2017-10-14 21:14:41 UTC
(In reply to Andrius Štikonas from comment #0)
> Can we stabilize any newer version of systemtap?
> 
> Current version does not compile with GCC6.

Could you add a log and emerge --info output please?!
Comment 2 Andrius Štikonas 2017-10-14 21:16:26 UTC
Portage 2.3.8 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-6.4.0, glibc-2.23-r4, 4.12.12-gentoo x86_64)
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700HQ_CPU_@_2.60GHz-with-gentoo-2.4.1
KiB Mem:    16383448 total,    440172 free
KiB Swap:   16777212 total,  16776956 free
Timestamp of repository gentoo: Sat, 14 Oct 2017 18:15:01 +0000
Head commit of repository gentoo: 1232af79b442c1eb68ee171921956db782a90368
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo                                                                                                                                                                          
sys-devel/libtool:        2.4.6-r3::gentoo                                                                                                                                                                        
sys-devel/make:           4.2.1::gentoo                                                                                                                                                                           
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)                                                                                                                                                        
sys-libs/glibc:           2.23-r4::gentoo                                                                                                                                                                         
Repositories:                                                                                                                                                                                                     
                                                                                                                                                                                                                  
gentoo                                                                                                                                                                                                            
    location: /usr/portage                                                                                                                                                                                        
    sync-type: rsync                                                                                                                                                                                              
    sync-uri: rsync://stikonas.eu/gentoo-portage                                                                                                                                                                  
    priority: -1000                                                                                                                                                                                               
                                                                                                                                                                                                                  
torbrowser
    location: /var/lib/layman/torbrowser
    sync-type: laymansync
    sync-uri: git://github.com/MeisterP/torbrowser-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/gamedata/ /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/ ftp://mirror.bytemark.co.uk/gentoo/ http://mirrors.evowise.com/gentoo/"
LANG="lt_LT.utf8"
LDFLAGS="-march=native -O2 -pipe"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="16k_voice 1stclassmsg R X a52 aac aacs aalib accessibility acl acpi activities addns addressbook ads aesicm aimodules aio akonadi alsa amd64 amr analitza android androiddump aot ap apache2 apng apparmor appindicator archive atmo attica auth autoipd autoreplace autotools autotype avahi baremetal bash-completion bazaar berkdb bindist bittorrent bl blender bluetooth bluray bogofilter bookmarks boost botan branding bs2b btrfs bugzilla bzip2 c++0x cairo cantor captcha cdb cdda cddb cdio cdr cgi chappa chatzilla chm chromium cjk clang cli client clucene cmake color color-management colordiff colorio connection-sharing contactnotes context contrib contrib_cvv contrib_hdf contrib_sfm cracklib crypt cryptsetup csharp css csv cups curl custom-optimization cvs cxx cycles d d3d9 dbus dc1394 deblob declarative deflate dep designer designer-plugin desktopglobe device-mapper dhclient dirac djvu dmraid dnssec doc doc-pdf docbook dos dot downloadorder dpi dri dri3 drm dts dump dvb dvd dvdnav dvdr dvi dvi2tty dvipdfm dynamic eap-sim ebook ecdh edit editor egl eigen emacs embedded emboss emovix enchant encode equalizer evdev examples exif extensions extra extra-algorithms extraengine extras f2fs fakevim fam farstream fat fbcon festival ffmpeg fftw fgpanel firefox fits flac fltk fluidsynth fontconfig fontforge foomaticdb fortran fortran2003 fortran95 fpm fpx freetds ftp fuse g3dvl gadu gallium games garmin gbm gc gccgo gcj gcrypt gd gdal gdata gdbm gecko geoip geoloc geolocation gflags ghcbootstrap gif gimp git glamor gles gles1 gles2 gles3 glew glog glsl gmail gme gmp gnome-online-accounts gnuefi gnuplot gnutls go gold google gpg gphoto2 gpm gps gpssync gptfdisk gpu graphics graphite graphviz grub gsl gsm gssapi gstreamer gtk gtk3 gtkspell gtkstyle gudev gui gyroscopic gzip handbook haptic harden hdf5 hdri hfs highlight history hscolour html http hunspell hwaccel hwdb i18n icedtea7 iconv icq icu id3tag ieee1394 ilbc imagemagick imaging imap imlib imlib2 import-filter inkjar inotify introspection iodbc ipc iplayer ipv6 irc jabber jadetex java javascript jbootstrap jfs jingle jit jpeg jpeg2k json kate kde kde4 kdecards kdenlive kdepim kerberos kexiv2 keymap kipi kontact kpathsea ktp kwallet lame lapack laptop lastfm latex latexmk lcms ldap legacy-systray lensfun less libass libav-aac libcaca libevent libilbc libinput libkms libmpv libnotify libproxy libsamplerate libssh2 libtiger libxml2 lightning llvm lm_sensors lpsol lto lua luatex lvm lyrics lz4 lzma lzo mad magic magnetgenerator maildir marble math mathml matplotlib matroska md5sum mdadm mdnsresponder-compat meanwhile mediaplayer mediawiki melt mercurial metalink mhash midi mikmod minizip mjpeg mms mng mobi mod mod_muc mod_pubsub modemmanager modplug modules mono monolithic monolithic-build monotone mount mp3 mp4 mpeg mpg123 mplayer mpx mtp multilib multitarget musepack music musicbrainz mysql mysqli mythtv nat native native-exceptions native-extensions natspec ncurses netapi nethack network networkmanager new-login nftables nls nntp nptl nscd nsplugin nss ntfs ntfsprogs ntp numpy oauth objc objc++ objc-gc octave offlinehelp ogg ogg123 ogm okteta okular omega openal opencl openconnect opencv openexr opengl opengtl openid openimageio openinventor openldap openmp openstreetmap optimization opus otr p2p pam pango parcheck parted pcap pcmcia pcntl pcre pcre16 pdf pdfimport pdo perl phonon php pim pkcs11 plasma player plotutils plymouth png pnm policykit postgres postproc postscript ppds prediction preview-latex printsupport prison privacy private-headers privatestorage projectm ps psf pstoedit pstricks pth publishers pulseaudio pwquality pyqt4 python qalculate qml qrcode qt3support qt4 qt5 qthelp qtmedia quickstarter quicktime quota qwt r600-llvm-compiler radio radius raster raw rdesktop readline realtime redeyes reencrypt reiser4 reiserfs required-use resolvconf reviewboard rss rtmp rtsp ruby s3tc samba sandbox sasl sbcl scanner schroedinger science script scripts scripttools sdk sdl sdl2 search seccomp secure-delete security semantic-desktop sensord server session sftp sha512 shapefile shared-dricore shared-glapi sip sipim skins smartcard smime snappy sndfile soap sockets socks5 solver soprano sound soundtouch spacenav sparse speech speex spell spice sql sqlite sqlite3 srt srtp ssh ssl staging stars startup-notification statistics strong-optimization stun subversion suhosin supernodal svc svg symlink sync-plugin-portage syslog system-boost system-cairo system-ffmpeg system-harfbuzz system-icu system-jpeg system-jsoncpp system-libevent system-libs system-libvncserver system-libvpx system-libyaml system-llvm system-lua system-mitkrb5 system-mpmath system-mupdf system-qemu system-qt system-renpy system-seabios system-snappy system-sqlite system-tbb system-uulib system-wine system-zlib systemd sysv-utils szip taglib tcl tcpd telepathy templates terminal tesseract tex4ht texteffect tfshark themedesigner themes theora thesaurus threads thumbnail thumbnails tidy tiff timidity tk tls tntc tools tor tordns touchpad translator truetype twolame udev udf udisks udisks2 umfpack unicode unlock-notify unzip upnp upnp-av upower usb usbredir user-session utils v4l v8 vaapi vala valgrind vamp vc vcd vdpau video videos videoslideshow vim vim-syntax vlc vlm vnc vorbis vpx vulkan wallet wav wavpack wayland wayland-compositor wcs webcam webchannel webdav webengine webgl webkit webkit2 webm webp widgets wifi wikipedia win32 win64 winbind wma wmf word-perfect wps wxwidgets x264 x265 xa xattr xcb xcomposite xetex xface xfs xft xinerama xkb xml xmlrpc xmlwriter xmp xorg xplanet xpm xrandr xrender xslt xv xvfb xvid xvmc xwayland xz yahoo youtube zeroconf zip zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 3dnow 3dnowext fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics keyboard mouse wacom" KERNEL="linux" L10N="lt en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="lt en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="x86_64 aarch64 arm" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="intel i965 nouveau radeon radeonsi amdgpu dummy fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Andrius Štikonas 2017-10-14 21:20:11 UTC
Created attachment 498664 [details]
build.log.xz

Build log of dev-util/systemtap-2.4-r1.

I can successfully compile 2.9
Comment 4 Andreas K. Hüttel gentoo-dev 2017-10-31 18:54:11 UTC
Yep, looks like gcc-6 problem.

I dont see any obvious regressions in BZ, so let's go for dev-util/systemtap-3.1-r1

Arches please do your thing.
Comment 5 Thomas Deutschmann gentoo-dev Security 2017-11-02 21:18:09 UTC
x86 stable
Comment 6 Manuel Rüger (RETIRED) gentoo-dev 2017-11-02 21:49:10 UTC
Stable on amd64
Comment 7 Sergei Trofimovich gentoo-dev 2017-11-04 19:07:45 UTC
ia64 will need a tweak before finishing: bug 510134#c5
Comment 8 Tobias Klausmann gentoo-dev 2017-11-08 12:51:46 UTC
Stable on alpha.
Comment 9 Andreas K. Hüttel gentoo-dev 2017-11-08 20:28:43 UTC
ping
Comment 10 Sergei Trofimovich gentoo-dev 2017-11-08 20:37:38 UTC
ia64 stable
Comment 11 Sergei Trofimovich gentoo-dev 2017-11-13 22:41:06 UTC
ppc64 stable
Comment 12 Andreas K. Hüttel gentoo-dev 2017-11-17 23:35:11 UTC
ping
Comment 13 Sergei Trofimovich gentoo-dev 2017-11-18 17:53:41 UTC
ppc stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-03-15 14:39:41 UTC
arm stable