Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 592456

Summary: media-libs/opusfile fails to build with >=dev-libs/openssl-1.1.0
Product: Gentoo Linux Reporter: Lars Wendler (Polynomial-C) <polynomial-c>
Component: Current packagesAssignee: Markos Chandras (RETIRED) <hwoarang>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://git.xiph.org/?p=opusfile.git;a=commitdiff;h=13a6a454c3c017d06ba185a9a2b7b3433310f8ca
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 592438    
Attachments: build.log
0001-Use-ASN1_STRING_get0_data-for-openssl-1.1.0.patch

Description Lars Wendler (Polynomial-C) gentoo-dev 2016-08-30 16:58:32 UTC
Created attachment 444470 [details]
build.log

See attached build.log
Comment 1 eroen 2017-01-02 18:59:27 UTC
Created attachment 458398 [details, diff]
0001-Use-ASN1_STRING_get0_data-for-openssl-1.1.0.patch

I submitted a patch for this to upstream's mailing list, but apparently it takes a while before it shows up in the list archive.

I have attached a version of the patch backported to opusfile-0.8.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2018-06-13 16:28:19 UTC
Seems to be fixed meanwhile.