Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 570446

Summary: [Tracker] Packages failing to build because of gcc-5 changed inline semantics
Product: Gentoo Linux Reporter: Sven E. <dark>
Component: [OLD] UnspecifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alex_y_xu, nheghathivhistha
Priority: Normal Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sven E. 2016-01-01 02:58:04 UTC
I'm seeing wuite a stack of BUGs that all relate to the changed inline semantics of c99 which is covered in 'Porting to gcc-5'. I think it would be wise to collect all those different bugs in this tracker.

Reproducible: Always
Comment 1 Alex Xu (Hello71) 2016-01-01 20:25:35 UTC
*which* bugs?
Comment 2 Sven E. 2016-01-01 20:31:15 UTC
(In reply to Alex Xu (Hello71) from comment #1)
> *which* bugs?

I.E.:  #570352 

Yes the original Sourcecode seems pretty much dead. I'm sure I've seen more 'undefined reference' bugs which relate to inlien semantics.
Comment 3 David Kredba 2016-01-01 21:26:29 UTC
There is a gcc-5 tracker.

In my opinion maintaining another one for inlining issues only is not helping anyhow.
Comment 4 Sven E. 2016-01-01 21:31:19 UTC
(In reply to David Kredba from comment #3)
> There is a gcc-5 tracker.
> 
> In my opinion maintaining another one for inlining issues only is not
> helping anyhow.

Ah!

I guess I missed out on that one, as I anticipated it was already closed BEFORE gcc-5 was unmasked.

Anyhow, yes, then all the inline semantics related failures should probably go into the gcc-5 Tracker directly.
Comment 5 Alex Xu (Hello71) 2016-01-02 16:33:55 UTC

*** This bug has been marked as a duplicate of bug 536984 ***