Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 511020

Summary: www-client/google-chrome-35.0.1916.114_p1 - /usr/bin/google-chrome-stable: error while loading shared libraries: cannot open shared object file: No such file or directory
Product: Gentoo Linux Reporter: Jonathan Marten <jjm>
Component: Current packagesAssignee: Mike Gilbert <floppym>
Severity: normal CC: chromium, xmw
Priority: Normal    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Jonathan Marten 2014-05-22 10:32:25 UTC
The binary installed by the updated (after splitting into 3 versions) google-chrome stable ebuild does not run:

$ google-chrome-stable 
/usr/bin/google-chrome-stable: error while loading shared libraries: cannot open shared object file: No such file or directory
$ ldd /opt/google/chrome/chrome | grep udev => not found => /lib/ (0xb0e9a000)

# equery files udev | grep libudev
# ll /lib/libudev*
lrwxrwxrwx 1 root root  16 May 21 20:50 /lib/ ->*
-rwxr-xr-x 1 root root 78K May 21 20:50 /lib/*

Versions: google-chrome (unstable)  www-client/google-chrome-35.0.1916.114_p1
          udev (stable)             sys-fs/udev-212-r1

Reproducible: Always

Steps to Reproduce:
1.  Emerge google-chrome (with ACCEPT_KEYWORDS="~x86")
2.  Attempt to run the browser

Actual Results:  
Library dependency error as above

Expected Results:  
Browser should run
Comment 1 Jonathan Marten 2014-05-22 10:42:37 UTC
Same result with google-chrome-unstable package,
Comment 2 Jonathan Marten 2014-05-22 10:43:46 UTC
# emerge --info
Portage 2.2.7 (default/linux/x86/13.0, gcc-4.7.3, glibc-2.17, 3.10.25-gentoo i686)
System uname: Linux-3.10.25-gentoo-i686-AMD_Phenom-tm-_II_X3_705e_Processor-with-gentoo-2.2
KiB Mem:     8309464 total,    132284 free
KiB Swap:    8401984 total,   8275088 free
Timestamp of tree: Wed, 21 May 2014 19:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x skype- skype-eula dlj-1.1 AdobeFlash-10 AdobeFlash-10.1 googleearth PUEL Oracle-BCLA-JavaSE AdobeFlash-10.3 google-talkplugin google-chrome Google-TOS"
CFLAGS="-O2 -march=amdfam10 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=amdfam10 -fomit-frame-pointer -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac alsa bash-completion berkdb bzip2 cdr cli crypt cups cxx dbus dri exif fortran ftp gdbm gif gtk2 iconv jpeg jpeg2k modules mp3 ncurses nis nls nptl offensive ogg opengl openmp pam pcmcia pcre pdf png pulseaudio readline samba session sse ssl svg tcpd tiff truetype unicode usb vim-syntax vorbis wmf x86 xface xinetd xml xpm zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse joystick void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB de fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" SANE_BACKENDS="agfafocus apple avision brother canon canon630u coolscan coolscan2 epson genesys gt68xx hp microtek microtek2 mustek mustek_usb plustek sharp test umax hp5400 hp4200 hp3500 qcam v4l net mustek_usb2 pnm" USERLAND="GNU" VIDEO_CARDS="dummy fbdev vesa vga i810 nv nvidia mach64 r128 radeon nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2014-05-22 11:27:44 UTC

*** This bug has been marked as a duplicate of bug 458320 ***
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2014-05-22 11:30:13 UTC
the ebuild is creating the .so.0 symlink:

google-chrome-34.0.1847.132_p1.ebuild: dosym /usr/$(get_libdir)/ "${CHROME_HOME}/"

so not sure what's there to left to do, `ldd` will obviously print a bogus output since it's in special directory, but the ld wrapper script that should be used for google-chrome execution should find it regardless
Comment 5 Mike Gilbert gentoo-dev 2014-05-22 12:16:54 UTC
This is definitely not a duplicate bug report.

Jonathan: The ebuild should create a symlink in pkg_postinst:

/opt/google/chrome/ -> ../../../lib/

Does this symlink exist?
Comment 6 Jonathan Marten 2014-05-22 14:31:13 UTC
Mike, the link is indeed there in /opt/google/chrome:

lrwxrwxrwx 1 root root 25 May 22 13:18 -> ../../../lib/

However, the problem may be my own fault.  Some time ago I moved /opt to under /usr and made a symlink /opt -> usr/opt, in order to save space on the root filesystem (my /usr is separate).  This has worked well until now, but for the current Chrome ebuild the relative symlink is pointing to the wrong place.

Changing the link to ../../../../lib/ (one more "../") fixes the problem.
Comment 7 Mike Gilbert gentoo-dev 2014-05-22 17:26:26 UTC
Hmm... maybe I should just drop the relative symlink and replace it with an absolute one.
Comment 8 Mike Gilbert gentoo-dev 2014-05-29 00:45:00 UTC
+  29 May 2014; Mike Gilbert <> systemd-9999.ebuild:
+  Add systemd-timesync user/group and set gentoo default NTP servers, bug 511386
+  by Hristo Venev.