Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 498422

Summary: net-voip/sflphone-1.4.0 version bump
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED WONTFIX    
Severity: normal CC: brad, gentoo.2019, gentoobugs, guillaume.horel, pierigno, tobias.pal
Priority: Normal Keywords: EBUILD, PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://sflphone.org/news/sflphone-140-released
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: sflphone-1.3.0.ebuild
do not use bundled pjsip
sflphone-1.4.1 patch
Build external pjsip patch

Description Dennis Schridde 2014-01-18 00:11:05 UTC
http://sflphone.org/news/sflphone-130-released

Reproducible: Always
Comment 1 Guillaume Horel 2014-01-22 00:06:48 UTC
Created attachment 368410 [details]
sflphone-1.3.0.ebuild

Updated ebuild. I've cleane it up a bit. I believit this solves bug #49643 and bug #49628.
Comment 2 Guillaume Horel 2014-01-22 00:08:02 UTC
I meant bug #496432 and #496280.
Comment 3 Guillaume Horel 2014-01-22 00:08:43 UTC
Created attachment 368412 [details, diff]
do not use bundled pjsip
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-08-05 09:08:12 UTC
*** Bug 519056 has been marked as a duplicate of this bug. ***
Comment 5 Martin Gysel (bearsh) 2014-09-15 12:12:43 UTC
I'm wondering if it's worth to unbundle pjsip considering it is linked statically and probably tree-cleaned soon, bug 522732
Comment 6 Brad Laue 2014-09-25 17:17:11 UTC
The inherit on kde4-base seems to be imposting a hard dependency on kdelibs - am I doing something wrong? emerge info below: 

Portage 2.2.13 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.8.3, glibc-2.19-r1, 3.16.2-gentoo x86_64)
=================================================================
System uname: Linux-3.16.2-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5606_@_2.13GHz-with-gentoo-2.2
KiB Mem:    74188372 total,    413696 free
KiB Swap:    2097148 total,   2092532 free
Timestamp of tree: Thu, 18 Sep 2014 20:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.8, 3.3.5-r1
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo mate-overlay sunrise brad-x-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL skype-eula dlj-1.1 google-talkplugin Oracle-BCLA-JavaSE google-chrome ut2003 AdobeFlash-11.x skype-4.0.0.7-copyright googleearth TeamViewer Google-TOS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n -b"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mate /var/lib/layman/sunrise /usr/local/portage"
USE="X a52 aac aacs acl acpi ads alsa amd64 apng applet autoipd automount avahi beagle berkdb binfilter bluetooth bluray branding bzip2 cairo canberra cdda cddax cddb cdio cdr chm cli clutter colord cracklib crypt css cups cxx daap dbus dc1394 dconf deskbar device-mapper dhcpcd dirac djvu dri dts dvb dvd dvdr dvi eds egl emboss encode evo exif expat extras faac faad fam ffmpeg firefox flac fontconfig foomaticdb fortran fuse g3dvl galago gbm gconf gdbm gdu gif glade glamor gles2 gmp gnome gnome-keyring gnome-online-accounts gnutls gpm gs gsf gsm gstreamer gtk gtk3 gtkstyle gudev hal hires-icons html http hwdb iconv icq icu id3tag idn ieee1394 imap introspection iptc ipv6 irc iscsi jabber jpeg karma kdrive ladspa lame lcms ldap libass libkms libmpeg2 libnotify libsamplerate libsecret libsysfs lightning live lvm lzma lzo mad matroska mdnsresponder-compat mixemu mmx mmxext mng modemmanager modules mono moonlight mp3 mp4 mpeg msn mtp multilib musicbrainz nautilus ncurses networkmanager nfs nls nm-applet nntp nptl nsplugin nss objc objc++ objc-gc ofx ogg openexr opengl openmp openssl opus pam pango pcre pdf pdfimport perl playlist png podcast policykit ppds pulseaudio python qemu qt3support qt4 quotes raw rdp readline resolvconf rss rtc rtmp rtsp samba schroedinger script sdl secure-delete session short-touchpad-timeout sip smime smp socialweb speex spell spice sqlite sse sse2 ssl ssse3 startup-notification stream svg systemd t1lib taglib tcpd telepathy templates theora threads tiff tracker truetype twolame udev udisks unicode unlock-notify unzip upcall upnp upower usb usbredir utp uxa v4l v4l2 vala vcdinfo vdpau vorbis wav webkit winbind wma-fixed wxwidgets x264 xattr xcb xcomposite xft xinerama xml xmp xorg xps xscreensaver xv xvid yahoo zeitgeist zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20 ruby21" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="intel radeon radeonsi nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 7 Michael Palimaka (kensington) gentoo-dev 2014-09-26 15:12:46 UTC
(In reply to Brad Laue from comment #6)
> The inherit on kde4-base seems to be imposting a hard dependency on kdelibs
> - am I doing something wrong? emerge info below: 
Set KDE_REQUIRED="optional" above the inherit.
Comment 8 Brad Laue 2014-09-26 20:14:24 UTC
Created attachment 385566 [details]
sflphone-1.4.1 patch

New sflphone ebuild which builds the built-in pjsip library according to Comment #5. 

Running eautoreconf in the ${S}/daemon directory seems to fail, so that's commented out. 

Also the gnome portion of src_install looks like a mess. I don't think the whole S= thing is necessary, but I'm hoping for some input on that.
Comment 9 Brad Laue 2014-09-26 20:19:08 UTC
Created attachment 385568 [details, diff]
Build external pjsip patch

Updated patch to build against pjsip provided by portage if desired, though the portage version is now older than that bundled in sflphone

There are only minor differences between this and the previous patch
Comment 10 Pacho Ramos gentoo-dev 2015-02-03 15:00:39 UTC
removed