Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 454298

Summary: On amd64, sci-mathematics/maxima - maxima cannot be started from wxmaxima or cantor, on ~amd, it works.
Product: Gentoo Linux Reporter: Benjamin Schulz <Benjamin_Schulz>
Component: New packagesAssignee: Gentoo Science Mathematics related packages <sci-mathematics>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Benjamin Schulz 2013-01-27 13:02:30 UTC
after the current stable version of maxima refused to compile, I tried ~amd version sci-mathematics/maxima-5.28.0

it works fine, it just can't connect to cantor or wxmaxima. wxmaxima. even the ~amd64 version,  sci-mathematics/wxmaxima-12.09.0 says:

(wxmaxima:2446): WARNING **: IPP request failed with status 1280



Reproducible: Always




Portage 2.1.11.31 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.7.1-gentoo x86_64)
=================================================================
System uname: Linux-3.7.1-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sun, 27 Jan 2013 11:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 Intel-SDP"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_De@euro"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X X509 a52 aac aacplus acl acpi afp alsa alstream amd64 analitza archive aspell atmo audio audiofile audioscrobbler autoipd automount avahi avcodec avx berkdb bittorrent bl bluetooth bluray bmp branding bs2b bzip2 cairo canberra cdda cdparanoia cdr cdrdao cdrom cgi chromium clamav clearpasswd cleartype cli clisp clucene colord connection-sharing connman consolekit contrast corefonts cpudetection cracklib crypt cue cups curl cvs cxx cython d3d dbus dc1394 dcc_video declarative demosaic dga dhcp-tools dhcpcd dia dirac directx djvu dot dri drm dshow dts dv dvb dvd dvdnav dvdr dvi dvi2tty dvipdfm dxva2 eap-sim ebook ecls egl emacs emboss enchant encode equalizer ethernet ewf examples excel exceptions exif faac faad facebook fam fasteap fbosd ffmpeg fftw firefox fits flac flickr fluidsynth font-styles fontconfig fonts foomaticdb fortran fpx ftp fuse g3dvl g711 g722 g7221 g729 gbm gcdmaster gdbm gdu geo geonames ggi gif gimp git glamor gles gles1 gles2 glut gmath gme gnome gnome-keyring gnumeric gpg gphoto2 gpm gps graph graphics graphicsmagick graphite graphviz groupwise growl gs gsm gstreamer gtk gtk3 gudev gzip h281 hdaps hdri hostip howl-compat html http hwdb hyperestraier i18n iconv icq icu idn ieee1394 image-cache imagemagick inotify introspection ios ipv6 jack java javascript jbig jingle jpeg jpeg2k kde kdm kerberos kexiv2 keymap kipi konqueror kontact ladspa lame lapack laptop lastfm lastfmfingerprint lastfmradio latex latex3 lcms ldap lensfun libass libcaca libedit libffi libkms libmpeg2 libnotify libproxy libsamplerate libv4l libv4l2 libvisual libxml2 lilo lm_sensors logrotate lyx lzma lzo mad math mathml matplotlib matroska md5sum mdnsresponder-compat meanwhile midi minizip mjpeg mms mmx mmxext mng modemmanager modplug modules mp3 mp4 mpeg mpg123 mplayer msn mudflap multilib multimedia musepack nas ncurses network networkmanager nfsv3 nfsv4 nfsv41 nls nominatim nptl nss ntfs nut ocr octave offensive ogg ogg123 okular omxil openal opencl opencv openexr opengl openmp openssl openvg openxml opus oscar otr pam pango pci pcmcia pcre pdf pdf-writer pdfimport perl phonon pic plasma plazes plotutils pm-utils png policykit portaudio postscript powersave powertop ppds prelink preview-latex previewer projectm ps pstoedit pstricks pulseaudio pvr pyqt4 python python2 python3 q16 qalculate qmake qt3support qt4 quicktime rar raw rawspeed rcs readline realtime resolvconf rpm rsh rss rtaudio rtc rtf rtmp rtsp samba sbcl scanner schroedinger science sdl sdl-image semantic-desktop sensord session sha sha1 sha512 shine shout sid skyhook skype smp sms smtp sna socks socks5 sound speex spell spidermonkey sql sqlite sse sse2 sse3 ssh ssl ssse3 startup-notification subversion svg switcher systeminfo taglib tcpd tdb tex4ht text theora thesaurus thin-splines thinkpad threads thumbnail tiff timezone tk tools transcode truetype twolame type3 udev udisks udisks2 umfpack unicode unzip upekbsapi upnp upower usb uuid v4l vaapi vba vcd vcdx video vlc vlm vocoder volume vorbis vpx wav wavpack webkit webp wicd wifi wimax win32 wma wma-fixed wmf wxwidgets x264 xa xanim xattr xcb xcomposite xemacs xetex xft xine xinerama xml xmlpatterns xmp xorg xosd xpm xprint xrandr xrender xscreensaver xterm xv xvid xvmc yahoo zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel vesa i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Benjamin Schulz 2013-01-27 16:38:12 UTC
i looked at cantor again.

It seems that cantor could start maxima, even if it said it didn't.

However, there was surely some crash, as maximas output was:

cantor(19294)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libcantorpart.so"
Object::disconnect: Unexpected null parameter
cantor(19294)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
Maxima 5.29.1 http://maxima.sourceforge.net
using Lisp SBCL 1.0.55
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
Maxima 5.29.1 http://maxima.sourceforge.net
using Lisp SBCL 1.0.55
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
(%i1) (%i1) 


the window of cantor, however, freezes, saying it wants to initialize the session...
Comment 2 Benjamin Schulz 2013-01-27 16:40:00 UTC
now there was additional console output:

 The function bug_report() provides bug reporting information.
(%i1) 
; in: PROGN (SETUP-SERVER 0)
;     (MAXIMA::SETUP-SERVER 0)
; 
; caught STYLE-WARNING:
;   undefined function: SETUP-SERVER
; 
; compilation unit finished
;   Undefined function:
;     SETUP-SERVER
;   caught 1 STYLE-WARNING condition

Maxima encountered a Lisp error:

 The function MAXIMA::SETUP-SERVER is undefined.

Automatically continuing.
To enable the Lisp debugger set *debugger-hook* to nil.
(%i1) Maxima 5.29.1 http://maxima.sourceforge.net
using Lisp SBCL 1.0.55
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
(%i1)
Comment 3 Benjamin Schulz 2013-01-27 16:42:52 UTC
that being said, i tried it with clisp, sbcl, and ecls. I also disabled each useflag one for one...

The current stable version in portage can only compile with clisp enabled and sbcl and ecls disabled.

After reverting to the stable version of maxima, i have now this error with the stable version too....

I don't know what is the cause for that...
Comment 4 Andrey Grozin gentoo-dev 2013-01-28 11:42:14 UTC
On my ~amd64 box, wxmaxima successfully starts maxima-5.29.1 with any of 5 lisps: sbcl-1.1.3, gcl-2.6.8_pre20120805, clozurecl-1.8, ecls-12.12.1, clisp-2.49-r3. On ~x86 box, also with cmucl-20c (it's not available on amd64). I cannot reproduce your problem.
I don't know how cantor interacts with maxima. You'd better ask the maxima mailing list, stating the exact versions of maxima and cantor. Maybe, there are people who will be able to help with this problem.
Comment 5 Benjamin Schulz 2013-01-28 17:08:17 UTC
I got this behavior since an emerge sync and an "emerge -uD world" two weeks ago....

before that, wxmaxima and maxima worked well.

The fact that, when I downgrade wxmaxima and maxima to  stable versions, the problem persists (even if these maxima and wxmaxima versions worked before) indecates that the problem is because of some updated library that came in by "emerge -uD world"...

I will now look at my lisp versions once Im at my laptop again, and see whether downgrading or upgrading them helps...

by the way, the stable version of maxima refuses to compile on my system. So it maybe on the lisp end....
Comment 6 Benjamin Schulz 2013-02-03 10:13:22 UTC
I compiled lisp and there we have it:

piling (DEFUN DISABLE-CALL-COUNTING ...)
; compiling (DEFUN ENABLE-CALL-COUNTING-FOR-FUNCTION ...)
; compiling (DEFUN TEST-0 ...)
; compiling (DEFUN TEST ...)
; compiling (PROVIDE (QUOTE SB-SPROF))

; SYS:CONTRIB;SB-SPROF;SB-SPROF.FASL.NEWEST written
; compilation finished in 0:00:01.210
* true
make: Leaving directory `/var/tmp/portage/dev-lisp/sbcl-1.0.55-r1/work/sbcl-1.0.55/contrib/sb-sprof'

WARNING! Some of the contrib modules did not build successfully or pass
their self-tests. Failed contribs:"
  sb-bsd-sockets
 * ERROR: dev-lisp/sbcl-1.0.55-r1 failed (compile phase):
 *   make failed
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2448:  Called die
 * The specific snippet of code:
 *       env - HOME="${T}" CC="$(tc-getCC)" AS="$(tc-getAS)" LD="$(tc-getLD)" CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" ASFLAGS="${ASFLAGS}" LDFLAGS="${LDFLAGS}" GNUMAKE=make ./make.sh "sh ${bindir}/run-sbcl.sh --no-sysinit --no-userinit --disable-debugger" || die "make failed";
 * 
 * If you need support, post the output of `emerge --info '=dev-lisp/sbcl-1.0.55-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-lisp/sbcl-1.0.55-r1'`.
 * The complete build log is located at '/var/tmp/portage/dev-lisp/sbcl-1.0.55-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lisp/sbcl-1.0.55-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lisp/sbcl-1.0.55-r1/work/sbcl-1.0.55'
 * S: '/var/tmp/portage/dev-lisp/sbcl-1.0.55-r1/work/sbcl-1.0.55'
Comment 7 Andrey Grozin gentoo-dev 2013-02-04 03:36:37 UTC
A pity. Unfortunately, the common-lisp team in Gentoo is < 1 person, and bugs are unfixed for very long periods. I tried to push some modern stuff into the tree, in particular, sbcl-1.1.x. For me, sbcl-1.1.3 works very well - it compiles maxima and fricas, and is the fastest common lisp. But these new ebuilds break something else, and therefore are hard masked. Unless we find somebody who will join the common-lisp team, the situation will remain hopeless.
Comment 8 Jeremy Murphy 2013-09-22 06:56:21 UTC
This doesn't sound like a bug in maxima, and perhaps not a bug at all if you haven't recompiled related packages like cantor after changing maxima version.

Could you please update the title to specify the bug correctly, or consider closing it if there is no clearly defined bug.
Comment 9 Benjamin Schulz 2013-09-22 09:47:32 UTC
hi,
of course I have recompiled cantor and wxmaxima with different versions a dozen times or so....
They seem to call maxima through the same client-server mechanism, and it seems that they can not establish a connection to the maxima server, because of some problem with a library that must be somewhere in my system. But I do not know which library this is. I will try emerge -UD world again soon, and see whether this is fixed.
Comment 10 Benjamin Schulz 2013-09-22 18:44:48 UTC
Perhaps I should say that I believe this is linked to 
https://bugs.gentoo.org/show_bug.cgi?id=455268

always during compilation of dev-lisp/sbcl, self tests are runned by the ebuild. Build is cancelled with 
 "Some of the contrib modules did not build successfully or pass their self-tests. Failed contribs:" sb-bsd-sockets"

and exactly these sockets module is responsible for the mechanism through which wxmaxima or cantor are contacting maxima.
The lisp librarys other than sbcl compile fine, however, they do not run self tests. The malfunction seems to become manifest, only if I start a probram with a client server mechanism through a socket module, like wxmaxima or cantor,
Comment 11 Benjamin Schulz 2013-09-22 18:46:52 UTC
I may also add that I do not have anything like selinux or something enabled, which could initiate this problem. 

It seems to be due to some library which lisp depends on.
Comment 12 Benjamin Schulz 2013-10-11 17:21:59 UTC
I did now an entire reinstall using ~amd64.

Now on unstable, maxima and wxmaxima works like a charm.

I still do not know thich library did prevent the communication between lisp clients and servers on my stable system.

At least ~amd64 seems to work.