Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 443510

Summary: dev-lang/python should install helper file for sys-devel/gdb
Product: Gentoo Linux Reporter: Jan Pobrislo <ccx>
Component: New packagesAssignee: Python Gentoo Team <python>
Status: RESOLVED FIXED    
Severity: minor CC: oli.huber
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugs.python.org/issue8032
Whiteboard:
Package list:
Runtime testing required: ---

Description Jan Pobrislo 2012-11-16 12:32:12 UTC
Python now bundles a script for >=sys-devel/gdb-7 (the one which supports python extensions).
This is currently installed at 
/usr/share/doc/${PN}/examples/Tools/gdb/libpython.py but gdb expects it at /usr/share/gdb/auto-load/${soname}-gdb.py for it to be autoloaded. Symlinking to desired location works too, eg.:
/usr/share/gdb/auto-load/usr/lib64/libpython2.7.so.1.0-gdb.py -> /usr/share/doc/python-2.7.3-r2/examples/Tools/gdb/libpython.py

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2013-03-19 02:45:21 UTC
*** Bug 460668 has been marked as a duplicate of this bug. ***