Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 415487

Summary: sys-apps/coreutils fails test ls/stat-free-color with sandbox due to using `strace` and counting stat calls
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal CC: gentoo
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log

Description Toralf Förster gentoo-dev 2012-05-11 14:35:47 UTC
at an usntable Gentoo Linux image

Reproducible: Always




n22 / # emerge --info coreutils
Portage 2.1.10.58 (default/linux/x86/10.0, gcc-4.6.3, glibc-2.15-r1, 3.3.5 i686)                                                                                      
=================================================================                                                                                                     
                        System Settings                                                                                                                               
=================================================================                                                                                                     
System uname: Linux-3.3.5-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1                                                                             
Timestamp of tree: Fri, 11 May 2012 11:45:01 +0000                                                                                                                    
app-shells/bash:          4.2_p28                                                                                                                                     
dev-lang/python:          2.7.3-r2, 3.2.3-r1                                                                                                                          
dev-util/cmake:           2.8.8-r2                                                                                                                                    
dev-util/pkgconfig:       0.26                                                                                                                                        
sys-apps/baselayout:      2.1                                                                                                                                         
sys-apps/openrc:          0.9.9.3                                                                                                                                     
sys-apps/sandbox:         2.5                                                                                                                                         
sys-devel/autoconf:       2.69                                                                                                                                        
sys-devel/automake:       1.11.5                                                                                                                                      
sys-devel/binutils:       2.22-r1                                                                                                                                     
sys-devel/gcc:            4.6.3                                                                                                                                       
sys-devel/gcc-config:     1.7                                                                                                                                         
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --nospinner --tree --deep --quiet-build"
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 cli cracklib crypt cups cxx dri fam fastbuild gdbm gmp gpm iconv ipv6 logrotate mmx modules mudflap mysql mysqli ncurses nls nptl openmp pam pcre pppd readline session sse sse2 sse3 ssl ssse3 tcpd threads unicode userlocales webmail x86 xml xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi compat dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so socache_shmcb speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-apps/coreutils-8.17 was built with the following:
USE="acl gmp nls unicode -caps (-selinux) -static -vanilla -xattr"
Comment 1 Toralf Förster gentoo-dev 2012-05-11 14:36:15 UTC
Created attachment 311433 [details]
build log
Comment 2 Marien Zwart (RETIRED) gentoo-dev 2012-05-12 15:51:17 UTC
The test counts the difference in the number of stat calls between "ls --help" and "ls --color=always .", and checks the difference is at most 2. That is: it checks that even with color output enabled ls can do its thing without statting every file in the directory. This test fails when run manually with sandbox, and succeeds without it. So it's just failing because sandbox adds some extra stat calls. 

I doubt this can be fixed sensibly: the test should just be skipped (at least if sandbox is enabled). I know of no sane way to only count stat calls from ls itself, and not ones added by sandbox. And adjusting the expected output would be way too fragile: the number of stat calls sandbox needs is going to vary between sandbox versions.

To run just this test, do this in ${S}/tests/:

make check TESTS=ls/stat-free-color VERBOSE=yes

You should see running the above through "sandbox" fails.
Comment 3 SpanKY gentoo-dev 2014-04-27 18:23:51 UTC
*** Bug 494654 has been marked as a duplicate of this bug. ***
Comment 4 SpanKY gentoo-dev 2014-04-27 19:04:06 UTC
i've updated the test patch to skip this test

http://sources.gentoo.org/gentoo/src/patchsets/coreutils/8.22/010_all_coreutils-tests.patch?r1=1.1&r2=1.2
Comment 5 Larry the Git Cow gentoo-dev 2017-11-06 16:22:04 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0edff67f453a7509c08fce538d3da9c947daa433

commit 0edff67f453a7509c08fce538d3da9c947daa433
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2017-11-06 16:20:43 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2017-11-06 16:20:57 +0000

    sys-apps/coreutils: Rev bump to address multiple test failures
    
    - Running test suite with FEATURES=usersandbox is no longer supported
      due to various sandbox issues. (bug #413621, #439574, #629660)
    
    - Due to sandbox failures previously disabled tests
      re-enabled. (bug #415487)
    
    - tests/ls/readdir-mountpoint-inode test failure fixed. (bug #353164)
    
    - "caps" USE flag description more specified. (bug #617702
    
    - Tools/programs/libraries used in test suite now listed in
      DEPEND="test? (...)" which requires re-keywording for some
      architectures.
    
    Bug: https://bugs.gentoo.org/413621
    Bug: https://bugs.gentoo.org/439574
    Bug: https://bugs.gentoo.org/629660
    Bug: https://bugs.gentoo.org/415487
    Closes: https://bugs.gentoo.org/353164
    Closes: https://bugs.gentoo.org/617702
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 sys-apps/coreutils/Manifest                 |   1 +
 sys-apps/coreutils/coreutils-8.28-r1.ebuild | 210 ++++++++++++++++++++++++++++
 sys-apps/coreutils/metadata.xml             |   1 +
 3 files changed, 212 insertions(+)}