Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 414593

Summary: app-text/ghostscript-gpl 9.05-r1 - ld: error in ./sobin/libgs.so(.eh_frame); no .eh_frame_hdr table will be created / multilib portage
Product: Gentoo Linux Reporter: Steven Green <steven>
Component: [OLD] PrintingAssignee: Printing Team <printing>
Status: RESOLVED DUPLICATE    
Severity: normal CC: Arsen.Shnurkov, christian, steven
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard: multilib
Package list:
Runtime testing required: ---
Attachments: Output from emerge --info
Build log
emerge --info =app-text/ghostscript-gpl-9.06
emerge -pqv '=app-text/ghostscript-gpl-9.06
build.log
environment

Description Steven Green 2012-05-04 13:07:56 UTC
Emerging app-text/ghostscript-gpl-9.05-r1 fails with errors regarding libgs.so

I will attach the full build log, but error is:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: error in ./sobin/libgs.so(.eh_frame); no .eh_frame_hdr table will be created.
collect2: ld returned 1 exit status


Reproducible: Always




Will attach emerge --info as file attachment as bugzilla is not letting me submit as says comment is >16384 bytes
Comment 1 Steven Green 2012-05-04 13:08:43 UTC
Created attachment 310783 [details]
Output from emerge --info
Comment 2 Steven Green 2012-05-04 13:10:04 UTC
Created attachment 310785 [details]
Build log
Comment 3 Steven Green 2012-05-04 13:15:26 UTC
Output from:  emerge -pqv =app-text/ghostscript-gpl-9.05-r1

[ebuild     U ] app-text/ghostscript-gpl-9.05-r1 [9.05] USE="X cups dbus gtk jpeg2k -bindist -djvu -idn -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW"
Comment 4 Diego Stamigni 2012-05-31 21:48:05 UTC
Same problem for me. I re try again maybe 3 times and then it works. Don't know why.
Comment 5 Christian Holpert 2012-07-20 14:24:46 UTC
confirmed for X86, app-text/ghostscript-gpl 9.05-r1 and app-text/ghostscript-gpl 9.05-r2.
Same error here.

Package compiled and installed after 5th try. Changed nothing in between, just retried.
Comment 6 Arsen Shnurkov 2012-12-19 23:13:15 UTC
I have the same error with app-text/ghostscript-gpl 9.05-r1  amd64
Comment 7 Arsen Shnurkov 2012-12-19 23:33:55 UTC
the same for 
[ebuild     U ~] app-text/ghostscript-gpl-9.06 [9.05-r1] USE="X cups static-libs -bindist -dbus -djvu -gtk -idn -jpeg2k" LINGUAS="-de% -ja -ko -zh_CN -zh_TW" 0 kB
Comment 8 Arsen Shnurkov 2012-12-19 23:38:29 UTC
Created attachment 332738 [details]
emerge --info =app-text/ghostscript-gpl-9.06
Comment 9 Arsen Shnurkov 2012-12-19 23:39:08 UTC
Created attachment 332740 [details]
emerge -pqv '=app-text/ghostscript-gpl-9.06
Comment 10 Arsen Shnurkov 2012-12-19 23:41:08 UTC
Created attachment 332742 [details]
build.log

/var/tmp/portage/app-text/ghostscript-gpl-9.06/temp/build.log
Comment 11 Arsen Shnurkov 2012-12-19 23:41:45 UTC
Comment on attachment 332742 [details]
build.log

/var/tmp/portage/app-text/ghostscript-gpl-9.06/temp/build.log
Comment 12 Arsen Shnurkov 2012-12-19 23:42:44 UTC
Created attachment 332744 [details]
environment

/var/tmp/portage/app-text/ghostscript-gpl-9.06/temp/environment
Comment 13 Petr Pisar 2013-05-04 10:14:51 UTC
This seems like the bug #383447.
Comment 14 Andreas K. Hüttel gentoo-dev 2014-04-26 23:25:45 UTC

*** This bug has been marked as a duplicate of bug 383447 ***