Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 407711

Summary: x11-drivers/ati-drivers-12.2: amdcccle segfaults when changing desktop settings
Product: Gentoo Linux Reporter: Eric Siegel <eric>
Component: [OLD] UnspecifiedAssignee: Gentoo X packagers <x11>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: enrico.tagliavini, proxy-maint
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: http://ati.cchtml.com/show_bug.cgi?id=346
Whiteboard:
Package list:
Runtime testing required: ---

Description Eric Siegel 2012-03-10 19:45:35 UTC
I updated to ati-drivers-12.2 to finally fix the xv issue (bug 391193).  I opened amdcccle (as root), selected "Display Manager", and changed my desktop from cloned to multi-display (I have 2 monitors).  When I hit "apply", amdcccle closed, and I saw the following in the console.

(process:12156): GLib-GObject-CRITICAL **: gtype.c:2715: You forgot to call g_type_init()

(process:12156): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:12156): GLib-GObject-CRITICAL **: gtype.c:2715: You forgot to call g_type_init()

(process:12156): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:12156): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

Segmentation Fault

After updating the drivers, I ran "/opt/bin/aticonfig --initial -f".  Luckily, that backed up my old xorg.conf, so I used it to set back my dual monitor setup.
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-03-10 20:49:00 UTC
That piece of software is proprietary, we can't fix it. Get a stack trace and report to the unofficial fglrx bugzilla http://ati.cchtml.com/
Comment 2 Enrico Tagliavini 2012-03-12 17:57:31 UTC
if you open a bug in the unofficial fglrx bugzilla add the link here please, thank you
Comment 3 Eric Siegel 2012-03-12 19:29:06 UTC
Someone else posted it already, I'll just add to that.

http://ati.cchtml.com/show_bug.cgi?id=346
Comment 4 Manuel Rüger (RETIRED) gentoo-dev 2015-07-10 17:13:16 UTC
Closing this bug, as 12.2 is not available in tree anymore. Please reopen, if you can reproduce with a recent version.