Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 391193 - x11-drivers/ati-drivers-11.11 - segmentation fault with Xv video
Summary: x11-drivers/ati-drivers-11.11 - segmentation fault with Xv video
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 4 votes (vote)
Assignee: Luca Barbato
URL:
Whiteboard: Do not use Xv with xorg-server-1.11 a...
Keywords:
Depends on: 403941
Blocks:
  Show dependency tree
 
Reported: 2011-11-21 08:45 UTC by Andrew Waters
Modified: 2012-03-09 16:18 UTC (History)
25 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,4.83 KB, text/plain)
2011-11-21 08:47 UTC, Andrew Waters
Details
emerge --info (emerge.info,4.78 KB, text/plain)
2011-11-23 19:40 UTC, blesk2
Details
emerge --info (emerge.info,6.30 KB, text/plain)
2011-11-26 15:28 UTC, phorsyon
Details
emerge --info (emerge.info,4.75 KB, text/plain)
2011-12-14 20:11 UTC, Michael
Details
emerge --info (emerge-info.txt,4.74 KB, text/plain)
2011-12-23 09:33 UTC, Michael Hampicke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Waters 2011-11-21 08:45:41 UTC
Running x11-base/xorg-server-1.11.2-r1, x11-drivers/ati-drivers-11.11 and media-video/vlc-1.1.12 causes segmentation fault in xorg-server.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x568a48]
1: /usr/bin/X (0x400000+0x16c629) [0x56c629]
2: /lib64/libpthread.so.0 (0x7f7ddfc1f000+0xf3d0) [0x7f7ddfc2e3d0]
3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xs111LookupPrivate+0x22) [0x7f7ddcfa3c72]
4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xclLookupPrivate+0xd) [0x7f7ddc97675d]
5: /usr/lib64/xorg/modules/amdxmm.so (X740XvPutImage+0x12e) [0x7f7dd9d618de]
6: /usr/bin/X (0x400000+0x888ae) [0x4888ae]
7: /usr/lib64/xorg/modules/extensions/libextmod.so (0x7f7dddc67000+0x1008c) [0x7f7dddc7708c]
8: /usr/bin/X (0x400000+0x35821) [0x435821]
9: /usr/bin/X (0x400000+0x249ea) [0x4249ea]
10: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f7ddeb89cdd]
11: /usr/bin/X (0x400000+0x24589) [0x424589]
Segmentation fault at address 0x20

Everything works correctly using xorg-server 1.10.4-r1

Reproducible: Always

Steps to Reproduce:
1.Start playing a video in VLC
2.
3.
Actual Results:  
xorg-server crashes

Expected Results:  
plays the video
Comment 1 Andrew Waters 2011-11-21 08:47:04 UTC
Created attachment 293275 [details]
emerge --info
Comment 2 Jeroen Roovers gentoo-dev 2011-11-23 15:40:24 UTC
Which version of ati-drivers is that?
Comment 3 Andrew Waters 2011-11-23 18:13:46 UTC
As it says in the description ati-drivers-11.11
Comment 4 blesk2 2011-11-23 19:40:03 UTC
Created attachment 293551 [details]
emerge --info
Comment 5 blesk2 2011-11-23 19:44:12 UTC
Same problem with vlc, mplayer and mplayer2.
Comment 6 Enrico Tagliavini 2011-11-25 17:13:26 UTC
Nice bug :|. Which video output are you using? Xv? opengl? can you try with different settings just to understand who works and who doesn't?

I will also try to reproduce the problem with xorg-server 1.10.4-r1 (just to be sure it works).
Comment 7 phorsyon 2011-11-26 15:28:21 UTC
Created attachment 293847 [details]
emerge --info

I can confirm this bug for vlc, mplayer2 and tvtime with the default video output.
Comment 8 blesk2 2011-11-26 18:07:39 UTC
x11-base/xorg-server-1.10.4-r1
xv - works
opengl - works

x11-base/xorg-server-1.11.2-r1
xv - segmentation fault
opengl - works

x11-base/xorg-server-1.11.2-r2
xv - segmentation fault
opengl - works

Tested with smplayer (mplayer backend).
Comment 9 Enrico Tagliavini 2011-11-27 18:13:13 UTC
At least opengl seems works, good news. Thank you for your report. I guess we need to wait for the next release of ati-drivers and test again.

Xv never worked good with fglrx, i feel better with opengl.
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2011-12-13 21:31:01 UTC
AMD has released 11.12 today, if the Xv crash is solved there we could slip it into the Xorg stabilization bug 394393.
Comment 11 Enrico Tagliavini 2011-12-14 08:11:24 UTC
(In reply to comment #10)
> AMD has released 11.12 today, if the Xv crash is solved there we could slip it
> into the Xorg stabilization bug 394393.

Nice, i will bump it this evening i hope. Only intel cards at work :(
Comment 12 Enrico Tagliavini 2011-12-14 18:35:48 UTC
Sorry for the late. ati-drivers-11.12 bumped to X11 overlay. Please test and report. Thank you.
Comment 13 Michael 2011-12-14 20:08:26 UTC
(In reply to comment #12)
> Sorry for the late. ati-drivers-11.12 bumped to X11 overlay. Please test and
> report. Thank you.

Still the same here. Tested with vlc-1.1.12-r1 using xv
Comment 14 Michael 2011-12-14 20:11:03 UTC
Created attachment 295845 [details]
emerge --info
Comment 15 Eric Siegel 2011-12-22 13:41:00 UTC
x11-drivers/ati-drivers-11.12 and x11-base/xorg-server-1.11.2-r2

Playing a video in VLC-1.1.13 (with xv): crash
Trying to open xine-ui-0.99.6 / xine-lib-1.1.20 (set to use xv): crash
Comment 16 Eric Siegel 2011-12-22 13:42:39 UTC
Can someone test with x11-base/xorg-server-1.11.3?
Comment 17 Michael Hampicke 2011-12-23 09:33:26 UTC
Still crashing when using xv as video out with
x11-base/xorg-server-1.11.2-r2
media-video/totem-2.32.0-r2
x11-drivers/ati-drivers-11.12
Comment 18 Michael Hampicke 2011-12-23 09:33:38 UTC
Created attachment 296729 [details]
emerge --info
Comment 19 Michael Hampicke 2011-12-23 09:37:58 UTC
Sorry, I meant x11-base/xorg-server-1.11.3, NOT 1.11.2-r2
Comment 20 Olivier Mondoloni 2011-12-25 19:00:42 UTC
With xorg-server-1.11.3 and ati-drivers-11.12, vlc with xv video continue to crash.
Comment 21 yury fedorchenko 2011-12-26 18:43:39 UTC
the same problem 
x11-base/xorg-server-1.11.2-r2 and 
ati-drivers-11.12 (11.11 crash too)

vlc and mplayer crash until i switch to opengl vo.
Comment 22 Jimis Hol 2011-12-28 21:38:46 UTC
mplayer and cheese crash.With  cheese I use Xv output. It was time consuming to go back to ati-drivers-11.8 (With radeon HD5700 I had to disable kernel's kms support.)
Comment 23 Eric Siegel 2011-12-28 21:43:43 UTC
I was googling around and found this: http://en.gentoo-wiki.com/wiki/Fglrx#X_crashes_when_playing_a_video_using_Xv

It suggests adding Option "TexturedVideo" "on" to xorg.conf.

Wonder if that'll help, I'll test it later tonight.
Comment 24 Enrico Tagliavini 2011-12-28 22:35:15 UTC
(In reply to comment #23)
> I was googling around and found this:
> http://en.gentoo-wiki.com/wiki/Fglrx#X_crashes_when_playing_a_video_using_Xv
> 
> It suggests adding Option "TexturedVideo" "on" to xorg.conf.
> 
> Wonder if that'll help, I'll test it later tonight.

Don't be hopeful, i already have it in my xorg.conf but X11 crashes anyway. I think we just need to wait for a fix by AMD, so looking at the next releases.
Comment 25 Eric Siegel 2011-12-28 22:44:02 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > I was googling around and found this:
> > http://en.gentoo-wiki.com/wiki/Fglrx#X_crashes_when_playing_a_video_using_Xv
> > 
> > It suggests adding Option "TexturedVideo" "on" to xorg.conf.
> > 
> > Wonder if that'll help, I'll test it later tonight.
> 
> Don't be hopeful, i already have it in my xorg.conf but X11 crashes anyway. I
> think we just need to wait for a fix by AMD, so looking at the next releases.

It was worth a shot...
Comment 26 Enrico Tagliavini 2011-12-28 22:46:06 UTC
(In reply to comment #25)
> It was worth a shot...

Of course it was. Thank you for pointing it out :).
Comment 27 Darren West 2011-12-30 04:03:09 UTC
I ran into this bug as well.  Wouldn't it be appropriate to mark x11-drivers/ati-drivers-11.11 as unstable at this point until a fixed version is released?
Comment 28 Eric Siegel 2011-12-30 05:04:52 UTC
(In reply to comment #27)
> I ran into this bug as well.  Wouldn't it be appropriate to mark
> x11-drivers/ati-drivers-11.11 as unstable at this point until a fixed version
> is released?

I think the issue here is with X, not ATI.  Look at comment 8.
Comment 29 Enrico Tagliavini 2011-12-30 15:19:49 UTC
(In reply to comment #27)
> I ran into this bug as well.  Wouldn't it be appropriate to mark
> x11-drivers/ati-drivers-11.11 as unstable at this point until a fixed version
> is released?

I'm not sure. The point is xorg-server-1.11 is now stable and if ati-drivers-11.11 or newer is not stable, user using this driver would hit a blocker and then the XV problem itself. A workaround is known, and unluck with binary drivers you know you can hit this kind of issue.

I know it is not nice, it would just be better if binary drivers would just work.
Comment 30 Chí-Thanh Christopher Nguyễn gentoo-dev 2011-12-30 19:04:57 UTC
The issue is with ati-drivers, all other X11 drivers work fine with Xv and xorg-server-1.11. It is also documented in pkg_postinst() messages and, as comment 29 noted, has a known workaround (use OpenGL instead of Xv for video).
Comment 31 Bill Prendergast 2012-01-18 03:58:54 UTC
(In reply to comment #30)
> The issue is with ati-drivers, all other X11 drivers work fine with Xv and
> xorg-server-1.11. It is also documented in pkg_postinst() messages and, as
> comment 29 noted, has a known workaround (use OpenGL instead of Xv for video).

the work-around in the ebuild should direct users to add

Section "Extensions"
        Option "XVideo" "Disable"
EndSection

to thier xorg.conf file (or add to the existing section if it is already present)
as suggested in http://ati.cchtml.com/show_bug.cgi?id=337#c7

Currently some applications will crash the X server before you can change the output mode (I'm experiencing this with media-video/cheese).
Comment 32 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-29 01:51:46 UTC
In Phoronix forums a link to this hotfix driver has been posted: http://www2.ati.com/drivers/hotfix/radeon_7900_series/amd-driver-installer-8.921-x86.x86_64.run
Although it is intended for 7970 only, maybe it solves other problems too.
Comment 33 Eric Siegel 2012-01-29 04:50:12 UTC
I noticed that the x11 overlay has x11-drivers/ati-drivers-12.1.  Wonder if this fixes anything.

http://gpo.zugaina.org/x11-drivers/ati-drivers/
Comment 34 Enrico Tagliavini 2012-01-29 13:05:28 UTC
(In reply to comment #32)
> In Phoronix forums a link to this hotfix driver has been posted:
> http://www2.ati.com/drivers/hotfix/radeon_7900_series/amd-driver-installer-8.921-x86.x86_64.run
> Although it is intended for 7970 only, maybe it solves other problems too.

I'm not sure: catalyst 12.1 reports version 8.93.4 so it should be newer than 8.921 (i still don't understand fglrx version scheme to be honest).

In the worst case that fix should be integrated in the next version of catalyst (so 12.2) due to the AMD QA process being 2 months usually.
Comment 35 Enrico Tagliavini 2012-01-29 13:06:30 UTC
(In reply to comment #33)
> I noticed that the x11 overlay has x11-drivers/ati-drivers-12.1.  Wonder if
> this fixes anything.

I'm sorry but no, it doesn't fix the XV problem, for me at least :(
Comment 36 Alexey Shildyakov 2012-02-12 16:50:12 UTC
The same here with x11-drivers/ati-drivers-12.1-r1
Also crashed when loading from kdm.


Feb 12 20:39:32 SERVER kernel: [72319.629547] [fglrx] Firegl kernel thread PID: 14677
Feb 12 20:39:32 SERVER kernel: [72319.629624] [fglrx] Firegl kernel thread PID: 14678
Feb 12 20:39:32 SERVER kernel: [72319.629671] [fglrx] Firegl kernel thread PID: 14679
Feb 12 20:39:32 SERVER kernel: [72319.629790] [fglrx] IRQ 44 Enabled
Feb 12 20:39:32 SERVER kernel: [72319.775506] [fglrx] Gart USWC size:1280 M.
Feb 12 20:39:32 SERVER kernel: [72319.775509] [fglrx] Gart cacheable size:508 M.
Feb 12 20:39:32 SERVER kernel: [72319.775514] [fglrx] Reserved FB block: Shared offset:0, size:1000000 
Feb 12 20:39:32 SERVER kernel: [72319.775516] [fglrx] Reserved FB block: Unshared offset:f8fd000, size:403000 
Feb 12 20:39:32 SERVER kernel: [72319.775518] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000 
Feb 12 20:39:34 SERVER kdm: :0[14685]: Received unknown or unexpected command -2 from greeter
Feb 12 20:39:34 SERVER kdm: :0[14685]: Abnormal termination of greeter for display :0, code 1, signal 0
Feb 12 20:39:34 SERVER kernel: [72322.094876] [fglrx] IRQ 44 Disabled
Feb 12 20:39:41 SERVER kernel: [72328.710981] fglrx_pci 0000:01:00.0: irq 44 for MSI/MSI-X
Feb 12 20:39:41 SERVER kernel: [72328.711207] debug_smp_processor_id: 545 callbacks suppressed
Feb 12 20:39:41 SERVER kernel: [72328.711209] BUG: using smp_processor_id() in preemptible [00000000] code: X/14774
Feb 12 20:39:41 SERVER kernel: [72328.711245] caller is ip_firegl_lseek+0x19cd/0x1c30 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711248] Pid: 14774, comm: X Tainted: P           O 3.2.2-gentoo #1
Feb 12 20:39:41 SERVER kernel: [72328.711250] Call Trace:
Feb 12 20:39:41 SERVER kernel: [72328.711256]  [<ffffffff813e25d5>] ? debug_smp_processor_id+0xd5/0xf0
Feb 12 20:39:41 SERVER kernel: [72328.711273]  [<ffffffffa00a09cd>] ? ip_firegl_lseek+0x19cd/0x1c30 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711290]  [<ffffffffa00a0a49>] ? ip_firegl_lseek+0x1a49/0x1c30 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711309]  [<ffffffffa00a5046>] ? KAS_InterlockedList_InsertAtTail+0x76/0x160 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711331]  [<ffffffffa00bb5c3>] ? MCIL_InterlockedList+0x193/0x2a0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711352]  [<ffffffffa00b4375>] ? fireglPcsCommand+0xa5/0x140 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711378]  [<ffffffffa017f3e6>] ? FIFO_Queue_Initialize+0xe6/0x100 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711403]  [<ffffffffa018e442>] ? AvailableCallbacksQueue_Initialize+0x52/0x90 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711426]  [<ffffffffa0190c75>] ? InitializeExtension+0x125/0x1d0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711449]  [<ffffffffa0191398>] ? InitializeInterrupts+0x38/0x60 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711475]  [<ffffffffa017ddad>] ? IRQMGR_InitializeIRQMGR+0xfd/0x110 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711498]  [<ffffffffa00bf5af>] ? irqmgr_wrap_assert_interrupt+0x31f/0x8b0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711519]  [<ffffffffa00bf367>] ? irqmgr_wrap_assert_interrupt+0xd7/0x8b0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711541]  [<ffffffffa00be6ae>] ? irqmgr_wrap_initialize+0x1e/0xb0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711563]  [<ffffffffa00bdb3e>] ? firegl_interrupt_control+0x16e/0x1a0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711566]  [<ffffffff810595fd>] ? ns_capable+0x1d/0x50
Feb 12 20:39:41 SERVER kernel: [72328.711587]  [<ffffffffa00bd9d0>] ? firegl_wait_for_hifreq_interrupt_PX+0xf0/0xf0 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711607]  [<ffffffffa00af5ed>] ? firegl_ioctl+0x1ed/0xf10 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711624]  [<ffffffffa00a1039>] ? ip_firegl_unlocked_ioctl+0x9/0x10 [fglrx]
Feb 12 20:39:41 SERVER kernel: [72328.711627]  [<ffffffff81131a16>] ? do_vfs_ioctl+0x96/0x4f0
Feb 12 20:39:41 SERVER kernel: [72328.711630]  [<ffffffff81131f08>] ? sys_ioctl+0x98/0xa0
Feb 12 20:39:41 SERVER kernel: [72328.711633]  [<ffffffff8112040e>] ? sys_write+0x4e/0x90
Feb 12 20:39:41 SERVER kernel: [72328.711637]  [<ffffffff8169af7b>] ? system_call_fastpath+0x16/0x1b
Comment 37 Siarhei Siamashka 2012-02-13 21:37:36 UTC
(In reply to comment #30)
> The issue is with ati-drivers, all other X11 drivers work fine with Xv and
> xorg-server-1.11. It is also documented in pkg_postinst() messages and, as
> comment 29 noted, has a known workaround (use OpenGL instead of Xv for video).

Could it be caused by this ABI break?
    http://comments.gmane.org/gmane.comp.freedesktop.xorg.devel/21857
Comment 38 Bodo Thiesen 2012-02-15 11:39:30 UTC
Please add a depend on "<x11-base/xorg-server-1.11.0". I can hardly believe, that Xorg 1.11 brings any new feature, which would pay off X server crashes and loosing entire sessions.
Comment 39 Enrico Tagliavini 2012-02-15 13:53:09 UTC
(In reply to comment #38)
> Please add a depend on "<x11-base/xorg-server-1.11.0". I can hardly believe,
> that Xorg 1.11 brings any new feature, which would pay off X server crashes and
> loosing entire sessions.

Given that AMD officially supports xorg-server-1.11, that a workaround exist, that the current stable is xorg-server-1.11 and blocking only xorg might lead to problems if not blocking also the entire Xorg-server-1.11 stack (for example the *-proto packages).

The main problem for me is that stable users will have a blocker they must resolve by hand. For testing this might also be ok, but for stable is not for this kind of bug imho.

Needless to say the X11 team has the final word for this and i will follow their decision, whatever it is. I hope ati-drivers-12.2 will finally fix this issue
Comment 40 Siarhei Siamashka 2012-02-15 18:40:04 UTC
(In reply to comment #39)
> (In reply to comment #38)
> > Please add a depend on "<x11-base/xorg-server-1.11.0". I can hardly believe,
> > that Xorg 1.11 brings any new feature, which would pay off X server crashes and
> > loosing entire sessions.
> 
> Given that AMD officially supports xorg-server-1.11

I can only find the following description on AMD website after a quick search: "Description: Automated installer and Display Drivers for X.Org 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, or 7.6". Do you have a better link where xorg-server-1.11 is documented to be supported?

AMD just needs to rebuild the drivers for the updated ABI to make everyone happy. Also the problem seems to be well known and discussed at phoronix:
    http://www.phoronix.com/scan.php?page=news_item&px=OTQ3NA

By the way, could it be that bug 398299 is caused by the same problem? Probably mismatched ABI, caused by forgetting to rebuild x11-drivers/xf86-video-intel or something else?
Comment 41 Enrico Tagliavini 2012-02-15 19:01:15 UTC
(In reply to comment #40)
> (In reply to comment #39)
> AMD just needs to rebuild the drivers for the updated ABI to make everyone
> happy. Also the problem seems to be well known and discussed at phoronix:
>     http://www.phoronix.com/scan.php?page=news_item&px=OTQ3NA

It is a bit (and this is sarcasm) harder than that, or AMD would just do it don't you think? To not talk about the QA process.

You can know the xorg-server support for fglrx by reading phoronix, the author has direct contacts with AMD and he is also a beta tester for fglrx (so he has access to not public fglrx beta builds). See here http://www.phoronix.com/scan.php?page=news_item&px=MTAxNTc for the xorg server 1.11 support announce.
Comment 42 Enrico Tagliavini 2012-03-08 19:03:22 UTC
ati-drivers-12.2 has just been bumped to X11 overlay. It should finally fix this issue. If you test please report if it works or not, thank you.
Comment 43 Stanislav Ochotnicky (RETIRED) gentoo-dev 2012-03-08 19:50:59 UTC
ati-drivers-12.2 fixed this bug for me. Thanks for such a fast bump
Comment 44 Michael Hampicke 2012-03-08 21:39:14 UTC
ati-drivers-12.2 worked for me too
Comment 45 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-03-09 00:35:10 UTC
Fixed in 12.2.
Comment 46 Olivier Mondoloni 2012-03-09 15:18:21 UTC
This 12.2 version of ati-drivers works for me too without any crash when playing videos with xv acceleration actived.
Comment 47 Enrico Tagliavini 2012-03-09 16:18:47 UTC
Very good, thank you all :)