Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 399353

Summary: app-admin/sysstat-10.0.3 generated daily report file will be truncated by cron.daily (sys-process/vixie-cron-4.1-r12) schedule
Product: Gentoo Linux Reporter: Timo Eissler <morlix>
Component: Current packagesAssignee: Jeroen Roovers <jer>
Status: RESOLVED WORKSFORME    
Severity: minor CC: barzog, morlix
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=415381
Whiteboard:
Package list:
Runtime testing required: ---

Description Timo Eissler 2012-01-19 08:23:18 UTC
The file /etc/cron.daily/sysstat should produce a daily summary of the data collected by sar.

Because cron.daily will be started 03:10 (run-crons) the generated report file only includes the data from 00:00 till 03:10.

# emerge --info
Portage 2.1.10.41 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo_20111023-1 x86_64)
=================================================================
System uname: Linux-3.0.6-gentoo_20111023-1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 19 Jan 2012 02:45:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo local-repository
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="ftp://de-mirror.org/distro/gentoo/ rsync://de-mirror.org/gentoo/ http://mirror.netcologne.de/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ rsync://ftp-stud.hs-esslingen.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync9.de.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 berkdb bzip2 clamav cli cracklib crypt cups cxx device-mapper dri fam fortran gdbm gpm gzip iconv ipv6 ldap lm_sensors lzma maildir mmx modules mudflap multilib mysql ncurses nls nptl nptlonly openmp pam pcre posix pppd quota readline session sse sse2 ssl sysfs syslog tcpd udev unicode vim-syntax xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always

Steps to Reproduce:
1. install sysstat package
2. wait one day
3. take a look at the generated sar daily report file in /var/log/sarXX
Actual Results:  
The generated report file is truncated

Expected Results:  
The generated report file should show the whole day.
Comment 1 Jeroen Roovers gentoo-dev 2012-01-19 15:05:40 UTC
This would be the cron.daily/ file installed by upstream. Would it suffice to make it non-executable by default?
Comment 2 Jeroen Roovers gentoo-dev 2012-01-19 15:28:48 UTC
(In reply to comment #1)
> This would be the cron.daily/ file installed by upstream. Would it suffice to
> make it non-executable by default?

One problem with that is that a re-emerge or upgrade will reset that once you've made the file(s) executable, so we'd have to check for that too. Maybe we shouldn't install them at all?

Also note that sa2(8) suggests putting this in a crontab:
     5 19 * * 1-5 /usr/lib64/sa/sa2 -A &

which suggests to me that despite appearances, the utility is not intended to generate a 24 hour report, but simply a report summarising the day until that moment (5 minutes past 7 PM implies a work day).
Comment 3 Jeroen Roovers gentoo-dev 2019-05-31 08:10:58 UTC
(In reply to Timo Eissler from comment #0)
> Because cron.daily will be started 03:10 (run-crons) the generated report
> file only includes the data from 00:00 till 03:10.

You can change when those are run; it does not have to be at 03:10 at all.