Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 389131

Summary: kde-base/kdelibs-4.7.2 dependency error when attempting emerge of kde-4.7.2
Product: Gentoo Linux Reporter: Chris Prior <cmprior>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED INVALID    
Severity: blocker    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 388279    

Description Chris Prior 2011-10-31 20:34:01 UTC
Attempting to test the upgrade to kde-4.7.2 stable release as noted in stable request bugzilla 388279.
Getting an error in the dependency check, despite copying the package list to the package.accept file in /etc/portage 



Not sure why this is the case as I cannot see any additional dependencies unless I need to set ~amd in make.conf

Reproducible: Always

Steps to Reproduce:
1.emerge --pretend --update --deep world
2.
3.
Actual Results:  
See below

Expected Results:  
Was expecting a clean list of package to upgrade to deploy kde 4.7.2

These are the packages that would be merged, in order:

Calculating dependencies  ... done!

!!! All ebuilds that could satisfy ">=kde-base/kdelibs-4.7.2:4[aqua=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-4.7.2::gentoo (masked by: ~amd64 keyword)

(dependency required by "kde-base/kdialog-4.7.2" [ebuild])
(dependency required by "kde-base/kdebase-meta-4.7.2" [ebuild])
(dependency required by "kde-base/kde-meta-4.7.2" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 1 Andreas K. Hüttel gentoo-dev 2011-10-31 20:51:20 UTC
I guess you should sync your tree and try again :) 
kdelibs-4.7.2-r1 is now there (and in the list)