Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 385513

Summary: dev-db/{mysql,mariadb}: convert to multilib
Product: Gentoo Linux Reporter: 颜烈彬 <slbyan>
Component: [OLD] DevelopmentAssignee: Gentoo Linux MySQL bugs team <mysql-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: binki, chewi
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 488418    
Bug Blocks: 454644, 511888, 498010    
Attachments: build.log.gz

Description 颜烈彬 2011-10-03 14:27:16 UTC
it is fine to compile amd64-ABI for dev-db/mariadb, but not for x86-ABI.


Reproducible: Always

Steps to Reproduce:
1. emerge -1v dev-db/mariadb
2.
3.
Actual Results:  
It failed on compiling x86-ABI, with error:
ma_search.c:872:6: error: conflicting types for '_ma_dpointer'
maria_def.h:937:13: note: previous declaration of '_ma_dpointer' was here
make[3]: *** [libmaria_common_la-ma_search.lo] Error 1
make[3]: *** Waiting for unfinished jobs....

Expected Results:  
compile successfully.

Portage 2.2.0_alpha55-r1 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_350_@_2.27GHz-with-gentoo-2.1
Timestamp of tree: Mon, 03 Oct 2011 07:15:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x11 xemacs proaudio sunrise gnome kde science gentoo-zh qting-edge enlightenment multilib hardened-dev
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10 AdobeFlash-10.1 DOOM3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=native -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -mtune=native -march=native"
DISTDIR="/opt/distfiles/"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en zh en_GB en_US zh_CN zh_HK zh_TW"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/xemacs /var/lib/layman/pro-audio /var/lib/layman/sunrise /var/lib/layman/gnome /var/lib/layman/kde /var/lib/layman/science /var/lib/layman/gentoo-zh /var/lib/layman/qting-edge /var/lib/layman/enlightenment /var/lib/layman/multilib /var/lib/layman/hardened-development"
SYNC="rsync://mirrors.163.com/gentoo-portage"
USE="PyQt X a52 aac aalib accessibility acl acpi ada agg alsa amd64 amr apache2 apm arpack audiofile avahi bittorrent branding bzip2 cairo calendar cdio chm cjk cli clisp consolekit cracklib crypt cscope cue cups custom-optimization cvs cvsgraph cxx dbus devkit dirac djvu doxygen dri ebook edje encode enscript espeak exif expat faac faad fbcon ffmpeg fftw flac fltk fluidsynth fortran frei0r ftp gallium gd gdbm gif git glitz glpk gmp gnat gnutls gpm graphite gsm gstreamer hardened hvm iconv icu imlib iproute2 ipv6 joystick jpeg jpeg2k kde kernel-patch lame lastfmradio latex lcms libg++ libmms libnotify libsamplerate libwww lzma lzo mad midi mikmod mjpeg mmx mng mod_python modperl modplug modules mp3 mpeg mplayer mudflap multilib multimedia musepack mysql ncurses nepomuk network nls nptl nptlonly nsplugin nvidia odbc ogg openal opengl openmp openvg pam pcre perl pipe plugin_stardict png poliykit polkitqt portaudio ppp pppd private-headers pulseaudio pvr pygments python qt4 quicktime readline realtime redeyes ree18 rtmp ruby savedconfig schroedinger sdl semantic-desktop session socks5 speex spell sql sqlite sse sse2 sse4 ssl ssse3 subversion svg synaptics sysfs tcpd theora threads tiff trace truetype unicode usb v4l2 vaapi vdpau vhosts vorbis x264 xanim xattr xcb xcomposite xetex xine xinerama xml xorg xv xvid xvmc xz zh zh_CN zh_TW zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en zh en_GB en_US zh_CN zh_HK zh_TW" MULTILIB_ABIS="amd64 x86" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64 ppc64" QEMU_USER_TARGETS="i386 x86_64 ppc64" RUBY_TARGETS="ruby18 ree18" USERLAND="GNU" VIDEO_CARDS="v4l2 nvidia intel vesa fbdev nouveau" XTABLES_ADDONS="cui gfw zhang" multilib_abi="amd64 x86"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-db/mariadb-5.1.50 was built with the following:
USE="community perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -libevent -max-idx-128 -minimal -pbxt -profiling (-selinux) -static -test" MULTILIB_ABI="(amd64) (-x86)"
CFLAGS="-O2 -pipe -mtune=native -DHAVE_ERRNO_AS_DEFINE=1 -fno-strict-aliasing"
CXXFLAGS="-O2 -pipe -mtune=native -DHAVE_ERRNO_AS_DEFINE=1 -fno-exceptions -fno-strict-aliasing -felide-constructors -fno-rtti -fno-implicit-templates -fno-strict-aliasing"
Comment 1 颜烈彬 2011-10-04 14:40:38 UTC
Created attachment 288769 [details]
build.log.gz
Comment 2 颜烈彬 2011-10-05 16:42:20 UTC
some functions defined in storage/maria/maria_def.h don't match their implements in parameters' types, such as _ma_dpointer and _ma_read_cache.
In 32-ABI my_off_t is different from MARIA_RECORD_POS.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-10-30 02:11:46 UTC
At this point this is in the bottom of my priorities for mysql.
In any case, please test with the latest mariadb versions (5.1.55 or preferably 5.2.9). If you still can't use portage-multilib with it, I suggest you open an upstream bug and link it here.
Comment 4 颜烈彬 2011-10-30 04:20:27 UTC
(In reply to comment #3)
> At this point this is in the bottom of my priorities for mysql.
> In any case, please test with the latest mariadb versions (5.1.55 or preferably
> 5.2.9). If you still can't use portage-multilib with it, I suggest you open an
> upstream bug and link it here.

The bug affects both 5.1.55 and 5.2.9 too.
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-10-08 02:48:44 UTC
(In reply to 颜烈彬 from comment #4)
> (In reply to comment #3)
> > At this point this is in the bottom of my priorities for mysql.
> > In any case, please test with the latest mariadb versions (5.1.55 or preferably
> > 5.2.9). If you still can't use portage-multilib with it, I suggest you open an
> > upstream bug and link it here.
> 
> The bug affects both 5.1.55 and 5.2.9 too.

Brian,

since you were working on the cmake-multilib eclass, this bug might interest you. Although you'll likely only care about mariadb-5.5.
Comment 6 Brian Evans Gentoo Infrastructure gentoo-dev 2014-04-01 16:45:05 UTC
I have a working prototype of the mysql-multilib eclass in the overlay.

This also incorporates EAPI 5 features as well.  This is the reason why mysql-v2 eclass is not suitable as is.
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-19 16:28:54 UTC
dev-db/mariadb-10.0.13 is in the tree as multilib.  other providers to soon follow.
Comment 8 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-31 22:19:59 UTC
Done with virtual/mysql-5.6-r2