Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 380623

Summary: Can't assign/use any alt + shift shortcut combinations, KDE 4.7.0 and Qt 4.7.3
Product: Gentoo Linux Reporter: Stefan Fuchs <stefan.ev.fuchs>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: facorread, qt
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 388279    

Description Stefan Fuchs 2011-08-25 11:16:36 UTC
When I try to to use a shortcut like alt + shift + f12 to enable/disable desktop effects nothing happens. When I try to set the shortcut the above sequence (which is already there) in System Settings > Desktop Effects > General, a window pops up saying "Unsupported Key - The key you just pressed is not supported by Qt."

Reproducible: Always

Steps to Reproduce:
1. Assign any sequence starting with alt + shift or shift + alt
Actual Results:  
Error Message.

Expected Results:  
Should assign shortcut.

Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.3 x86_64)
=================================================================
System uname: Linux-3.0.3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9550_@_2.66GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 25 Aug 2011 00:45:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo science
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.iinet.net.au/pub/Gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/opt/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 apache2 avahi bash-completion berkdb bzip2 cairo cdr cli cracklib crypt cups cxx dbus dri dvd ffmpeg fortran gdbm gpm handbook hddtemp iconv icu ieee1394 ipv6 jpeg kde kipi kontact laptop lm_sensors lzma mad midi mmx mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin opengl openmp pam pcre pdf perl php png policykit pppd python qt3support qt4 readline session spell sql sse sse2 ssl svg symlink sysfs tcpd threads truetype udev unicode vorbis webkit wifi xcomposite xine xml xorg zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_basic auth_digest dav rewrite" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andreas K. Hüttel gentoo-dev 2011-08-27 21:48:25 UTC
Which exact kde and qt versions do you use?
Comment 2 Stefan Fuchs 2011-08-28 03:00:25 UTC
KDE 4.7.0
Qt 4.7.3
Comment 3 Andreas K. Hüttel gentoo-dev 2011-09-26 21:47:22 UTC
"Unsupported Key - The key you just pressed is not supported by Qt."

@qt - any clue?
Comment 4 Andreas K. Hüttel gentoo-dev 2011-10-25 19:57:28 UTC
Do you still see this problem with kde 4.7.2 ?
Comment 5 Davide Pesavento gentoo-dev 2011-10-25 20:05:16 UTC
(In reply to comment #3)
> "Unsupported Key - The key you just pressed is not supported by Qt."
> 
> @qt - any clue?

I have no idea honestly. And I can't reproduce the issue.
Comment 6 Stefan Fuchs 2011-10-25 23:33:21 UTC
(In reply to comment #4)
> Do you still see this problem with kde 4.7.2 ?

No, the issue disappeared. Thank you guys :-)
Comment 7 Andreas K. Hüttel gentoo-dev 2011-10-28 17:48:06 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > Do you still see this problem with kde 4.7.2 ?
> 
> No, the issue disappeared. Thank you guys :-)

Excellent. :)