Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 373613

Summary: app-admin/eselect broken for eselect modules which rely on skel.bash (such as blas, cblas, lapack)
Product: Gentoo Hosted Projects Reporter: Jacob Middag <marienberg>
Component: eselectAssignee: Gentoo eselect Team <eselect>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom, gabemarcano, v_2e, zerochaos
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Jacob Middag 2011-06-30 16:30:19 UTC
When using eselect with the module blas, cblas or lapack, it does not output anything. At the forums this problem is reported. See http://forums.gentoo.org/viewtopic-t-883505.html for more information

After some debugging I found the problem. The function list_libdirs in libs/multlib.bash uses ld.so.conf to check the library dirs. In my configuration no environment file uses /lib64 (they use /lib), so it gets excluded. But in the /etc/env.d/{blas,cblas,lapack}/ the directory is named lib64.

Workaround is to create /etc/env.d/99fix-eselect and to with contents:[code]LDPATH="/lib64"[/code]

Reproducible: Always

Steps to Reproduce:
1.eselect blas list

Always reproducable.


Expected Results:  
Installed BLAS for library directory lib64
  [1]   reference *
Comment 1 Ulrich Müller gentoo-dev 2011-07-01 06:17:32 UTC
"emerge --info" please.
What is the output of "ls -ld /lib /lib32 /lib64"?
Comment 2 Jacob Middag 2011-07-01 08:05:06 UTC
[emerge --info]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.25-r2
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.65-r1
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo local layman
Installed sets: @kdeartwork-4.6, @kdebase-4.6, @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.tiscali.nl/ ftp://gentoo.tiscali.nl/pub/mirror/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US en_GB nl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
Portage 2.2.0_alpha41 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-x86_64-AMD_Phenom-tm-_II_X4_940_Processor-with-gentoo-2.0.2
Timestamp of tree: Wed, 29 Jun 2011 10:15:01 +0000
ccache version 2.4 [disabled]
USE="3dnow 3dnowext 64bit X a52 aac acl acpi alsa amd64 bash-completion berkdb bitmap-fonts blas bluetooth bmp branding bzip2 cairo caps cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fbcon ffmpeg firefox flac fortran gcj gd gdbm gdu gif gpm gstreamer iconv ieee1394 imagemagick ipv6 java java6 jpeg kde kipi kpathsea lame lapack latex lcms libnotify lm_sensors logrotate mad matroska mmx mng modules moonlight mozdevelop mp3 mp4 mpeg mudflap multilib musepack ncurses nls nptl nptlonly nsplugin ogg ogm opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd python python3 qt3 qt3support qt4 readline samba sdl semantic-desktop session sox spell sqlite sqlite3 srt sse sse2 sse3 sse4a ssl startup-notification svg sysfs tcpd theora threads tiff truetype truetype-fonts type1-fonts udev umfpack unicode usb vim vim-syntax vorbis wav webkit x264 xcb xcomposite xetex xine xinerama xinetd xml xorg xscreensaver xulrunner xv xvid zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US en_GB nl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeonhd radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



[ls -ld /lib /lib32 /lib64]
lrwxrwxrwx  1 root root     5 May 20 11:14 /lib -> lib64
drwxr-xr-x  3 root root  4096 Jun 30 12:44 /lib32
drwxr-xr-x 15 root root 12288 Jun 30 12:59 /lib64
Comment 3 Ulrich Müller gentoo-dev 2011-07-02 06:17:38 UTC
Looks like a normal setup for a multilib profile to me. Eselect will ignore /lib because it is a symlink to /lib64.

What is the contents of /etc/env.d/04multilib?
Comment 4 Jacob Middag 2011-07-04 12:04:13 UTC
[/etc/env.d/04multilib]
LDPATH="/lib32:/usr/lib32:/usr/local/lib32:/lib:/usr/lib:/usr/local/lib"
Comment 5 Rick Farina (Zero_Chaos) gentoo-dev 2015-10-05 20:14:02 UTC
bump, this appears to still be valid, a mere 4 years later.
Comment 6 Larry the Git Cow gentoo-dev 2019-06-26 06:07:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f8a985b71b033d7a7c4d252c00dd83669ee5913

commit 5f8a985b71b033d7a7c4d252c00dd83669ee5913
Author:     Mo Zhou <cdluminate@gmail.com>
AuthorDate: 2019-06-26 02:27:40 +0000
Commit:     Benda Xu <heroxbd@gentoo.org>
CommitDate: 2019-06-26 06:06:09 +0000

    virtual/{blas,cblas,lapack,lapacke}: add/update virtual packages.
    
      These virtual packages are used by the BLAS/LAPACK runtime switching
      mechanism.
    
      Drop old EAPI=5 ebuilds.
    
    Closes: https://github.com/gentoo/gentoo/pull/12323
    Closes: https://bugs.gentoo.org/373613
    Closes: https://bugs.gentoo.org/669644
    Closes: https://bugs.gentoo.org/564546
    Closes: https://bugs.gentoo.org/565776
    Closes: https://bugs.gentoo.org/646316
    Closes: https://bugs.gentoo.org/563674
    Closes: https://bugs.gentoo.org/659014
    Closes: https://bugs.gentoo.org/659264
    Closes: https://bugs.gentoo.org/657984
    Closes: https://bugs.gentoo.org/381801
    Closes: https://bugs.gentoo.org/646316
    Closes: https://bugs.gentoo.org/565776
    Closes: https://bugs.gentoo.org/498490
    
    Signed-off-by: Mo Zhou <cdluminate@gmail.com>
    Signed-off-by: Benda Xu <heroxbd@gentoo.org>

 virtual/blas/blas-1.0.ebuild       | 14 --------------
 virtual/blas/blas-3.8.ebuild       | 14 ++++++++++++++
 virtual/blas/metadata.xml          | 10 +++++++---
 virtual/cblas/cblas-1.0.ebuild     | 14 --------------
 virtual/cblas/cblas-3.8.ebuild     | 14 ++++++++++++++
 virtual/cblas/metadata.xml         | 10 +++++++---
 virtual/lapack/lapack-3.0.ebuild   | 13 -------------
 virtual/lapack/lapack-3.1.ebuild   | 13 -------------
 virtual/lapack/lapack-3.8.ebuild   | 14 ++++++++++++++
 virtual/lapack/metadata.xml        | 10 +++++++---
 virtual/lapacke/lapacke-3.8.ebuild | 14 ++++++++++++++
 virtual/lapacke/metadata.xml       | 16 ++++++++++++++++
 12 files changed, 93 insertions(+), 63 deletions(-)
Comment 7 Larry the Git Cow gentoo-dev 2019-07-03 12:34:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0721aba4db4bc8ce37d11eab06ff528f31e4ce9f

commit 0721aba4db4bc8ce37d11eab06ff528f31e4ce9f
Author:     Benda Xu <heroxbd@gentoo.org>
AuthorDate: 2019-06-27 05:41:31 +0000
Commit:     Benda Xu <heroxbd@gentoo.org>
CommitDate: 2019-07-03 12:30:39 +0000

    virtual/{blas,cblas,lapack,lapacke}: add virtual packages.
    
      These virtual packages are used by the BLAS/LAPACK runtime switching
      mechanism.
    
    Closes: https://github.com/gentoo/gentoo/pull/12323
    Closes: https://bugs.gentoo.org/373613
    Closes: https://bugs.gentoo.org/381801
    Closes: https://bugs.gentoo.org/498490
    Closes: https://bugs.gentoo.org/563674
    Closes: https://bugs.gentoo.org/564546
    Closes: https://bugs.gentoo.org/565776
    Closes: https://bugs.gentoo.org/646316
    Closes: https://bugs.gentoo.org/657984
    Closes: https://bugs.gentoo.org/659014
    Closes: https://bugs.gentoo.org/659264
    Closes: https://bugs.gentoo.org/669644
    
    Signed-off-by: Mo Zhou <cdluminate@gmail.com>
    Signed-off-by: Benda Xu <heroxbd@gentoo.org>

 virtual/blas/blas-3.8.ebuild       | 14 ++++++++++++++
 virtual/blas/metadata.xml          | 10 +++++++---
 virtual/cblas/cblas-3.8.ebuild     | 14 ++++++++++++++
 virtual/cblas/metadata.xml         | 10 +++++++---
 virtual/lapack/lapack-3.8.ebuild   | 14 ++++++++++++++
 virtual/lapack/metadata.xml        | 10 +++++++---
 virtual/lapacke/lapacke-3.8.ebuild | 14 ++++++++++++++
 virtual/lapacke/metadata.xml       | 16 ++++++++++++++++
 8 files changed, 93 insertions(+), 9 deletions(-)