Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 304895

Summary: kde-base/kmail-4.4.5: "nepomuk indexing agents have been disabled" error message every time I run it
Product: Gentoo Linux Reporter: PM <mitaspiotr>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: ag+services, anarsoul, donmartio, esigra, nikoli, vincent
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 313999    
Attachments: backtrace1
backtrace2
backtrace3
backtrace4
backtrace5
report file

Description PM 2010-02-13 16:21:36 UTC
Every time I run kmail for the first time in current session, I get this error:

Nepomuk Indexing Agents Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Therefore indexing of all data stored in the Akonadi PIM service has been disabled, which will severely limit the capabilities of any application using this data.

The following problems were detected:
Unable to start the Nepomuk server.
Nepomuk is not running.
Additional help can be found here: userbase.kde.org/Akonadi

Then it continues to work normally, but it's pretty much annoying.

Reproducible: Always




Portage 2.2_rc62 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo-r5 x86_64)
=================================================================                                     
System uname: Linux-2.6.32-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7400_@_2.80GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 12 Feb 2010 18:30:01 +0000                                                      
app-shells/bash:     4.0_p37                                                                            
dev-java/java-config: 2.1.10                                                                            
dev-lang/python:     2.6.4-r1, 3.1.1-r1                                                                 
dev-util/cmake:      2.8.0-r2                                                                           
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.6.0-r1                                                                           
sys-apps/sandbox:    2.2                                                                                
sys-devel/autoconf:  2.13, 2.65                                                                         
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1                                                 
sys-devel/binutils:  2.20                                                                               
sys-devel/gcc:       4.4.3                                                                              
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6b                                                                             
virtual/os-headers:  2.6.30-r1                                                                          
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                          
ACCEPT_LICENSE="* -@EULA dlj-1.1 Nero-EULA-US PUEL"                                                     
CBUILD="x86_64-pc-linux-gnu"                                                                            
CFLAGS="-O2 -march=core2 -msse3 -mssse3 -msse4.1 -pipe -g"                                              
CHOST="x86_64-pc-linux-gnu"                                                                             
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -msse3 -mssse3 -msse4.1 -pipe -g"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-sunset /usr/local/portage/moje"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib acl acpi alsa amd64 amr amrnb amrwb async audiofile automount bash-completion berkdb branding bzip2 cairo cdda cddb cdio cdparanoia cdr chdir cli consolekit cracklib crypt css cuda cups curl cxx dbus dirac disk-partition divx djvu dri dts dvd dvdr editor eds emboss emovix encode evo exchange exif faac faad fam fat ffmpeg fftw firefox firefox3 flac fontconfig fortran gd gdbm geoip gif glitz gmedia gphoto2 gpm gstreamer gtk hal hddtemp iconv id3 id3tag imagemagick inotify ipod jpeg kde kde4 kdehiddenvisibility kipi kompare kpathsea kqemu ladspa lame laptop lastfm latex libcaca libnotify libsamplerate lm_sensors mad midi mikmod mjpeg mmap mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin ntfs ogg openal opencore-amr opengl openmp optimized-qmake pam pch pcre pdf perl plasma png policykit ppds pppd python qt3 qt3support qt4 quicktime readline realmedia reflection roe sasl scanner schroedinger sdl sensord session slang sndfile solver soundtouch sourceview spell spl sse sse2 sse3 sse4a ssl ssse3 startup-notification suid svg swat symlink sysfs syslog tcpd theora threads thunar tiff truetype unicode upnp usb vamp vcd vdpau vorbis webkit wmf wmp wxwidgets wxwindows x264 xcb xcomposite xine xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Franz Trischberger 2010-02-14 12:57:02 UTC
Did you change to soprano-backend?
In ~/.kde4/share/config/nepomukserverrc
Change the sesame2 Backend to

Used Soprano Backend=virtuosobackend

And stop nepomuk (best would be to logout and login again).
Comment 2 PM 2010-02-15 14:17:10 UTC
I did that, then killed everything with nepomuk in it's name and started kmail. I got the same error message plus four "Akondai Resource" crash dialogs and one "Akondai Agent" crash dialog. I'll attach the backtraces.
Comment 3 PM 2010-02-15 14:20:46 UTC
Also when I was closing those dialogs, more of them were popping up, there was about 15 of them...
Comment 4 PM 2010-02-15 14:21:09 UTC
Created attachment 219783 [details]
backtrace1
Comment 5 PM 2010-02-15 14:21:24 UTC
Created attachment 219785 [details]
backtrace2
Comment 6 PM 2010-02-15 14:21:40 UTC
Created attachment 219787 [details]
backtrace3
Comment 7 PM 2010-02-15 14:21:53 UTC
Created attachment 219789 [details]
backtrace4
Comment 8 PM 2010-02-15 14:22:07 UTC
Created attachment 219791 [details]
backtrace5
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2010-02-17 10:17:30 UTC
And kdepim-runtime is installed?
Comment 10 PM 2010-02-17 11:05:23 UTC
Yes.
Comment 11 PM 2010-02-23 06:33:47 UTC
Now all of a sudden I started getting the following window instead of the previous error: http://img687.imageshack.us/img687/1728/plasmadesktopmy2119.jpg

After clicking "Close" kmail quits.

I'll attach the report file.
Comment 12 PM 2010-02-23 06:34:16 UTC
Created attachment 220795 [details]
report file
Comment 13 Vasily 2010-02-24 11:44:17 UTC
I'm hitting same bug, 
Soprano Backend is virtuosobackend.
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2010-04-09 06:18:56 UTC
Does this still happen on kde 4.4.2?
Comment 15 PM 2010-04-09 11:07:32 UTC
Yes.
Comment 16 Vicente Olivert Riera (RETIRED) gentoo-dev 2010-06-11 14:55:35 UTC
(In reply to comment #15)
> Yes.
> 

Does this still happen on kde 4.4.4?
Comment 17 Geoff Madden 2010-07-26 05:10:53 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > Yes.
> > 
> 
> Does this still happen on kde 4.4.4?
> 

yes still in 4.4.5, and the cure was to change the backend to virtuoso as previously noted, my error was a bit different in that nepomuk was complaining about the sesame2 db not available.
Comment 18 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-13 00:26:58 UTC
sesame2 is not a supported soprano backend any more, and i removed it from >=soprano-2.5.2
I'll close this bug, please reopen if you hit it again with virtuoso backend (as it is the only supported backend)