Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 304695

Summary: =kde-base/kontact-4.4.* should depend on nepomuk
Product: Gentoo Linux Reporter: Aleister <maxtaager>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom, esigra
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 313999    

Description Aleister 2010-02-12 08:50:54 UTC
was trying to run kontact which depends on akonadi (but also takes some use of the new virtuoso backend).

Reproducible: Always

Steps to Reproduce:
1.install akonadi with -semantic-desktop in make.conf (override it for kdelibs).
2.run akonadictl start
3.it fails

Actual Results:  
kontact                                  
kontact(6469)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from  "/var/tmp/kdecache-max/ksycoca4"
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Loading Plugin: "Mail"                                      
Calling appendChild() on a null node does nothing.                                                                         
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: LIBNAMEPART: "kmailpart"                                    
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Loading Plugin: "Notebooks"                                 
Calling appendChild() on a null node does nothing.                                                                         
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: LIBNAMEPART: "kjotspart"                                    
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Loading Plugin: "Feeds"                                     
Calling appendChild() on a null node does nothing.                                                                         
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: LIBNAMEPART: "akregatorpart"                                
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Loading Plugin: "Summary"                                   
Calling appendChild() on a null node does nothing.                                                                         
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: LIBNAMEPART: ""                                             
kontact(6469)/kontact (core) Kontact::MainWindow::addPlugin:                                                               
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Plugging New actions "new_mail"                             
kontact(6469)/kontact (core) Kontact::MainWindow::addPlugin:                                                               
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Plugging New actions "feed_new"                             
kontact(6469)/kontact (core) Kontact::MainWindow::addPlugin:                                                               
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Plugging New actions "new_kjots_page"                       
kontact(6469)/kontact (core) Kontact::MainWindow::loadPlugins: Plugging New actions "new_kjots_book"                       
kontact(6469)/kontact (core) Kontact::MainWindow::addPlugin:                                                               
kontact(6469)/kutils (KSettings::Dispatcher) KSettings::Dispatcher::registerComponent: "kontact"                           
kontact(6469)/kontact (interfaces) KontactInterface::Core::createPart: kmailpart                                           
kontact(6469)/kontact (interfaces) KontactInterface::Core::createPart: Creating new KPart                                  
kontact(6469)/kontact (interfaces) KontactInterface::Core::createPart: "/usr/lib64/kde4/kmailpart.so"                      
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)                     
kontact(6469)/kdepimlibs (mailtransport) MailTransport::TransportManagerPrivate::fillTypes: Have SMTP, Sendmail, and 0 Akonadi types.
kontact(6469)/kdepimlibs (mailtransport) MailTransport::Transport::Transport: "1499431382"                                           
kontact(6469)/kdepimlibs (mailtransport) MailTransport::Transport::usrReadConfig: type 0                                             
kontact(6469)/kdeui (Wallet) KWalletDLauncher::getInterface: The kwalletd service has been registered                                
"/usr/bin/kontact(6469)" Error in thread 139755410560832 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"                                                                                                                          
kontact(6469)/nepomuk (library) <unnamed>::GlobalModelContainer::init: Connecting to local socket "/home/max/.kde4/share/apps/nepomuk/socket"                
"/usr/bin/kontact(6469)" Error in thread 139755410560832 : "QLocalSocket::connectToServer: Invalid name"                                                     
QMutex::unlock: mutex lock failure:

Expected Results:  
kontact should work :-)

after installing nepomuk byhand it works :-)

emerge --info
Portage 2.1.7.16 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-tuxonice-r1 x86_64)
=================================================================                                 
System uname: Linux-2.6.32-tuxonice-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 10 Feb 2010 01:45:01 +0000                                                        
distcc 3.1 x86_64-pc-linux-gnu [enabled]                                                                  
ccache version 2.4 [disabled]                                                                             
app-shells/bash:     4.0_p35                                                                              
dev-java/java-config: 2.1.10                                                                              
dev-lang/python:     2.6.4                                                                                
dev-util/ccache:     2.4-r7                                                                               
dev-util/cmake:      2.6.4-r3                                                                             
sys-apps/baselayout: 2.0.1                                                                                
sys-apps/openrc:     0.6.0-r1                                                                             
sys-apps/sandbox:    1.6-r2                                                                               
sys-devel/autoconf:  2.13, 2.63-r1                                                                        
sys-devel/automake:  1.9.6-r2, 1.10.2                                                                     
sys-devel/binutils:  2.18-r3                                                                              
sys-devel/gcc:       4.3.4                                                                                
sys-devel/gcc-config: 1.4.1                                                                               
sys-devel/libtool:   2.2.6b                                                                               
virtual/os-headers:  2.6.27-r2                                                                            
ACCEPT_KEYWORDS="amd64"                                                                                   
ACCEPT_LICENSE="*"                                                                                        
CBUILD="x86_64-pc-linux-gnu"                                                                              
CFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf"                                                             
CHOST="x86_64-pc-linux-gnu"                                                                               
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                                                
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"                                                                                   
CXXFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf"                                                                                                              
DISTDIR="/usr/net_portage"                                                                                                                                   
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs 3 --load-average 6"                                                                                               
FEATURES="assume-digests binpkgs distcc distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"                                                                                                                                       
GENTOO_MIRRORS="http://gentoo.tiscali.nl/"                                                                                                                   
LDFLAGS="-Wl,--as-needed -Wl,--hash-style=gnu"                                                                                                               
LINGUAS="en_GB"                                                                                                                                              
MAKEOPTS="-j6"                                                                                                                                               
PKGDIR="/usr/net_portage/packages"                                                                                                                           
PORTAGE_CONFIGROOT="/"                                                                                                                                       
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                                            
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://192.168.0.1/gentoo-portage"
USE="X acl alsa amd64 bash-completion berkdb bluetooth bzip2 cli cracklib crypt cxx dbus dri fortran gdbm gpm hal iconv kde lzma minimal mmx mmxext mng modules mudflap multilib ncurses nls nptl nptlonly nsplugin opengl openmp pam pcre pppd qt3support qt4 readline reflection session spl sse sse2 ssl ssse3 sysfs tcpd threads unicode usb vim-syntax vorbis xcb xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-02-17 20:00:59 UTC
(In reply to comment #0)
> QMutex::unlock: mutex lock failure:
> 
> Expected Results:  
> kontact should work :-)

The mutex local failure was fixed with soprano-2.4.0.1...
Comment 2 Aleister 2010-02-17 22:02:04 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > QMutex::unlock: mutex lock failure:
> > 
> > Expected Results:  
> > kontact should work :-)
> 
> The mutex local failure was fixed with soprano-2.4.0.1...
> 

i dont think that was the problem because how could kontact get a lock on something that dosent exists Connecting to local socket "/home/max/.kde4/share/apps/nepomuk/socket" because of lacking nepomuk?
as i understand it kdepim needs nepomuk (so it can put stuff in the virtuoso database)if this is optional it could be fixed with a useflag etc. But before we go down this road. Somebody should figure out if nepomuk is really needed or is optional for kde-pim (or some parts of it).
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-02-17 22:12:25 UTC
I think it should be $(add_kdebase_dep kdepim-runtime) in RDEPEND, same as kmail

reavertm, can you check?
Comment 4 Maciej Mrozowski gentoo-dev 2010-06-05 14:45:28 UTC
Fixed, thanks for reporting and to all involved!
Yes, kdepim-runtime is the way to go.