Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 283273

Summary: www-servers/tomcat-6.0.20-r1: examples are not compiled
Product: Gentoo Linux Reporter: Krzysztof Magusiak <chrmag>
Component: [OLD] UnspecifiedAssignee: Mike Weissman <mike>
Status: RESOLVED FIXED    
Severity: minor CC: g2t, java, m1k0
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 428002    
Bug Blocks: 322979    
Attachments: ant script to build the examples

Description Krzysztof Magusiak 2009-08-30 19:28:22 UTC
After installing tomcat with examples, TOMCAT_BASE/webapps/examples/WEB-INF/classes contains only source files (*.java). These files must be compiled to make the examples work.

Reproducible: Always

Steps to Reproduce:
1. USE="examples" emerge -av tomcat
2. Browse: http://localhost:8080/examples
Actual Results:  
Before the compilation, resource unavailble page is shown.

Expected Results:  
Examples should work out of the box.
Comment 1 Krzysztof Magusiak 2009-08-30 19:30:15 UTC
Created attachment 202738 [details]
ant script to build the examples

To compile, put this file in TOMCAT_BASE/webapps/examples/WEB-INF and run ant.
Comment 2 William L. Thomson Jr. 2011-02-15 02:51:35 UTC
Duplicate of bug 282071 which has a bad summary, this bug has a much better summary, and I will look into resolving this ASAP time permitting.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-02-23 18:56:29 UTC
*** Bug 282071 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Kohler 2011-03-04 21:23:18 UTC
Same here, but solution above don't bring me the examples page. I had copied the build.xml in /var/lib/tomcat-6/webapps/examples/WEB-INF go into that directory and start ant. Message was: BUILD SUCCESSFUL. Than restart tomcat server.

Same with using below the "/usr/share/tomcat-6/" directory.

I'm using the "www-servers/tomcat-6.0.32-r1".

------- the page show me that content: --------
HTTP Status 404 -
type Status report
message
description The requested resource () is not available.
Apache Tomcat/6.0.32
Comment 5 Ralph Sennhauser (RETIRED) gentoo-dev 2012-12-07 16:35:16 UTC
Using the new ebuilds the setup is done differently. See https://wiki.gentoo.org/wiki/Apache_Tomcat for more info. If you build tomcat with USE=extra-webapps, deployed instances will have the examples up and running.

Thanks for the report.