Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 276377

Summary: <=kde-base/kmail-4.4.0 fails to compile with -j > 1: dependency issue in generated makefiles
Product: Gentoo Linux Reporter: Tanktalus
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal Flags: tampakrap: Bugday-
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=198807
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 313999    

Description Tanktalus 2009-07-03 15:27:08 UTC
According to ABCD in IRC, I'm filing this.

Basically, kmail failed to compile giving:

make[2]: *** No rule to make target `kmail/org.kde.kmail.kmail.xml', needed by `kontact/plugins/kmail/kmailinterface.cpp'.  Stop.

When I add "-j1" to the MAKEOPTS in /etc/portage/env/kde-base/kmail, kmail completes successfully.  Ideally, the dependencies would get fixed upstream, but, in the meantime, adding "-j1" to the make command in kmail may be sufficient.

Reproducible: Always
Comment 1 Jonathan Callen (RETIRED) gentoo-dev 2009-07-03 15:47:14 UTC
There is a temporary fix (-j1) in the ebuild, and a bug has been filed upstream at <https://bugs.kde.org/show_bug.cgi?id=198807>.
Comment 2 Tanktalus 2009-11-23 17:22:00 UTC
I took out the -j1 option from my kmail-4.3.3 ebuild, and rebuilt it.  It rebuilt fine.  It looks like upstream did fix this bug between 4.2.95 and 4.3.3.

Thanks :-)

(I'd mark this bug fixed, but I think that we should now be able to remove the -j1 flag before closing it.)
Comment 3 Jonathan Callen (RETIRED) gentoo-dev 2009-11-23 17:37:31 UTC
I just checked, and it still can fail with current trunk (that doesn't mean it will always fail, or even will usually fail, but it *can* fail due to underspecified dependencies).
Comment 4 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-11-25 13:03:05 UTC
If this is only a compile problem, we can add an ewarn in the ebuild. But this can be done if this is only a compile problem, not if it also causes any runtime issues. Kmail takes a long time to compile now, so i guess it would be the best option atm, since upstream doesn't seem to care that much about this
Comment 5 Jonathan Callen (RETIRED) gentoo-dev 2009-11-25 19:52:15 UTC
As far as I can tell, it's a compile-time only issue.  The main problem is that if make tries to build certain files in kontact/plugins/kmail/ before other files in kmail/, it fails (and there is no way that I am aware of to create the proper dependencies in cmake, unfortunately).
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2010-04-20 21:21:02 UTC
Seems to work fine with my -j9 on kde 4.4.2. 
But then, this is a non-deterministic bug class... :)
Comment 7 Jonathan Callen (RETIRED) gentoo-dev 2010-04-20 23:20:56 UTC
(In reply to comment #6)
> Seems to work fine with my -j9 on kde 4.4.2. 
> But then, this is a non-deterministic bug class... :)
> 

Did you edit the ebuild to remove the "-j1" bit - otherwise, you *didn't* test with -j9. (I think this may have been fixed for 4.5, but I haven't actually checked yet)
Comment 8 Andreas K. Hüttel archtester gentoo-dev 2010-05-01 17:45:27 UTC
(In reply to comment #7)
> Did you edit the ebuild to remove the "-j1" bit - otherwise, you *didn't* test
> with -j9. (I think this may have been fixed for 4.5, but I haven't actually
> checked yet)

In the beginning, no. Now I did it...

Worked fine for kmail-4.4.2 two times in a row with -j9
(and top really displayed the concurrent compilers... :)

Comment 9 Andreas K. Hüttel archtester gentoo-dev 2010-06-04 19:29:44 UTC
I commented out the "-j1" lines in the ebuild for 4.4.4. When this moves to the tree, we'll get some more testing...
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2010-06-07 18:55:36 UTC
Nobody screaming so let's assume this is fixed.