Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 275802

Summary: fltk 2.0_pre6786 gcc4.4
Product: Gentoo Linux Reporter: Christoph Brill (egore) (RESIGNED) <egore>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: minor CC: esigra
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 249226    
Attachments: fltk-2.0_pre6786-gcc44.patch

Description Christoph Brill (egore) (RESIGNED) 2009-06-29 10:16:01 UTC
I tried to build fltk on amd64 and it failed with the following error.

filename_list.cxx: In function »int fltk::filename_list(const char*, dirent64***, int (*)(const dirent64* const*, const dirent64* const*))«:
filename_list.cxx:66: Fehler: ungültige Umwandlung von »int (*)(const void*, const void*)« in »int (*)(const dirent64**, const dirent64**)«
filename_list.cxx:66: Fehler:   Argument 4 von »int scandir64(const char*, dirent64***, int (*)(const dirent64*), int (*)(const dirent64**, const dirent64**))« wird initialisiert

The attached patch lets fltk build on gcc 4.4

Reproducible: Always

Steps to Reproduce:
Comment 1 Christoph Brill (egore) (RESIGNED) 2009-06-29 10:17:03 UTC
Created attachment 196049 [details, diff]
fltk-2.0_pre6786-gcc44.patch
Comment 2 Ben de Groot (RETIRED) gentoo-dev 2009-07-04 16:52:58 UTC

*** This bug has been marked as a duplicate of bug 270487 ***