Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 261360

Summary: dolphin does not copy all files over cifs (cp does)
Product: Gentoo Linux Reporter: Trenton D. Adams <trenton.d.adams>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED UPSTREAM    
Severity: normal CC: trenton.d.adams
Priority: High Flags: tampakrap: Bugday+
Version: unspecified   
Hardware: AMD64   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=186182
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: bug related files

Description Trenton D. Adams 2009-03-05 20:31:44 UTC
There is MAJOR potential for loss of data here if people think that all of their files were copied, and they delete the originals.

Version:            (using KDE 4.2.0)
Compiler:          sys-devel/gcc-4.1.2 
OS:                Linux
Installed from:    Gentoo Packages

Dolphin fails to copy all of my files as requested.  It tells me that some
files do not exist anymore, and then fails to copy them, though they do exist. 
Using "cp" from the command line works just fine.  I do it as the same user as
dolphin.

Source folder      : /timecapsule/backup/pre-linux/Pictures2
Destination folders: ~/photos/Pictures-{good,bad}-copy

The time capsule is mount as a cifs mount.

For example, I have a file at
/timecapsule/backup/pre-linux/Pictures2/media/2006/family/2006-11-30-17.42.36.jpg.
 Dolphin claims that it cannot copy file
/timecapsule/backup/pre-linux/Pictures2/media/2007/family/2006-11-30-17.42.36.jpg
because it does not exist.  Well, of course that file doesn't exist, because I
don't put 2006 files in the 2007 folder.  The file it claims it is trying to
copy is in the 2006 folder, not the 2007 folder.  It does this on 901 files out
of 7306..

I have generated three lists of files.  They are
1. The original list from the copy source directory.  it is called
pictures-original-copy.list
2. The good copy using "cp" from the commandline.  It is called
pictures-good-copy.list
3. The bad copy, using dolphin.  It is called pictures-bad-copy.list

Now see the output below...

trenta@tdamac ~/photos $ wc -l pictures-original-copy.list
7306 pictures-original-copy.list
trenta@tdamac ~/photos $ wc -l pictures-good-copy.list
7306 pictures-good-copy.list
trenta@tdamac ~/photos $ wc -l pictures-bad-copy.list
6405 pictures-bad-copy.list


These lists were generated using "find ./ | sort >
~/photos/pictures-original-copy.list" for easy diffing.  I will attach them
when given the option in the wizard, or after the bug is created.  I will also
attach a screen shot.

I picked the "auto skip" option, because it happened 5 or
6 times, so I figured I didn't want to click through all of them (not knowing
how many there were).



Reproducible: Always
Comment 1 Trenton D. Adams 2009-03-05 20:32:47 UTC
Created attachment 184054 [details]
bug related files

pictures-bad-copy.list
pictures-good-copy.list
pictures-original-copy.list
File does not exist.png
Comment 2 Trenton D. Adams 2009-03-05 20:33:14 UTC
I have also filed a bug in the KDE bug system...
https://bugs.kde.org/show_bug.cgi?id=186182
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-06 01:01:57 UTC
Hm i clicked on normal why it get blocker, maybe i scrolled my mouse...
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-07 23:44:00 UTC
If this is related to cifs, are you sure you're not having a problem with nls and character codes?
Is your system configured to use utf-8? Did you mount the cifs partition as utf-8?
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-07 23:57:59 UTC
I just came across the 261367 bug report. It seems it might be related and it lists a patch by KDE. Please check it
https://bugs.gentoo.org/show_bug.cgi?id=261367
Comment 6 Trenton D. Adams 2009-03-08 18:52:54 UTC
(In reply to comment #4)
> If this is related to cifs, are you sure you're not having a problem with nls
> and character codes?
> Is your system configured to use utf-8? Did you mount the cifs partition as
> utf-8?
> 

I don't think that is possible.  I think this is a dolphin only bug.

After all, this is the file that exists...
/timecapsule/backup/pre-linux/Pictures2/media/2006/family/2006-11-30-17.42.36.jpg.

This is the file that it claims it cannot find.
/timecapsule/backup/pre-linux/Pictures2/media/2007/family/2006-11-30-17.42.36.jpg

Notice that dolphin somehow translated the file to be located in the 2007 folder instead of the 2006 folder.  The file DOES NOT EXIST in the 2007 folder, so something is wrong with Dolphin to be thinking a file is supposed to be somewhere it is not.

Also, I'm not trying to open files, I'm trying to copy them.  During a copy, it should do a direct binary copy.  As for filenames having funny characters, mine don't have any, because I'm Canadian eh!!! hehe  And us Canadians, we are a very sane bunch.
Comment 7 Alex Alexander (RETIRED) gentoo-dev 2009-08-01 17:08:45 UTC
According to the KDE bug report, this only happens over cifs.

Trenton, do you have anything else new on this besides the talk you had with David at KDE's bugzilla?
Comment 8 Trenton D. Adams 2009-08-05 04:18:56 UTC
No, I can't seem to reproduce it, other than on that single CIFS mount, which is an apple timecapsule.  I can't even reproduce on another set of data, just that set of data.  And the data is fine, so I don't know what is up.

Wish I could be of more help. :(
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 01:40:25 UTC
i'll close this as upstream, i'm CC'ed in the upstream bug in case there are news. Also please reopen if you have a patch here. Thanks