Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 244947

Summary: media-libs/realcodecs-11.0.1.1056 tries to pull in media-libs/win32codecs
Product: Gentoo Linux Reporter: Mark Nowiasz <mark+gentoobugs>
Component: Current packagesAssignee: media-video herd <media-video>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bbutscheidt, chad.simmons, che, dsdale24, ec5983, f5d8fd51ed1e804c9e8d0357e8614e0493b06e96, jadamcze, jdaluz, junk_siu, patrizio.bassi, robbyjo, tetromino, voyageur, zmedico
Priority: High Keywords: InVCS
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mark Nowiasz 2008-10-30 05:38:07 UTC
media-libs/realcodecs-11.0.1.1056 tries to pull in media-libs/win32codecs which it didn't do before and which is rather pointless on amd64.

Reproducible: Always

Steps to Reproduce:
1. emerge -u media-libs/realcodecs
2.
3.

Actual Results:  
emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/win32codecs-20071007-r4[real]".
!!! One of the following packages is required to complete your request:
- media-libs/win32codecs-20071007-r4 (Change USE: +real)
(dependency required by "media-libs/realcodecs-11.0.1.1056" [ebuild])



tower ~ # emerge --info
Portage 2.2_rc12 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r2 x86_64)                                                       
=================================================================               
System uname: Linux-2.6.26-gentoo-r2-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-glibc2.2.5                                                                   
Timestamp of tree: Thu, 30 Oct 2008 04:45:01 +0000                              
ccache version 2.4 [enabled]                                                    
app-shells/bash:     3.2_p39                                                    
dev-java/java-config: 1.3.7, 2.1.6-r1                                           
dev-lang/python:     2.5.2-r8                                                   
dev-util/ccache:     2.4-r8                                                     
dev-util/cmake:      2.6.2                                                      
sys-apps/baselayout: 2.0.0                                                      
sys-apps/openrc:     0.3.0-r1                                                   
sys-apps/sandbox:    1.2.18.1-r3                                                
sys-devel/autoconf:  2.13, 2.63                                                 
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1               
sys-devel/binutils:  2.18-r4                                                    
sys-devel/gcc-config: 1.4.0-r4                                                  
sys-devel/libtool:   2.2.6a                                                     
virtual/os-headers:  2.6.27-r2                                                  
ACCEPT_KEYWORDS="amd64 ~amd64"                                                  
CBUILD="x86_64-pc-linux-gnu"                                                    
CFLAGS="-O2 -pipe"                                                              
CHOST="x86_64-pc-linux-gnu"                                                     
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                                        
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                             
CXXFLAGS="-O2 -pipe"                                                            
DISTDIR="/usr/portage/distfiles"                                                
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                         
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo "         
LANG="de_DE.UTF-8"                                                              
LC_ALL="de_DE.UTF-8"                                                            
LDFLAGS="-Wl,-O1"                                                               
LINGUAS="de"                                                                    
MAKEOPTS="-j2"                                                                  
PKGDIR="/usr/portage/packages"                                                  
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                  
PORTAGE_TMPDIR="/var/tmp"                                                       
PORTDIR="/usr/portage"                                                          
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                           
USE="3dnow X a52 aac acl acli acpi ada aim alsa amd64 apm audiofile bash-completion berkdb bluetooth branding bzip2 cairo calendar cdb cddb cdparanoia cdr clamav cli cracklib crypt css ctype cups dbus dri dv dvb dvd dvdr dvdread emacs encode exif expat fam ffmpeg flac fontconfig fortran ftp gdbm gif gimp glut gnuplot gphoto2 gpm gps graphviz hal htmlhandbook iconv icq imagemagick innodb ipv6 irc isdnlog jabber java java6 joystick jpeg jpeg2k kde lame latex lcms libnotify libwww lm_sensors logitech-mouse loop-aes maildir man mhash midi mime mmap mmx mng mp3 mpeg mplay msn mudflap multilib musepack musicbrainz mysql ncurses nls nntp nptl nptlonly nsplugin ntpl offensive ogg openexr opengl openmp pam pcre pda pdfperl png pppd python qt3 qt3support qt4 readline reflection rss scanner sdl session sox spl sqlite sse sse2 ssl startup-notification subversion suid svg sysfs syslog taglib tcpd themes theora threads tiff timidity truetype unicode usb v4l v4l2 vcd vnc vorbis wavpack webkit wmf x264 xattr xine xml xorg xosd xpn xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfileauthz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Wormo (RETIRED) gentoo-dev 2008-10-30 06:51:30 UTC
win32codecs is keyworded ~amd64; how about enabling USE=real and giving it a try?
Comment 2 Bernard Cafarelli gentoo-dev 2008-10-30 10:01:03 UTC
real USE flag is masked on amd64:

enterprise bernard # emerge -av win32codecs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/win32codecs-20071007-r4  USE="(-real*)" 0 kB

And so portage complains it cannot find the needed USE=+real win32codecs
Comment 3 Mark Nowiasz 2008-10-30 17:26:25 UTC
(In reply to comment #1)
> win32codecs is keyworded ~amd64; how about enabling USE=real and giving it a
> try?

I would love to, but as Bernard stated - it's not possible to give it a try.


Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2008-10-30 20:25:40 UTC
*** Bug 244982 has been marked as a duplicate of this bug. ***
Comment 5 Zac Medico gentoo-dev 2008-10-30 21:05:26 UTC
(In reply to comment #2)
> [ebuild   R   ] media-libs/win32codecs-20071007-r4  USE="(-real*)" 0 kB
> 
> And so portage complains it cannot find the needed USE=+real win32codecs
> 

You can unmask the flag like this:

mkdir -p /etc/portage/profile
echo media-libs/win32codecs -real >> /etc/portage/package.use.mask
Comment 6 Zac Medico gentoo-dev 2008-10-30 21:06:38 UTC
(In reply to comment #5)
> You can unmask the flag like this:
> 
> mkdir -p /etc/portage/profile
> echo media-libs/win32codecs -real >> /etc/portage/package.use.mask

Oops, forgot the "profile" dir, so that shoud be:

echo media-libs/win32codecs -real >> /etc/portage/profile/package.use.mask
Comment 7 junk_siu 2008-10-31 02:32:22 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > You can unmask the flag like this:
> > 
> > mkdir -p /etc/portage/profile
> > echo media-libs/win32codecs -real >> /etc/portage/package.use.mask
> 
> Oops, forgot the "profile" dir, so that shoud be:
> 
> echo media-libs/win32codecs -real >> /etc/portage/profile/package.use.mask
> 

Shouldn't amd64 use media-libs/amd64codecs?

Moreover, my mplayer is able to play real media(video) until this change. That means without win32codecs. But it cannot now.
Comment 8 Zac Medico gentoo-dev 2008-10-31 04:48:33 UTC
FWIW, the next release of portage (2.2_rc13) will include repoman support for detecting USE deps, such as this "real" flag, that are masked on a given profile (currently in svn r11762).

(In reply to comment #7)
> Shouldn't amd64 use media-libs/amd64codecs?

Well, not yet because media-libs/amd64codecs doesn't currently have a "real" flag and it's not currently pulled in as a dependency of media-libs/realcodecs.
Comment 9 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-10-31 23:34:27 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > You can unmask the flag like this:
> > 
> > mkdir -p /etc/portage/profile
> > echo media-libs/win32codecs -real >> /etc/portage/package.use.mask
> 
> Oops, forgot the "profile" dir, so that shoud be:
> 
> echo media-libs/win32codecs -real >> /etc/portage/profile/package.use.mask
> 

Doesn't work for me.

# cat /etc/portage/profile/package.use.mask
media-libs/win32codecs -real
# emerge -pv world --update --deep --tree

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/win32codecs-20071007-r4[real]".
!!! One of the following packages is required to complete your request:
- media-libs/win32codecs-20071007-r4 (Change USE: +real)
(dependency required by "media-libs/realcodecs-11.0.1.1056" [ebuild])
Comment 10 Zac Medico gentoo-dev 2008-10-31 23:55:23 UTC
In addition to unmasking the flag, you also have to explicitly enable it. So, all together, here's everything you'll have to do:

mkdir -p /etc/portage/profile
echo media-libs/win32codecs -real >> /etc/portage/profile/package.use.mask
echo media-libs/win32codecs real >> /etc/portage/package.use
Comment 11 Patrizio Bassi 2008-11-01 10:01:02 UTC
works for me, can you please apply to portage?
Comment 12 Jose daLuz 2008-11-01 18:02:39 UTC
(In reply to comment #10)
> In addition to unmasking the flag, you also have to explicitly enable it. So,
> all together, here's everything you'll have to do:
> 
> mkdir -p /etc/portage/profile
> echo media-libs/win32codecs -real >> /etc/portage/profile/package.use.mask
> echo media-libs/win32codecs real >> /etc/portage/package.use
> 
This doesn't work with paludis -- there is a /etc/paludis/use.conf but no use.mask. How is this supposed to work with non portage package managers? For that matter it's been a while since I used portage -- when did portage start requiring disabling a disabled USE flag explicitly in a profile in addition to package.use?
Comment 13 Jose daLuz 2008-11-01 18:13:14 UTC
To expand on the last point -- the real USE flag is apparently masked in the profile. Yet there is an extra step here to enable it in the profile. Presumably, if it can be enabled safely, it will actually work. Which begs the question, why is it profile masked in the first place? Wouldn't the correct approach be to allow this USE flag without any extra steps?
Comment 14 Zac Medico gentoo-dev 2008-11-01 19:00:53 UTC
(In reply to comment #11)
> works for me, can you please apply to portage?

I've added the necessary media-libs/win32codecs[real] unmasks to the following files in the profiles:

arch/amd64/package.use.mask
default-linux/amd64/package.use.mask
hardened/amd64/package.use.mask

Comment 15 Zac Medico gentoo-dev 2008-11-02 01:06:32 UTC
(In reply to comment #8)
> FWIW, the next release of portage (2.2_rc13) will include repoman support for
> detecting USE deps, such as this "real" flag, that are masked on a given
> profile (currently in svn r11762).

This repoman support has been released in sys-apps/portage-2.2_rc13.
Comment 16 Patrizio Bassi 2008-11-02 13:41:00 UTC
zac, it seems mplayer still reports disabled real flag...
Comment 17 Zac Medico gentoo-dev 2008-11-02 17:19:27 UTC
I only unmasked the "real" flag for media-libs/win32codecs because it's a local USE flag (listed in /usr/portage/profiles/use.local.desc) and I only wanted to unmask the local flag which was reported to work.

You can test it for mplayer too:

mkdir -p /etc/portage/profile
echo media-video/mplayer -real >> /etc/portage/profile/package.use.mask
echo media-video/mplayer real >> /etc/portage/package.use.mask

If you rebuild mplayer with that flag enabled and it works then we can unmask that flag for mplayer in the official profiles.
Comment 18 Steve Dibb (RETIRED) gentoo-dev 2008-11-05 15:12:00 UTC
(In reply to comment #13)
> To expand on the last point -- the real USE flag is apparently masked in the
> profile. Yet there is an extra step here to enable it in the profile.
> Presumably, if it can be enabled safely, it will actually work. Which begs the
> question, why is it profile masked in the first place? Wouldn't the correct
> approach be to allow this USE flag without any extra steps?
> 

No.  They were use.masked for security reasons.  Simply put (summarizing from other bugs and forum posts) it's either doing this or removing realplayer support completely.

Zac, I'm gonna undo your changes, assuming I'm doing it right on the profiles.  I guess I didn't make it clear last time the reason.

http://forums.gentoo.org/viewtopic-t-713051-highlight-.html
Comment 19 Steve Dibb (RETIRED) gentoo-dev 2008-11-05 15:22:43 UTC
Opened a new bug to track realplayer masking status, bug 245662

*** This bug has been marked as a duplicate of bug 245662 ***
Comment 20 Zac Medico gentoo-dev 2008-11-05 21:28:14 UTC
(In reply to comment #18)
> Zac, I'm gonna undo your changes, assuming I'm doing it right on the profiles. 
> I guess I didn't make it clear last time the reason.
> 
> http://forums.gentoo.org/viewtopic-t-713051-highlight-.html
> 

I've checked your changes and they seem reasonable. I was confused because the flag was masked on amd64 yet unmasked on x86, so it seemed like a mistake. 

I've just checked and it seems that the flag is still unmasked, at least in default-linux/x86/use.mask and arch/x86/use.mask. It doesn't really matter too much now though, since the relevant packages are masked in the global package.mask now.
Comment 21 Zac Medico gentoo-dev 2008-11-05 21:36:41 UTC
FWIW, here's an exhaustive list of the places the "real" flag is still unmasked:

$ find /usr/portage/profiles -name use.mask -o -name package.use.mask | \
xargs grep \\-real | sed 's:^/usr/portage/profiles/::'
default-linux/amd64/package.use.mask:media-libs/xine-lib -real
default-linux/x86/use.mask:-real
hardened/ia64/use.mask:-real
hardened/x86/use.mask:-real
hardened/x86/2.6/use.mask:-real
arch/amd64/package.use.mask:media-libs/xine-lib -real
arch/x86/use.mask:-real