Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 244142

Summary: mail-filter/libdomainkeys: CC variable not respected
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Net-Mail Packages <net-mail>
Status: RESOLVED FIXED    
Severity: normal CC: arttuv69
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: libdomainkeys ebuild patch which tries to respect CC and CFLAGS

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-24 19:49:13 UTC
I'm filing this bug (from a template, mind you) because the ebuild I'm reporting it against failed to build once I removed my /usr/bin/{gcc,cc,c++,c99} binaries. This means that the ebuild is relying on gcc or cc as compiler, while it should use "$(tc-getCC)" so that user choices are respected, and cross-compiling works as intended.

This usually comes down to one of these tasks:

- use emake CC="$(tc-getCC)" for building, to ovewrite make's CC variable (defaults to "cc", some upstream rewrites it);
- the above plus replacing explicit "gcc" (or similar) calls with $(CC) so that the variable is actually respected;
- tc-export CC in src_compile before eventual econf.

For C++, you'd have to replace CC with CXX everywhere above, of course.

If your package is a special case on this, please let me know.

Thanks,
Diego
Comment 1 Torsten Veller (RETIRED) gentoo-dev 2009-06-24 13:33:16 UTC
Reassign to net-mail herd as peitolm retires
Comment 2 Arttu Valo 2010-01-03 13:11:37 UTC
Created attachment 215016 [details, diff]
libdomainkeys ebuild patch which tries to respect CC and CFLAGS

Tries to patch the libdomainkeys-0.68-r1.ebuild to respect both CC (this bug) and CFLAGS (bug # 240782).
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-07-10 22:12:03 UTC
+*libdomainkeys-0.68-r2 (10 Jul 2010)
+
+  10 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+  +libdomainkeys-0.68-r2.ebuild:
+  Respect CC/CFLAGS/LDFLAGS wrt bug #244142 and bug #240782. Thanks to Arttu
+  Valo <arttuv69@gmail.com>
+