Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240782 - mail-filter/libdomainkeys: C(XX)FLAGS are ignored (at src_configure/compile)
Summary: mail-filter/libdomainkeys: C(XX)FLAGS are ignored (at src_configure/compile)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-09 21:18 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-07-10 22:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-09 21:18:10 UTC
I don't know the build system for this program (and this is a generic bug template so I cannot tell you which program exactly is), but my tests shows that it's not respecting CFLAGS (or CXXFLAGS) properly.

Please look into it, since it's important to respect user CFLAGS and CXXFLAGS.

Warning: this bug might look like a false positive because you actually have your CFLAGS being used; this happens if the CFLAGS are "set in stone" in the build system during src_unpack/src_prepare. While QA has not as of this moment expressed to me a preference, I'd sincerely suggest to avoid the set-in-stone approach, so that ebuild commands could work to reproduce the actual results.

To avoid the set in stone approach:

- consider just changing CFLAGS= to CFLAGS+= if the build system enables warnings;
- if the buildsystem does not use CFLAGS variable at all, in the sed use '$(CFLAGS)', single quoted, so that the CFLAGS variable is picked up;
- use '$(OPTCFLAGS)' in the sed and then use make OPTCFLAGS=$CFLAGS.

Thanks,
Diego
Comment 1 Torsten Veller (RETIRED) gentoo-dev 2009-06-24 13:33:15 UTC
Reassign to net-mail herd as peitolm retires
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2010-07-10 22:12:09 UTC
+*libdomainkeys-0.68-r2 (10 Jul 2010)
+
+  10 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+  +libdomainkeys-0.68-r2.ebuild:
+  Respect CC/CFLAGS/LDFLAGS wrt bug #244142 and bug #240782. Thanks to Arttu
+  Valo <arttuv69@gmail.com>
+