Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 2098

Summary: lack of 'vi' clone
Product: Gentoo Release Media Reporter: Chris Lee <c_lee>
Component: EverythingAssignee: Bart Verwilst <bart>
Status: RESOLVED FIXED    
Severity: trivial CC: agenkin, clacour, mholzer
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Chris Lee 2002-04-25 06:48:38 UTC
Tell me that this is some sort of a sick joke, please?   
   
Gentoo is "geared towards Linux power users" and yet vi is not on the CD?  
  
wow.  
  
(Just for your info... I've compiled 'nvi' locally, and the resulting binary is 30kB, so it's only 
1/3 the size of the 'nano' binary you're shipping. Space is obviously not the issue here.) 
 
-clee
Comment 1 Arcady Genkin (RETIRED) gentoo-dev 2002-04-26 04:11:39 UTC
FWIW, I'd like to voice my agreement with Chris.  That 'nano' thing would be a
laugh, if it were not for the absence of 'vi'. ;^)  IMO 'nano' is absolutely
inadequate for Gentoo distribution, given its target users.  

'vi' should be on the boot CD and in the base system, and I think that it should
be the default editor right out of the box.

Please note that I'm an avid emacs user, and the only reason I advocate `vi'
here is that it's the de facto standard as far as Unix text editors go.  A Unix
distro without `vi' command is incomplete.
Comment 2 Wout Mertens 2002-04-28 06:10:07 UTC
 I, too, would like to see vi on the rescue disk. Way better than having to          remember adding -w to the nano command line. If you know how to use it, it         will not clobber files as easily as other editors.              Sadly enough, the binary may be 30k, but it needs libdb-3.2 and libvi,       totalling about 800KB. I couldn't figure out a way to make it use less than       that, so if vi were to be included, it should be yet another clone that's       actually small, like elvis-tiny and levee:      http://packages.debian.org/unstable/base/elvis-tiny.html      http://www.pell.chi.il.us/~orc/            To compile levee, make LIBES=-lncurses in Makefile and make. Resulting   executable is 40KB after stripping, and it links to libncurses, which is   already on the rescue disk. If interested, I will make an ebuild. The only  disadvantage is that it doesn't support the cursor keys, but uses the 'hjlk'  mapping.  Wout. 
Comment 3 Wout Mertens 2002-04-28 12:46:49 UTC
See bug #2190 for an ebuild for levee
Comment 4 Ryan Phillips (RETIRED) gentoo-dev 2002-04-30 01:53:09 UTC
*** Bug 2235 has been marked as a duplicate of this bug. ***
Comment 5 José Fonseca 2002-05-20 05:09:52 UTC
I also missed the lack of vi during and right after Gentoo installation, as
several editing took place then.

One reason because I started to use vi was that although pico and nano were very
easy to learn they had very limited functionality, so I don't see how they are
the only solution available in a distribution with the target audience that
Gentoo has.
Comment 6 Mark Bainter 2002-05-25 00:28:33 UTC
I agree.  I was extremely shocked to find vi was missing.
Trying to work my way through using nano was painfull and
unnecessary.  Anyone serious about unix has invested the 
time to learn enough vi to use it in emergencies, and on
unfamiliar systems w/out their favorite editor of choice.
I too vote that vi should be a part of the base distribution.
Comment 7 Alexander Gretencord 2002-05-26 13:33:36 UTC
I could get away with nano if there was even _one_ good reason explained in the 
FAQ or install doc to include _only_ nano but this way it's just ridiculous. 
Nothing against newbie friendlyness even in gentoo, but alienate the users this 
was aimed to at first ? What chris quoted in his bug report was from the 
_first_ sentence in the "About Gentoo" doc! 
Comment 8 Charles Lacour 2002-05-28 08:30:07 UTC
*** Bug 3041 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Holler 2002-05-29 05:29:29 UTC
I agree too.   Vi should be the default editor.    
Comment 10 temperanza 2002-05-29 13:36:55 UTC
I disagree. VI is a bit too hard for newbies to use. Nano could be kept and
auto-aliased to "nano -w", or we could use jed- easy without the automatic word
wrap, or we could include both nano and vi.
Comment 11 mike wakerly 2002-07-02 20:43:22 UTC
What is there to disagree with? Nano and vi are not mutually exclusive. This is
like saying lynx or ftp can't be included because Mozilla is there.

I couldn't believe vi wasn't there on the 16MB boot CD. I'm sure it will be in
the next release... right?
Comment 12 Bart Verwilst 2002-07-03 07:30:41 UTC
Heh, i forgot to mention it here, but the 1.3b isos will include both Vim and nano..  
Comment 13 SpanKY gentoo-dev 2002-09-22 23:43:34 UTC
vi is on the 1.4 cds, so if at some point in the future it gets lost, feel free 
to re-open and rip someone's head off ;)
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2005-03-25 11:24:24 UTC
Moving these so we can remove the "Install CD" component from "Gentoo Linux".

I apologize to everyone for this spam, but according to the bugzilla developers,
this is the only reasonable way to do this.