Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 190036

Summary: problem with gnome-base/libgnomekbd-2.18
Product: Gentoo Linux Reporter: Sawk <sawk.ita>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED NEEDINFO    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sawk 2007-08-24 13:04:39 UTC
I've update GNOME at the 2.18 version. Now, when i try to set the keyboard, the /usr/bin/gnome-keyboard-properties crashes with this Bug:



Distribution: Gentoo Base System release 1.12.9
Gnome Release: 2.18.2 2007-08-13 (Gentoo)
BugBuddy Version: 2.18.1

System: Linux 2.6.22-gentoo-r5 #1 SMP Thu Aug 23 20:36:11 CEST 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 70200000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Lush
Icon Theme: Amaranth

Memory status: size: 33484800 vsize: 33484800 resident: 20303872 share: 10448896 rss: 20303872 rss_rlim: 4294967295
CPU usage: start_time: 1187960369 rtime: 72 utime: 67 stime: 5 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/gnome-keyboard-properties'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1236084512 (LWP 6515)]
0xb7f7b410 in __kernel_vsyscall ()
#0  0xb7f7b410 in __kernel_vsyscall ()
#1  0xb70d82c3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0xb7e3b477 in ?? () from /usr/lib/libgnomeui-2.so.0

Thread 1 (Thread -1236084512 (LWP 6515)):
#0  0xb7f7b410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb70d82c3 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0xb7e3b477 in ?? () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#0  0xb7f7b410 in __kernel_vsyscall ()
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]


----------- .xsession-errors (14 sec old) ---------------------
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
No running windows found
--------------------------------------------------


Reproducible: Always

Steps to Reproduce:
1.Start keyboard settings
Comment 1 Rémi Cardona gentoo-dev 2007-08-24 20:44:12 UTC
please follow this guide, the backtrace you've provided is almost useless as is. Thanks

http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 2 Sawk 2007-09-18 16:46:58 UTC
sawk@localhost ~ $ gdb gnome-keyboard-properties 
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/gnome-keyboard-properties 
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1237932336 (LWP 31811)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1237932336 (LWP 31811)]
0xb6d71b33 in strncat () from /lib/libc.so.6
Comment 3 Rémi Cardona gentoo-dev 2007-09-18 21:29:50 UTC
Nearly useless :) you must have missed one part of the guide. The "backtrace" command in gdb should return function names.

Thanks nonetheless
Comment 4 Sawk 2007-09-18 22:31:27 UTC
Ups, this is the backtrace command after run:

(gdb) backtrace 
#0  0xb6e2db33 in strncat () from /lib/libc.so.6
#1  0xb7edc609 in ?? () from /usr/lib/libxklavier.so.11
Comment 5 Saleem Abdulrasool (RETIRED) gentoo-dev 2007-12-12 04:53:09 UTC
Is this reproducible with GNOME 2.20?  If so, please rebuild libxklavier with -O0 -g -ggdb and get a backtrace.
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-01-01 22:40:25 UTC
please get back to us
Comment 7 Gilles Dartiguelongue gentoo-dev 2010-09-30 12:07:04 UTC
This bug has not been updated in the last 6 weeks with requested information.
Closing.