Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 872689 (CVE-2022-38398, CVE-2022-38648, CVE-2022-40146, CVE-2022-41704, CVE-2022-42890) - dev-java/barik: multiple vulnerabilities
Summary: dev-java/barik: multiple vulnerabilities
Status: CONFIRMED
Alias: CVE-2022-38398, CVE-2022-38648, CVE-2022-40146, CVE-2022-41704, CVE-2022-42890
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B4 [ebuild]
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-24 19:19 UTC by John Helmert III
Modified: 2022-10-25 16:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-09-24 19:19:59 UTC
CVE-2022-38398 (https://lists.apache.org/thread/712c9xwtmyghyokzrm2ml6sps4xlmbsx):

Server-Side Request Forgery (SSRF) vulnerability in Batik of Apache XML Graphics allows an attacker to load a url thru the jar protocol. This issue affects Apache XML Graphics Batik 1.14.

https://issues.apache.org/jira/browse/BATIK-1331

CVE-2022-38648 (https://lists.apache.org/thread/gfsktxvj7jtwyovmhhbrw0bs13wfjd7b):

Server-Side Request Forgery (SSRF) vulnerability in Batik of Apache XML Graphics allows an attacker to fetch external resources. This issue affects Apache XML Graphics Batik 1.14.

https://issues.apache.org/jira/browse/BATIK-1333

CVE-2022-40146 (https://lists.apache.org/thread/hxtddqjty2sbs12y97c8g7xfh17jzxsx):

Server-Side Request Forgery (SSRF) vulnerability in Batik of Apache XML Graphics allows an attacker to access files using a Jar url. This issue affects Apache XML Graphics Batik 1.14.

https://issues.apache.org/jira/browse/BATIK-1335

All fixed in 1.15, please bump.
Comment 1 Volkmar W. Pogatzki 2022-09-25 06:57:43 UTC
Change Log
==========

The following log records some of the most important changes.
Bug fixing is an ongoing task, so it is implied in all sub-releases.

1.14 -> 1.15
------------

BATIK-1260: Java 11 module error
BATIK-1321: Remove Xerces
BATIK-1299: Batik-all jar has all classes so should not pull other jars also
BATIK-1329: Remove xalan
BATIK-1331: Jar url should be blocked by DefaultExternalResourceSecurity
BATIK-1333: Block external resource before calling fop
BATIK-1335: Jar url should be blocked by DefaultScriptSecurity
Comment 2 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-10-25 16:36:27 UTC
CVE-2022-41704: "Block loading jars by default to avoid running untrusted code"
CVE-2022-42890: "Restrict what java classes can be run thru JavaScript"

The subject lines call these "information disclosure" vulnerabilities,
but preventing the execution of untrusted code sounds significantly
worse than information disclosure.

https://issues.apache.org/jira/browse/BATIK-1338
https://issues.apache.org/jira/browse/BATIK-1345

java@, any input on the severity?