Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 850622 (CVE-2022-26377, CVE-2022-28614, CVE-2022-28615, CVE-2022-29404, CVE-2022-30522, CVE-2022-30556, CVE-2022-31813) - <www-servers/apache-2.4.54: multiple vulnerabilities
Summary: <www-servers/apache-2.4.54: multiple vulnerabilities
Status: CONFIRMED
Alias: CVE-2022-26377, CVE-2022-28614, CVE-2022-28615, CVE-2022-29404, CVE-2022-30522, CVE-2022-30556, CVE-2022-31813
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B4 [glsa? cleanup]
Keywords:
Depends on: 852251
Blocks:
  Show dependency tree
 
Reported: 2022-06-08 13:37 UTC by John Helmert III
Modified: 2022-06-26 06:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-06-08 13:37:55 UTC
CVE-2022-26377: Apache HTTP Server: mod_proxy_ajp: Possible request smuggling
CVE-2022-28330: Apache HTTP Server: read beyond bounds in mod_isapi
CVE-2022-28614: Apache HTTP Server: read beyond bounds via ap_rwrite()
CVE-2022-29404: Apache HTTP Server: Denial of service in mod_lua r:parsebody
CVE-2022-30522: Apache HTTP Server: mod_sed denial of service
CVE-2022-30556: Apache HTTP Server: Information Disclosure in mod_lua with websockets
CVE-2022-31813: Apache HTTP Server: mod_proxy X-Forwarded-For dropped by hop-by-hop mechanism
CVE-2022-28615: Apache HTTP Server: Read beyond bounds in ap_strcmp_match()

Please stabilize 2.4.54 when ready.