Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 796530 (CVE-2021-34825) - net-irc/quassel: Does not enforce --require-ssl in some situations (CVE-2021-34825)
Summary: net-irc/quassel: Does not enforce --require-ssl in some situations (CVE-2021-...
Status: IN_PROGRESS
Alias: CVE-2021-34825
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [upstream/ebuild]
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-18 03:05 UTC by Sam James
Modified: 2021-08-07 21:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester gentoo-dev Security 2021-06-18 03:05:50 UTC
Description:
"Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system."

https://github.com/quassel/quassel/pull/581 (not yet merged)
Comment 1 NATTkA bot gentoo-dev 2021-07-29 17:21:44 UTC Comment hidden (obsolete)
Comment 2 NATTkA bot gentoo-dev 2021-07-29 17:29:54 UTC Comment hidden (obsolete)
Comment 3 NATTkA bot gentoo-dev 2021-07-29 17:37:52 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2021-07-29 17:45:58 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2021-07-29 18:01:55 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2021-07-29 18:10:14 UTC
Package list is empty or all packages have requested keywords.
Comment 7 John Helmert III gentoo-dev Security 2021-08-07 21:43:31 UTC
Patch was merged, not yet in a release