Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 777786 (CVE-2021-27928) - <dev-db/mariadb-{10.2.37,10.3.28,10.4.18,10.5.9}: eval injection via db superuser (CVE-2021-27928)
Summary: <dev-db/mariadb-{10.2.37,10.3.28,10.4.18,10.5.9}: eval injection via db super...
Status: RESOLVED FIXED
Alias: CVE-2021-27928
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://packetstormsecurity.com/files...
Whiteboard: B2 [glsa+ cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-22 21:58 UTC by John Helmert III
Modified: 2021-05-26 09:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III gentoo-dev Security 2021-03-22 21:58:06 UTC
CVE-2021-27928:

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.


Please cleanup vulnerable versions.
Comment 1 Thomas Deutschmann gentoo-dev Security 2021-05-25 01:46:25 UTC
New GLSA request filed.
Comment 2 GLSAMaker/CVETool Bot gentoo-dev 2021-05-26 09:53:35 UTC
This issue was resolved and addressed in
 GLSA 202105-28 at https://security.gentoo.org/glsa/202105-28
by GLSA coordinator Thomas Deutschmann (whissi).