Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 621722 (CVE-2017-5470, CVE-2017-5472, CVE-2017-7749, CVE-2017-7750, CVE-2017-7751, CVE-2017-7752, CVE-2017-7754, CVE-2017-7756, CVE-2017-7757, CVE-2017-7758, CVE-2017-7764) - <www-client/firefox{,-bin}-{52.2.0,54.0}: multiple vulnerabilities
Summary: <www-client/firefox{,-bin}-{52.2.0,54.0}: multiple vulnerabilities
Status: RESOLVED FIXED
Alias: CVE-2017-5470, CVE-2017-5472, CVE-2017-7749, CVE-2017-7750, CVE-2017-7751, CVE-2017-7752, CVE-2017-7754, CVE-2017-7756, CVE-2017-7757, CVE-2017-7758, CVE-2017-7764
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL: https://www.mozilla.org/en-US/securit...
Whiteboard: A2 [glsa+ cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-14 07:11 UTC by Agostino Sarubbo
Modified: 2018-02-20 00:58 UTC (History)
2 users (show)

See Also:
Package list:
=www-client/firefox-52.2.0
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ian Stakenvicius gentoo-dev 2017-06-14 22:13:25 UTC
www-client/firefox{,-bin}-{52.2.0,54.0} are now in gentoo-repo.

Arches, please stabilize www-client/firefox-52.2.0 with target
KEYWORDS="amd64 ppc ppc64 x86"


Please note that due to the new dependency on rust, firefox-54.0 is only available on amd64 and x86 right now.  This could cause issues relating to the removal of 53.x on the other platforms.
Comment 2 Agostino Sarubbo gentoo-dev 2017-06-15 08:34:32 UTC
amd64 stable
Comment 3 Agostino Sarubbo gentoo-dev 2017-06-15 09:55:10 UTC
x86 stable
Comment 4 Thomas Deutschmann gentoo-dev Security 2017-06-15 19:54:36 UTC
CVE-2017-5472: Use-after-free using destroyed node when regenerating trees

Impact
    critical

Description
===========
A use-after-free vulnerability with the frameloader during tree reconstruction while regenerating CSS layout when attempting to use a node in the tree that no longer exists. This results in a potentially exploitable crash.


CVE-2017-7749: Use-after-free during docshell reloading

Impact
    high

Description
===========
A use-after-free vulnerability when using an incorrect URL during the reloading of a docshell. This results in a potentially exploitable crash.


CVE-2017-7750: Use-after-free with track elements

Impact
    high

Description
===========
A use-after-free vulnerability during video control operations when a <track> element holds a reference to an older window if that window has been replaced in the DOM. This results in a potentially exploitable crash.


CVE-2017-7751: Use-after-free with content viewer listeners

Impact
    high

Description
===========
A use-after-free vulnerability with content viewer listeners that results in a potentially exploitable crash.


CVE-2017-7752: Use-after-free with IME input

Impact
    moderate

Description
===========
A use-after-free vulnerability during specific user interactions with the input method editor (IME) in some languages due to how events are handled. This results in a potentially exploitable crash but would require specific user interaction to trigger.


CVE-2017-7754: Out-of-bounds read in WebGL with ImageInfo object

Impact
    high

Description
===========
An out-of-bounds read in WebGL with a maliciously crafted ImageInfo object during WebGL operations.


CVE-2017-7756: Use-after-free and use-after-scope logging XHR header errors

Impact
    high

Description
===========
A use-after-free and use-after-scope vulnerability when logging errors from headers for XML HTTP Requests (XHR). This could result in a potentially exploitable crash.


CVE-2017-7757: Use-after-free in IndexedDB

Impact
    high

Description
===========
A use-after-free vulnerability in IndexedDB when one of its objects is destroyed in memory while a method on it is still being executed. This results in a potentially exploitable crash.


CVE-2017-7758: Out-of-bounds read in Opus encoder

Impact
    high

Description
===========
An out-of-bounds read vulnerability with the Opus encoder when the number of channels in an audio stream changes while the encoder is in use.


CVE-2017-7764: Domain spoofing with combination of Canadian Syllabics and other unicode blocks

Impact
    moderate

Description
===========
Characters from the "Canadian Syllabics" unicode block can be mixed with characters from other unicode blocks in the addressbar instead of being rendered as their raw "punycode" form, allowing for domain name spoofing attacks through character confusion. The current Unicode standard allows characters from "Aspirational Use Scripts" such as Canadian Syllabics to be mixed with Latin characters in the "moderately restrictive" IDN profile. We have changed Firefox behavior to match the upcoming Unicode version 10.0 which removes this category and treats them as "Limited Use Scripts."


CVE-2017-5470: Memory safety bugs fixed in Firefox 54 and Firefox ESR 52.2

Impact
    critical

Description
===========
Mozilla developers and community members Tyson Smith, Mats Palmgren, Philipp, Masayuki Nakano, Christian Holler, Andrew McCreight, Gary Kwong, André Bargull, Carsten Book, Jesse Schwartzentruber, Julian Hector, Marcia Knous, Ronald Crane, and Nils Ohlmeier reported memory safety bugs present in Firefox 53 and Firefox ESR 52.1. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code.
Comment 5 Thomas Deutschmann gentoo-dev Security 2017-06-15 19:56:29 UTC
Vulnerabilities in the Graphite 2 library

Impact
    high

Description
===========
A number of security vulnerabilities in the Graphite 2 library including out-of-bounds reads, buffer overflow reads and writes, and the use of uninitialized memory. These issues were addressed in Graphite 2 version 1.3.10.
    Graphite2 lz4::decompress out of bounds write (CVE-2017-7778)
    Graphite2 out of bounds read [@ graphite2::Pass::readPass] (CVE-2017-7771)
    Graphite2 heap-buffer-overflow write [@ lz4::decompress] (CVE-2017-7772)
    Graphite2 heap-buffer-overflow write [@ lz4::decompress] src/Decompressor (CVE-2017-7773)
    Graphite2 out of bounds read [@ graphite2::Silf::readGraphite] (CVE-2017-7774)
    Graphite2 Assertion 'size() > n' failed (CVE-2017-7775)
    Graphite2 heap-buffer-overflow read [@ graphite2::Silf::getClassGlyph] (CVE-2017-7776)
    Graphite2 use of uninitialized memory [@ graphite2::GlyphCache::Loader::read_glyph] (CVE-2017-7777)
Comment 6 Agostino Sarubbo gentoo-dev 2017-06-21 12:05:02 UTC
ppc stable
Comment 7 Agostino Sarubbo gentoo-dev 2017-06-21 12:21:40 UTC
ppc64 stable.

Maintainer(s), please cleanup.
Security, please add it to the existing request, or file a new one.
Comment 8 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2017-09-17 20:55:16 UTC
GLSA Request filed.

Tree is clean.

Gentoo Security Padawan
ChrisADR
Comment 9 GLSAMaker/CVETool Bot gentoo-dev 2018-02-20 00:58:59 UTC
This issue was resolved and addressed in
 GLSA 201802-03 at https://security.gentoo.org/glsa/201802-03
by GLSA coordinator Thomas Deutschmann (whissi).