Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 546592 (CVE-2015-3138) - =net-analyzer/tcpdump-4.7.3: Denial of Service (segfault) (CVE-2015-3138)
Summary: =net-analyzer/tcpdump-4.7.3: Denial of Service (segfault) (CVE-2015-3138)
Alias: CVE-2015-3138
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
Whiteboard: ~3 [noglsa]
Depends on:
Reported: 2015-04-14 16:06 UTC by Denis Ovsienko
Modified: 2015-06-20 13:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Denis Ovsienko 2015-04-14 16:06:09 UTC

Recently an independent researcher had discovered a vulnerability in tcpdump, which would be a segmentation fault triggered through feeding into tcpdump a crafted packet, either from a live network interface or from a .pcap file. It has been assigned CVE-2015-3138 and you can find the steps to reproduce it here:

Subsequent analysis made it clear that the vulnerability was introduced into one of tcpdump functions by an accident not long before the 4.7.0 release. It remained in tcpdump releases 4.7.2 and 4.7.3 (4.7.1 was never released). The next release, 4.7.4, will have it fixed, but it is likely to be delayed. Since the vulnerability has been public for a few weeks, meanwhile you might want to fix it in an update to the tcpdump package. The fix is in the following commit:

Let me know if you need any additional information about this case.

Reproducible: Always
Comment 1 Kristian Fiskerstrand (RETIRED) gentoo-dev 2015-04-14 16:18:02 UTC
Upon a closer look this does not seem to affect the current stable version, 4.6.2-r1, as such reducing whiteboard to ~3
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-05-01 15:48:45 UTC
FYI, 4.7.4 is in the tree, and the vulnerable 4.7.3 has been removed.
Comment 3 Sean Amoss (RETIRED) gentoo-dev Security 2015-06-20 13:59:15 UTC
(In reply to Jeroen Roovers from comment #2)
> FYI, 4.7.4 is in the tree, and the vulnerable 4.7.3 has been removed.

Thank you.

Closing noglsa for ~arch only.