Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 515282 (CVE-2014-4610) - <media-video/ffmpeg-2.2.15: LZO Denial of Service and Arbitrary Code Execution through embedded code (CVE-2014-4610)
Summary: <media-video/ffmpeg-2.2.15: LZO Denial of Service and Arbitrary Code Executio...
Alias: CVE-2014-4610
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
Whiteboard: B3 [glsa]
: 515236 (view as bug list)
Depends on:
Blocks: 515236 CVE-2014-4607
  Show dependency tree
Reported: 2014-06-27 01:14 UTC by Yury German
Modified: 2016-03-12 11:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Yury German Gentoo Infrastructure gentoo-dev 2014-06-27 01:14:37 UTC
It is suspected that this package is vulnerable to a security vulnerability in LZO. As such we ask maintainers with packages suspected to be vulnerable to verify if the package is (or have been) affected. 

Please see the information contained in the tracker bug 515246. "An integer overflow may occur when processing any variant of a "literal run" in the lzo1x_decompress_safe function. Each of these three locations is subject to an integer overflow when processing zero bytes.", additional information about the upstream vulnerability is available at
Comment 1 Hanno Böck gentoo-dev 2014-06-27 10:58:32 UTC
2.2.4 upstream release seems to contain the fix. So a version bump should do.
Comment 2 Kristian Fiskerstrand (RETIRED) gentoo-dev 2014-06-28 12:59:30 UTC
*** Bug 515236 has been marked as a duplicate of this bug. ***
Comment 3 Kristian Fiskerstrand (RETIRED) gentoo-dev 2014-06-28 13:01:53 UTC
ffmpeg got its own advisory and CVE assignment in . Making this bug the primary and related bugs as duplicates.
Comment 4 Alexis Ballier gentoo-dev 2015-02-15 10:31:40 UTC marks it as fixed in 2.2.4 for the 2.2 branch,
we'll go with 2.2.12+ since 1.2 (current stable) is not maintained anymore
Comment 5 Yury German Gentoo Infrastructure gentoo-dev 2015-07-01 13:08:30 UTC
Since 1.1.X and 1.2.X is no longer maintained and 
2.2.14 is being stabilized, but higher version without bugs is 2.2.15. Once stabilized we can clean up 1.1.x and 1.2.x

Setting dependency on: 548006
Comment 6 GLSAMaker/CVETool Bot gentoo-dev 2016-03-12 11:21:12 UTC
This issue was resolved and addressed in
 GLSA 201603-06 at
by GLSA coordinator Kristian Fiskerstrand (K_F).