Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 505662 (CVE-2014-2309) - Kernel: IPv6: crash due to router advertisement flooding (CVE-2014-2309)
Summary: Kernel: IPv6: crash due to router advertisement flooding (CVE-2014-2309)
Status: CONFIRMED
Alias: CVE-2014-2309
Product: Gentoo Security
Classification: Unclassified
Component: Kernel (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Security
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-25 11:58 UTC by Agostino Sarubbo
Modified: 2016-12-07 04:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-03-25 11:58:42 UTC
CVE-2014-2309 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2309):

The ip6_route_add function in net/ipv6/route.c in the Linux kernel through 3.13.6 does not properly count 
the addition of routes, which allows remote attackers to cause a denial of service (memory consumption) 
via a flood of ICMPv6 Router Advertisement packets.
Comment 1 GLSAMaker/CVETool Bot gentoo-dev 2014-08-10 21:58:39 UTC
CVE-2014-2309 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2309):
  The ip6_route_add function in net/ipv6/route.c in the Linux kernel through
  3.13.6 does not properly count the addition of routes, which allows remote
  attackers to cause a denial of service (memory consumption) via a flood of
  ICMPv6 Router Advertisement packets.