Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507164 (CVE-2014-0165) - <www-apps/wordpress-3.8.2: multiple vulnerabilities (CVE-2014-{0165,0166})
Summary: <www-apps/wordpress-3.8.2: multiple vulnerabilities (CVE-2014-{0165,0166})
Alias: CVE-2014-0165
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Gentoo Security
Whiteboard: ~4 [noglsa]
: CVE-2014-0166 (view as bug list)
Depends on:
Reported: 2014-04-08 20:03 UTC by Laurent Bachelier
Modified: 2014-08-10 21:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bachelier 2014-04-08 20:03:16 UTC

WordPress 3.8.2 is now available. This is an important security release for all previous versions and we strongly encourage you to update your sites immediately.

This releases fixes a weakness that could let an attacker force their way into your site by forging authentication cookies. This was discovered and fixed by Jon Cave of the WordPress security team.

It also contains a fix to prevent a user with the Contributor role from improperly publishing posts. Reported by edik.

This release also fixes nine bugs and contains three other security hardening changes:

    Pass along additional information when processing pingbacks to help hosts identify potentially abusive requests.
    Fix a low-impact SQL injection by trusted users. Reported by Tom Adams of dxw.
    Prevent possible cross-domain scripting through Plupload, the third-party library WordPress uses for uploading files. Reported by Szymon Gruszecki.
Comment 1 Murray McAllister 2014-04-09 14:53:34 UTC
I think the two CVEs assigned are CVE-2014-0165 and CVE-2014-0166:
Comment 2 Yury German Gentoo Infrastructure gentoo-dev 2014-04-10 04:46:40 UTC
*** Bug 507250 has been marked as a duplicate of this bug. ***
Comment 3 Laurent Bachelier 2014-04-15 11:38:27 UTC
Minor update/fix:
Comment 4 Kristian Fiskerstrand (RETIRED) gentoo-dev 2014-06-17 22:42:15 UTC
3.8.3 in three and 3.7 was never included. Package not stable: closing noglsa
Comment 5 GLSAMaker/CVETool Bot gentoo-dev 2014-08-10 21:11:39 UTC
CVE-2014-0166 (
  The wp_validate_auth_cookie function in wp-includes/pluggable.php in
  WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine
  the validity of authentication cookies, which makes it easier for remote
  attackers to obtain access via a forged cookie.

CVE-2014-0165 (
  WordPress before 3.7.2 and 3.8.x before 3.8.2 allows remote authenticated
  users to publish posts by leveraging the Contributor role, related to
  wp-admin/includes/post.php and