Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504722 (CVE-2014-0132) - <net-nds/389-ds-base-1.3.4.8: SASL/GSSAPI Security Bypass Security Issue (CVE-2014-0132)
Summary: <net-nds/389-ds-base-1.3.4.8: SASL/GSSAPI Security Bypass Security Issue (CVE...
Status: RESOLVED FIXED
Alias: CVE-2014-0132
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/57427/
Whiteboard: ~4 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-15 15:32 UTC by Agostino Sarubbo
Modified: 2016-03-29 11:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-03-15 15:32:56 UTC
From ${URL} :

Description

A security issue has been reported in 389 Directory Server, which can be exploited by malicious 
users to bypass certain security restrictions.

The security issue is caused due to an error related to SASL/GSSAPI authentication when the 
"authzid" parameter is specified and can be exploited to use the directory as another user.

The security issue is reported in versions prior to 1.3.1.20 and 1.3.2.14.


Solution:
Update to version 1.3.1.20 or 1.3.2.14.

Provided and/or discovered by:
rv3 in a bug report.

Original Advisory:
http://directory.fedoraproject.org/wiki/Releases/1.3.1.20
http://directory.fedoraproject.org/wiki/Releases/1.3.2.14

rv3:
https://fedorahosted.org/389/ticket/47739


@maintainer(s): since the package has never been marked as stable, we don't need to stabilize it. After the bump, please remove the affected versions from the tree.
Comment 1 GLSAMaker/CVETool Bot gentoo-dev 2014-04-28 19:43:38 UTC
CVE-2014-0132 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0132):
  The SASL authentication functionality in 389 Directory Server before
  1.2.11.26 allows remote authenticated users to connect as an arbitrary user
  and gain privileges via the authzid parameter in a SASL/GSSAPI bind.
Comment 2 William Brown 2016-02-07 01:48:39 UTC
Hi,

We have updated 389-ds-base to 1.3.4.7. This should resolve the issue.

Thanks,
Comment 3 Adam Feldman gentoo-dev 2016-02-07 01:56:06 UTC
Referenced commit 5a7174bf7122309eee568651fb5f3413155f9fc2
Comment 4 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-03-29 11:30:10 UTC
No vulnerable versions in tree.