Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 480882 (CVE-2013-4623) - <net-libs/polarssl-1.2.8: Certificate Message Processing Denial of Service Vulnerability (CVE-2013-4623)
Summary: <net-libs/polarssl-1.2.8: Certificate Message Processing Denial of Service Vu...
Status: RESOLVED FIXED
Alias: CVE-2013-4623
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/54430/
Whiteboard: B3 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-13 14:21 UTC by Agostino Sarubbo
Modified: 2013-10-17 09:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-08-13 14:21:42 UTC
From ${URL} :

Description

A vulnerability has been reported in PolarSSL, which can be exploited by malicious people to cause 
a DoS (Denial of Service) of the application using the library.

The vulnerability is caused due to an error when processing certificate messages and can be 
exploited to trigger an infinite loop via a PEM encoded certificate within the certificate message.

Successful exploitation requires that PolarSSL is compiled with the POLARSSL_PEM_C option (enabled 
by default). 

The vulnerability is reported in versions prior to 1.1.7 and 1.2.8.


Solution:
Update to version 1.1.7 or 1.2.8.

Provided and/or discovered by:
The vendor credits Jack Lloyd.

Original Advisory:
PolarSSL Security Advisory 2013-03:
https://polarssl.org/tech-updates/security-advisories/polarssl-security-advisory-2013-03


@maintainer(s): after the bump, in case we need to stabilize the package, please say explicitly if it is ready for the stabilization or not.
Comment 1 Chris Reffett gentoo-dev Security 2013-08-14 23:51:04 UTC
Are we good to stable?
Comment 2 Thomas Sachau gentoo-dev 2013-08-16 16:14:53 UTC
(In reply to Chris Reffett from comment #1)
> Are we good to stable?

looks good for stable, so adding arches.

please stabilize:

=net-libs/polarssl-1.2.8

target keywords: amd64 arm hppa ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd
Comment 3 Agostino Sarubbo gentoo-dev 2013-08-16 19:39:17 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2013-08-16 19:43:25 UTC
x86 stable
Comment 5 Jeroen Roovers gentoo-dev 2013-08-17 15:20:28 UTC
Stable for HPPA.
Comment 6 Agostino Sarubbo gentoo-dev 2013-08-19 13:57:29 UTC
ppc stable
Comment 7 Agostino Sarubbo gentoo-dev 2013-08-24 12:34:59 UTC
ppc64 stable
Comment 8 Agostino Sarubbo gentoo-dev 2013-08-24 15:54:58 UTC
arm stable
Comment 9 Agostino Sarubbo gentoo-dev 2013-08-28 12:08:24 UTC
s390 stable
Comment 10 Agostino Sarubbo gentoo-dev 2013-08-28 12:10:26 UTC
sparc stable
Comment 11 Thomas Sachau gentoo-dev 2013-08-29 19:44:30 UTC
old version removed
Comment 12 Sergey Popov gentoo-dev Security 2013-08-30 09:29:00 UTC
GLSA vote: yes

As we already have draft for polarssl
Comment 13 GLSAMaker/CVETool Bot gentoo-dev 2013-10-02 04:00:53 UTC
CVE-2013-4623 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4623):
  The x509parse_crt function in x509.h in PolarSSL 1.1.x before 1.1.7 and
  1.2.x before 1.2.8 does not properly parse certificate messages during the
  SSL/TLS handshake, which allows remote attackers to cause a denial of
  service (infinite loop and CPU consumption) via a certificate message that
  contains a PEM encoded certificate.
Comment 14 Sergey Popov gentoo-dev Security 2013-10-17 08:16:21 UTC
Added to existing GLSA draft
Comment 15 GLSAMaker/CVETool Bot gentoo-dev 2013-10-17 09:03:31 UTC
This issue was resolved and addressed in
 GLSA 201310-10 at http://security.gentoo.org/glsa/glsa-201310-10.xml
by GLSA coordinator Sergey Popov (pinkbyte).