Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206651 (CVE-2005-0508) - dev-java/batik < 1.5.1 Squiggle Vulnerable scripting engine (CVE-2005-0508)
Summary: dev-java/batik < 1.5.1 Squiggle Vulnerable scripting engine (CVE-2005-0508)
Status: RESOLVED FIXED
Alias: CVE-2005-0508
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-19 16:17 UTC by Petteri Räty (RETIRED)
Modified: 2008-02-12 08:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petteri Räty (RETIRED) gentoo-dev 2008-01-19 16:17:22 UTC
From http://xmlgraphics.apache.org/batik/

Security warning

This is a warning that a script security issue was reported in the Batik Squiggle browser. Squiggle uses the Rhino scripting engine and some features of that engine can be leveraged by malicious scripts to gain access to otherwise protected resources (like the file system). This issue was fixed in the 1.5.1 release of Batik. If you are using a version of Batik older than 1.5.1, you should upgrade.
Comment 1 Robert Buchholz (RETIRED) gentoo-dev 2008-01-19 22:59:08 UTC
So our latest stable 1.6-r3 is not vulnerable to this, but since it and the 1.5 branch are slotted, people might still use the old version.

Do packages depend on this specific slot, or can we just drop it from the tree?
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2008-01-19 23:20:50 UTC
(In reply to comment #1)
> 
> Do packages depend on this specific slot, or can we just drop it from the tree?
> 

Probably not doable at this point in time but I will version bump 1.5 when get to it.
Comment 3 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-01-20 22:32:48 UTC
Turned out that nothing depended on 1.5 anymore, so I removed it. We even had 1.5.1 in the tree but own slot, was removed earlier.
So to GLSA or not to GLSA? :) We were installing launcher for the svg browser...
Comment 4 Sune Kloppenborg Jeppesen gentoo-dev 2008-01-21 07:59:43 UTC
I tend to vote YES.
Comment 5 Robert Buchholz (RETIRED) gentoo-dev 2008-02-11 21:28:41 UTC
1.5.1 hit the tree about 2004, stable 2005. I vote NO for reasons of obsoletion.
Comment 6 Pierre-Yves Rofes (RETIRED) gentoo-dev 2008-02-12 08:22:58 UTC
(In reply to comment #5)
> 1.5.1 hit the tree about 2004, stable 2005. I vote NO for reasons of
> obsoletion.
> 

same here, and closing.