Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 99650 - net-dialup/fritzcapi: New ebuild for SuSE 9.3 drivers
Summary: net-dialup/fritzcapi: New ebuild for SuSE 9.3 drivers
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Lowest enhancement (vote)
Assignee: Gentoo Dialup Developers
URL:
Whiteboard:
Keywords:
: 99649 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-20 04:08 UTC by sf
Modified: 2005-08-22 02:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fritzcapi-2.6.35.ebuild (fritzcapi-2.6.35.ebuild,5.77 KB, text/plain)
2005-07-20 07:45 UTC, Stefan Schweizer (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sf 2005-07-20 04:08:52 UTC
I just noticed that there are new SuSE 9.3 drivers.

Maybe the maintainer would like to update the ebuild?
Comment 1 sf 2005-07-20 04:11:29 UTC
*** Bug 99649 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Schweizer (RETIRED) gentoo-dev 2005-07-20 07:45:56 UTC
Created attachment 63893 [details]
fritzcapi-2.6.35.ebuild

Hi, can you please test this ebuild?
The amd64 support is not yet finished, but otherwise it should work fine.
Comment 3 sf 2005-07-20 09:16:22 UTC
That was fast!

Will try compiling tomorrow but only can test fcpci next weekend.
Comment 4 sf 2005-07-20 10:25:01 UTC
Note: I am using config-kernel to build the kernel outside of the source tree!

fcpci fcpcmcia fcusb fcusb2 fxusb: compile fine

fcclassic fcpnp fxusb_CZ e2220pc e5520pc: do not compile; They search for a file
../lib/*-lib.o (* is fcclassic, fcpnp, fxusb_CZ, driver, driver respectively).

Example: fcpnp

Calculating dependencies ...done!
>>> emerge (1 of 1) net-dialup/fritzcapi-2.6.35 to /
>>> md5 files   ;-) fritzcapi-2.6.35.ebuild
>>> md5 files   ;-) fritzcapi-2.6.32.ebuild
>>> md5 files   ;-) files/digest-fritzcapi-2.6.32
>>> md5 files   ;-) files/digest-fritzcapi-2.6.35
>>> md5 files   ;-) files/fritzcapi-fix-for-2.6.10.patch
>>> md5 src_uri ;-) km_fritzcapi-2.6-35.i586.rpm
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /var/tmp/kernel-output/2.6.11.11
 * Found sources for kernel version:
 *     2.6.11.11
 * Selected cards:  fcpnp
>>> Unpacking source...
>>> Unpacking fcpci-suse93-3.11-07.tar.gz to
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi
>>> Unpacking fcpcmcia-suse93-3.11-07.tar.gz to
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi
>>> Unpacking fcusb-suse93-3.11-04.tar.gz to
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi
>>> Unpacking fcusb2-suse93-3.11-07.tar.gz to
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi
>>> Unpacking fxusb-suse93-3.11-06.tar.gz to
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi
 * Converting ./Makefile to use M= instead of SUBDIRS= ...                     
                  [ ok ]
 * Converting ./fritz.usb.orig/src/Makefile to use M= instead of SUBDIRS= ...  
                  [ ok ]
 * Converting ./fritz.usb2/src/Makefile to use M= instead of SUBDIRS= ...      
                  [ ok ]
 * Converting ./fritz.usb2/Makefile to use M= instead of SUBDIRS= ...          
                  [ ok ]
 * Converting ./fritz.xusb/src/Makefile to use M= instead of SUBDIRS= ...      
                  [ ok ]
 * Converting ./fritz.xusb/Makefile to use M= instead of SUBDIRS= ...          
                  [ ok ]
 * Converting ./fritz.pcmcia.orig/src/Makefile to use M= instead of SUBDIRS= ...
                 [ ok ]
 * Converting ./fritz.pci/src/Makefile to use M= instead of SUBDIRS= ...       
                  [ ok ]
 * Converting ./fritz.pci/Makefile to use M= instead of SUBDIRS= ...           
                  [ ok ]
 * Converting ./fritz.pnp/src/Makefile to use M= instead of SUBDIRS= ...       
                  [ ok ]
 * Converting ./fritz.usb/src/Makefile to use M= instead of SUBDIRS= ...       
                  [ ok ]
 * Converting ./fritz.usb/Makefile to use M= instead of SUBDIRS= ...           
                  [ ok ]
 * Converting ./fritz.pcmcia/src/Makefile to use M= instead of SUBDIRS= ...    
                  [ ok ]
 * Converting ./fritz.pcmcia/Makefile to use M= instead of SUBDIRS= ...        
                  [ ok ]
 * Converting ./e2220pc/src/Makefile to use M= instead of SUBDIRS= ...         
                  [ ok ]
 * Converting ./e2220pc/Makefile to use M= instead of SUBDIRS= ...             
                  [ ok ]
 * Converting ./fritz.classic/src/Makefile to use M= instead of SUBDIRS= ...   
                  [ ok ]
 * Converting ./e5520pc/src/Makefile to use M= instead of SUBDIRS= ...         
                  [ ok ]
 * Converting ./e5520pc/Makefile to use M= instead of SUBDIRS= ...             
                  [ ok ]
 * Converting ./fritz.xusb_CZ/src/Makefile to use M= instead of SUBDIRS= ...   
                  [ ok ]
 * Converting ./fritz.usb2.orig/src/Makefile to use M= instead of SUBDIRS= ... 
                  [ ok ]
 * Converting ./fritz.xusb.orig/src/Makefile to use M= instead of SUBDIRS= ... 
                  [ ok ]
 * Converting ./fritz.pci.orig/src/Makefile to use M= instead of SUBDIRS= ...  
                  [ ok ]
>>> Source unpacked.
 * Preparing fcpnp module
make -C /usr/src/linux 
M=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src
modules
make[1]: Entering directory `/usr/src/linux-2.6.11.11'
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/main.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/driver.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/tools.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/tables.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/queue.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/lib.o
  LD [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/fcpnp.o
ld: /usr/src/linux-2.6.11.11/../lib/fcpnp-lib.o: No such file: No such file or
directory
make[3]: ***
[/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src/fcpnp.o]
Error 1
make[2]: ***
[_module_/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/fritz.pnp/src]
Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.11.11'
make: *** [all] Error 2

!!! ERROR: net-dialup/fritzcapi-2.6.35 failed.
!!! Function linux-mod_src_compile, Line 491, Exitcode 2
!!! Unable to make                                  KDIR=/usr/src/linux
LIBDIR=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/var/lib/fritz all.
!!! If you need support, post the topmost build error, NOT this status message.


--
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11.11 i686)
=================================================================
System uname: 2.6.11.11 i686 Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.10
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-march=i586 -O2 -Os -fomit-frame-pointer -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i586 -O2 -Os -fomit-frame-pointer -pipe"
DISTDIR="/gentoo/distfiles"
FEATURES="autoconfig buildpkg collision-protect distlocks sandbox sfperms strict
userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo
http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
PKGDIR="/gentoo/packages"
PORTAGE_TMPDIR="/tmp/gentoo/tmp"
PORTDIR="/gentoo/portage"
PORTDIR_OVERLAY="/gentoo/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X X509 Xaw3d aalib acl acpi activefilter adns alsa apm async avi berkdb
bidi bitmap-fonts caps cdr chroot crypt cscope cspoe cups curl dga directfb doc
dvb dvd dvdr emboss encode erandom ethereal evo f77 fam fbcon firebird flac
flash foomaticdb fortran freetds freetype gb gcj gd gdbm ggi gif gphoto2 gpm gps
gtk gtk2 hbci imagemagick imap imlib imlib2 informix innodb ipv6 java jbig jikes
jpeg junit ladcca lcms ldap libg++ libwww lirc mad mailwrapper mcal md5sum
mikmod motif mozilla mozsvg mp3 mpeg mpi mysql nas ncurses nhc98 nls nntp nptl
oav oci8 odbc ogg oggvorbis opengl oss pam pcmcia pda pdflib pg-hier
pg-intdatetime pg-vacuumdelay pic pie plotutils png pnp postgres ppds prebuilt
quicktime readline samba sasl scanner sdl slang slp snmp socks5 speex spell ssl
svga tcpd tetex threads tiff truetype truetype-fonts type1-fonts unicode usb
vanilla vorbis wavelan wmf xface xine xinerama xml xml2 xmms xv zlib
fritzcapi_cards_fcpci userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Comment 5 sf 2005-07-26 03:41:49 UTC
I did not find the time to test fcpci but will try again next weekend.
Comment 6 sf 2005-08-03 04:49:13 UTC
fcpci works for me with kernel 2.6.11.11.
Comment 7 Markus Friedrich 2005-08-08 07:20:15 UTC
Hi,
I have tested fcusb2 with gentoo kernel 2.6.12-r4. It works fine, including NO
system crash when unloading (as it happens with fritzcapi-2.6.32)

But 2.6.35 and 2.6.32 dose not work if it is connected through a USB-Hub.
Comment 8 Dead Schorsch 2005-08-08 07:39:33 UTC
I have tested fcpcmcia with no crash so far. I do not use and have therefor not
testet the FAX capabilities, though I do adress the card using CAPI.
Comment 9 Stefan Schweizer (RETIRED) gentoo-dev 2005-08-11 02:33:01 UTC
Thanks, fixed:
I added a workaround for the config-kernel issue, sf, does that work?


  11 Aug 2005; Stefan Schweizer <genstef@gentoo.org>
  +fritzcapi-2.6.35.ebuild:
  Version bump thanks to sf <sf@b-i-t.de>, Markus Friedrich <fm12@freenet.de>
  and Christoph Dahlen <christoph@dahlen.org> in bug 99650
Comment 10 sf 2005-08-22 02:26:25 UTC
Re comment #9: e2220pc and e5520pc still do not compile, others do.

 * Preparing e2220pc module
make -C /usr/src/linux 
M=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src
modules
make[1]: Entering directory `/usr/src/linux-2.6.11.11'
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/main.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/driver.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/tools.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/tables.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/queue.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/lib.o
  LD [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/e2220pc.o
ld: /usr/src/linux-2.6.11.11/../lib/driver-lib.o: No such file: No such file or
directory
make[3]: ***
[/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src/e2220pc.o]
Error 1
make[2]: ***
[_module_/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e2220pc/src]
Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.11.11'
make: *** [e2220pc.o] Error 2

!!! ERROR: net-dialup/fritzcapi-2.6.35 failed.
!!! Function linux-mod_src_compile, Line 491, Exitcode 2
!!! Unable to make                                  KDIR=/usr/src/linux
LIBDIR=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/var/lib/fritz all.
!!! If you need support, post the topmost build error, NOT this status message.


 * Preparing e5520pc module
make -C /usr/src/linux 
M=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src
modules
make[1]: Entering directory `/usr/src/linux-2.6.11.11'
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/main.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/driver.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/tools.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/tables.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/queue.o
  CC [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/lib.o
  LD [M] 
/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/e5520pc.o
ld: /usr/src/linux-2.6.11.11/../lib/driver-lib.o: No such file: No such file or
directory
make[3]: ***
[/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src/e5520pc.o]
Error 1
make[2]: ***
[_module_/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/usr/src/kernel-modules/fritzcapi/e5520pc/src]
Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.11.11'
make: *** [e5520pc.o] Error 2

!!! ERROR: net-dialup/fritzcapi-2.6.35 failed.
!!! Function linux-mod_src_compile, Line 491, Exitcode 2
!!! Unable to make                                  KDIR=/usr/src/linux
LIBDIR=/tmp/gentoo/tmp/portage/fritzcapi-2.6.35/work/var/lib/fritz all.
!!! If you need support, post the topmost build error, NOT this status message.