Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98958 - X11 crashes with RenderBadGlyphSet.. (on international char sets?)
Summary: X11 crashes with RenderBadGlyphSet.. (on international char sets?)
Status: RESOLVED DUPLICATE of bug 112355
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: ppc64 architecture team
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-13 23:27 UTC by Cameron Blackwood
Modified: 2006-05-01 05:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cameron Blackwood 2005-07-13 23:27:50 UTC
I just switched to ppc64 (I know that mozilla isnt stable, thats _NOT_ the
problem) so Ive been using mozilla off a ppc32 chroot environ and via ssh from
an x86 and ppc32 system (both of which are perfectly happy to run without this bug).

Situation:
  Log into my X session on my ppc64
  ssh to other host (creating x pipe from other host to my ppc64)
  run web browser on other host (displaying to ppc64)
  access http://en.wikinews.org/wiki/Main_Page
  page downloads but on display crashes with following...

Output:
korg@pookie ~ $ mozilla 
/usr/lib/mozilla/mozilla-xremote-client: Error: Failed to find a running server.
No running windows found
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadGlyphSet (invalid GlyphSet parameter)'.
  (Details: serial 29433 error_code 176 request_code 152 minor_code 23)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
mozilla-bin exited with non-zero status (1)

x11-xorg info:
root@kali /usr/src/linux # emerge info xorg-x11
Portage 2.0.51.22-r1 (!/usr/portage/profiles/default-linux/ppc64/2004.3, gcc-3.4
.4, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r8 ppc64)
=================================================================
System uname: 2.6.11-gentoo-r8 ppc64 PPC970, altivec supported
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5 
sys-apps/sandbox:    1.2.10
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.90.0.3-r5
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="ppc64"    
AUTOCLEAN="yes"            
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=G5 -pipe -maltivec -mabi=altivec -fno-strict-aliasing
-mpowerpc-gfxopt -mmultiple -mstring"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=G5 -pipe -maltivec -mabi=altivec -fno-strict-aliasing
-mpowerpc-gfxopt -mmultiple -mstring"
DISTDIR="/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distlocks nostrip sandbox sfperms
strict"                    
GENTOO_MIRRORS="http://kali.cs.mu.oz.au/gentoo/ http://rahu.cs.mu.oz.au/gentoo/
http://ftp.monash.edu.au/pub/linux/gentoo/ http://128.213.5.34/gentoo/
http://mirror.datapipe.net/gentoo http://gentoo.eliteitminds.com
http://csociety-ftp.ecn.purdue.edu/pub/gentoo/ http://gentoo.llarian.net/
ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
ftp://mirror.pacific.net.au/linux/Gentoo"
MAKEOPTS="-j3"             
PKGDIR="/portage/packages" 
PORTAGE_TMPDIR="/portage/build_tmp"
PORTDIR="/portage/portage_tree"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rahu.cs.mu.oz.au/gentoo-portage"
USE="ppc64 X alsa berkdb bitmap-fonts cdr crypt dvdr emboss escreen esd fam
fbcon font-server fortran gdbm gif gpm gtk jpeg motif mozcalendar mozilla
ncurses nls opengl pam perl png python readline sdk slang ssl tcpd terminfo
threads tiff truetype truetype-fonts type1-fonts unicode xinerama xml2 xv zlib
video_cards_riva userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

It looks to me like a ppc64 _X11 server_ problem (given that ppc32 and x86 and
ppc64 browsers all display the same problem but run fine when displayed on a
non-ppc64 x server system).

Given that this isnt a very common problem (ie, only xyz on the forums also
seems to have it) it seems probable that its just something i have done wrong...

Reproducible: Always
Steps to Reproduce:
1. xorg-x11 recently updated in portage, so its been recompiled and restarted
recently (it was also happening before that though)
2. ssh to a remote host with a working mozilla
3. start mozilla, visit http://en.wikinews.org/wiki/Main_Page
4. mozilla dies..

Actual Results:  

The error was 'RenderBadGlyphSet (invalid GlyphSet parameter)'. (see above)

Expected Results:  

correct rendering of the page... 


ppc64 g5 mac with:

CFLAGS="-O2 -mcpu=G5 -pipe -maltivec -mabi=altivec -fno-strict-aliasing
-mpowerpc-gfxopt -mmultiple -mstring"

ACCEPT_KEYWORDS="ppc64"

USE="-emacs alsa -kde -qt -openjade terminfo -termcap ncurses truetype zlib
xinerama tiff dvdr cdr mozcalendar crypt fbcon threads -java pda mozilla opengl
sdk escreen python xv"
Comment 1 Cameron Blackwood 2005-09-25 22:20:26 UTC
Can I as what the status of libunicode is for ppc64? I have it set (as ppc),
although I dont really want or need unicode. Obviously ive turned it on for some
dependancy.

Is it something that is barfworthy under ppc64? Should I not have it?
Comment 2 Yang Dehua 2006-02-01 18:40:14 UTC
Same problem here. Is there any progress in solving it? That's a big hurdle in xorg of ppc64 arena.
Comment 3 Yuta SATOH (RETIRED) gentoo-dev 2006-02-18 17:53:39 UTC
I attached the patch for the similar problem on Bug #112355. 
Would you check Bug #112355 and try the patch ?

Thanks. 
Comment 4 Yang Dehua 2006-03-10 02:37:14 UTC
I tried it manually on xorg-7.0, but no luck.
Comment 5 Yang Dehua 2006-04-15 17:11:07 UTC
Any progress in solving this bug, please? It seems the bug occurs more often than before in my system, so many gtk+ programs crash under my newly built kde-3.5.2 with this problem.
Thanks.
Comment 6 Markus Rothe (RETIRED) gentoo-dev 2006-05-01 05:12:41 UTC

*** This bug has been marked as a duplicate of 112355 ***