Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98881 - emerge-delta-webrsync-3.3: uncompressed verification failed
Summary: emerge-delta-webrsync-3.3: uncompressed verification failed
Status: RESOLVED CANTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Brian Harring
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-13 07:42 UTC by sf
Modified: 2005-09-27 22:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
messages (log.txt,188.20 KB, text/plain)
2005-07-13 07:49 UTC, sf
Details
differences between runs (diff.txt,12.96 KB, text/plain)
2005-07-15 02:47 UTC, sf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sf 2005-07-13 07:42:33 UTC
Since 2005-07-11 I get the message "uncompressed verification failed" when running emerge-delta-webrsync.
Comment 1 sf 2005-07-13 07:49:01 UTC
Created attachment 63312 [details]
messages

The messages are from

(set -x && . emerge-delta-webrsync -u -k )
Comment 2 Brian Harring gentoo-dev 2005-07-14 12:32:05 UTC
what's the md5 of the 07/09 tarball in /var/delta-webrsync ?
Comment 3 sf 2005-07-15 01:58:54 UTC
Sorry, but I don't understand. There is no file
/var/delta-webrsync/portage-20050709.tar.bz2.
Comment 4 sf 2005-07-15 02:23:06 UTC
I found this typo (snapshoRt):

# cat snapshot-20050705-20050706.patch.bz2.md5sum 
28f4f83795bbee06afae58d6ad0e1a58  snapshort-20050705-20050706.patch.bz2

Server compromised? ;-)
Comment 5 sf 2005-07-15 02:31:31 UTC
"Server compromised" was meant as a joke but something is definitely funny:

snapshot-20050705-20050706.patch.bz2        10-Jul-2005 06:50  1.0M  
snapshot-20050705-20050706.patch.bz2.md5sum 10-Jul-2005 06:53   72   

The snapshot is quite large and has a timestamp that is four days late. Brian,
did you create and upload these files manually?
Comment 6 sf 2005-07-15 02:45:59 UTC
That snapshot-20050705-20050706 seems to be the root cause. The messages I sent
were from a run with the "original" snapshot. Now I downloaded the "new"
snapshot and fixed the typo in the md5sum file. Everything looks good again.

But I am still suspicious... why is there a new snapshot?
Comment 7 sf 2005-07-15 02:47:57 UTC
Created attachment 63449 [details]
differences between runs

This is from a unified diff of the different runs.
Comment 8 Brian Harring gentoo-dev 2005-07-16 05:27:40 UTC
Pardon, real life is being a bugger and forcing me to deal with it a bit :)

I recreated the 05-06 patch due to the fact that the 07/06 snapshot was
rereleased without me being poked about it- wouldn't be an issue, except some
people *had* already updated to the original 07/06 snapshot, and a re-release of
the snapshot effectively screwed them, leaving them out in the cold.

I've since made it known not to do that again without giving me a heads up, but
the framework in place doesn't allow for anyway to help those who are stuck with
the original 07/06 release.
Comment 9 Brian Harring gentoo-dev 2005-09-27 22:30:34 UTC
Closing cantfix, since the failures were related to screwups of snapshot
generation serverside (something I can't retroactively fix for those affected).

Reopen if it occurs again please.