Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98393 - app-cdr/cdrtools-2.01-r3 cdrecord fails when burning ISO as normal user.
Summary: app-cdr/cdrtools-2.01-r3 cdrecord fails when burning ISO as normal user.
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-08 13:51 UTC by Benoît Knecht
Modified: 2005-10-01 09:50 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benoît Knecht 2005-07-08 13:51:25 UTC
When I try burning an ISO using cdrecord as a normal user, it fails. If I try
the exact same command as root, it works.
I use app-cdr/cdrtools-2.01-r3, gentoo-sources-2.6.11-r11 without scsi emulation.

Reproducible: Always
Steps to Reproduce:
1. Run cdrecord dev=ATAPI:/dev/hdd -v -dao test.iso
Actual Results:  
It fails with the following message:

Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J�g Schilling
on-the-fly encryption (version 1.0-rc1) built-in, (C) 2004,2005 Maximilian Decker

NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <burbon04 at gmx.de>.
      For more information please see
http://burbon04.gmxhome.de/linux/CDREncryption.html.
      The original author should not be bothered with problems of this version.

cdrecord: Warning: Running on Linux-2.6.11-gentoo-r11
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
TOC Type: 1 = CD-ROM
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: 'ATAPI:/dev/hdd'
devname: 'ATAPI:/dev/hdd'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PREMIUM  '
Revision       : '1.06'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x0008
Profile: 0x0009 (current)
Profile: 0x000A
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes:
Drive buf size : 4802784 = 4690 KB
Drive DMA Speed: 28294 kB/s 160x CD 20x DVD
FIFO size      : 16777216 = 16384 KB
cdrecord: Drive does not support SAO recording.
cdrecord: Illegal write mode for this drive.

Expected Results:  
When using the same command as root, it succeeds:

Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J&#65533;g Schilling
on-the-fly encryption (version 1.0-rc1) built-in, (C) 2004,2005 Maximilian Decker

NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <burbon04 at gmx.de>.
      For more information please see
http://burbon04.gmxhome.de/linux/CDREncryption.html.
      The original author should not be bothered with problems of this version.

cdrecord: Warning: Running on Linux-2.6.11-gentoo-r11
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
TOC Type: 1 = CD-ROM
scsidev: 'ATAPI:/dev/hdd'
devname: 'ATAPI:/dev/hdd'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PREMIUM  '
Revision       : '1.06'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x0008
Profile: 0x0009 (current)
Profile: 0x000A
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE VARIREC FORCESPEED SPEEDREAD
SINGLESESSION HIDECDR
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 4802784 = 4690 KB
Drive DMA Speed: 29059 kB/s 165x CD 20x DVD
FIFO size      : 16777216 = 16384 KB
Track 01: data   667 MB
Total size:      766 MB (75:57.54) = 341816 sectors
Lout start:      767 MB (75:59/41) = 341816 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type A, high Beta category (A+) (3)
  ATIP start of lead in:  -11634 (97:26/66)
  ATIP start of lead out: 359846 (79:59/71)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Single session is OFF.
Hide CDR is OFF.
Speed-Read is OFF.
Blocks total: 359846 Blocks current: 359846 Blocks remaining: 18030
Forcespeed is OFF.
Power-Rec is ON.
Power-Rec write speed:     52x (recommended)
Starting to write CD/DVD at speed 32 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Turning BURN-Free off
Performing OPC...
Sending CUE sheet...
Writing pregap for track 1 at -150
Encryption feature disabled.
Starting new track at sector: 0
Track 01:  667 of  667 MB written (fifo 100%) [buf  99%]  32.5x.
Track 01: Total bytes read/written: 700039168/700039168 (341816 sectors).
Writing  time:  175.946s
Average write speed  27.7x.
Min drive buffer fill was 99%
Fixating...
Fixating time:    3.860s
Last selected write speed: 32x
Max media write speed:     52x
Last actual write speed:   31x
cdrecord: fifo had 11027 puts and 11027 gets.
cdrecord: fifo was 0 times empty and 6424 times full, min fill was 97%.

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r11 i686)
=================================================================
System uname: 2.6.11-gentoo-r11 i686 Intel(R) Pentium(R) 4 CPU 2.53GHz
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 28 2005, 21:20:38)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/
ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo
http://gentoo.oregonstate.edu"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X Xaw3d aac aalib acl acpi adns alsa apache2 async athena avi
bitmap-fonts bzip2 bzlib cddb cdparanoia chroot crypt cups dts dvd dvdr dvdread
encode ethereal exif faac faad fbcon fbdev ffmpeg flac freetype fs ftp gif
gimpprint gnuplot gs gstreamer imap imlib java javascript jp2 jpeg jpeg2k kde
latex lcd lcms libcaca live logitech-mouse mad md5sum mime mmx mmx2 mng motif
mozxmlterm mp3 mpeg mpeg4 mplayer ncurses network nls nocardbus nodrm nojoystick
nptl nptlonly nvidia offensive ogg oggvorbis ooo-kde openal opengl pam pdf
pdflib perl php physfs plotutils png print qt quicktime readline real scanner
sdl sftplogging smime sox spell sse sse2 ssl stats svg svga tetex tiff transcode
truetype truetype-fonts type1 type1-fonts unicode usb vorbis win32codecs wmf
wsconvert xchattext xine xml2 xosd xv xvid xvmc yv12 zlib video_cards_nvidia
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Lars Weiler (RETIRED) gentoo-dev 2005-07-09 05:33:49 UTC
Please check if the permissions to your cd-drive are correct and that the
cdrecord-binary is not setuid root.
Comment 2 Benoît Knecht 2005-07-09 06:23:18 UTC
I checked the permissions on /dev/hdd:
brw-rw----  1 root disk 22, 64 Jul  9 11:10 /dev/hdd
I'm in the disk group, but I also tried with 0666 mode, with no success.
/usr/bin/cdrecord is not setuid root.
Comment 3 Luis Medinas (RETIRED) gentoo-dev 2005-08-20 19:44:47 UTC
can you try with gentoo-sources-2.6.12 and with the latest cdrtools available in
portage (2.01.01_alpha03-r1) ?
Comment 4 Benoît Knecht 2005-08-21 06:14:55 UTC
(In reply to comment #3)
I'm sorry, I cannot try for now because of bug 102878 which prevents
app-cdr/cdrtools-2.01.01_alpha03 from emerging. But I'll try as soon as possible.
Comment 5 Benoît Knecht 2005-08-22 09:20:08 UTC
OK, I tried with app-cdr/cdrtools-2.01.01_alpha03-r2 and
sys-kernel/gentoo-sources-2.6.12-r9, with no success. Here's the output of both
commands I tried:
$ cdrecord dev=/dev/hdd -v test.iso

cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 J&#65533;g Schilling
TOC Type: 1 = CD-ROM
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdd'
devname: '/dev/hdd'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PREMIUM  '
Revision       : '1.06'
Device seems to be: Generic mmc CD-RW.
Current: 0x000A
Profile: 0x0008
Profile: 0x0009
Profile: 0x000A (current)
cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl

-----

$ cdrecord dev=ATAPI:/dev/hdd -v test.iso

cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 J&#65533;g Schilling
TOC Type: 1 = CD-ROM
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: 'ATAPI:/dev/hdd'
devname: 'ATAPI:/dev/hdd'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PREMIUM  '
Revision       : '1.06'
Device seems to be: Generic mmc CD-RW.
Current: 0x000A
Profile: 0x0008
Profile: 0x0009
Profile: 0x000A (current)
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes:
Drive buf size : 4802784 = 4690 KB
Drive DMA Speed: 22876 kB/s 129x CD 16x DVD
FIFO size      : 16777216 = 16384 KB
cdrecord: Drive does not support TAO recording.
cdrecord: Illegal write mode for this drive.

And I had /dev/hdd permissions set to 0666.
Comment 6 Luis Medinas (RETIRED) gentoo-dev 2005-10-01 09:50:46 UTC
Closing this for now because alpha03 is very broken. Reopen if you still have
problems with cdrtools 2.01 stable version