Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98100 - motherboard ga-k8nf-9: ehci_hcd doesn't work
Summary: motherboard ga-k8nf-9: ehci_hcd doesn't work
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-07-06 03:09 UTC by Marco Clocchiatti
Modified: 2005-08-17 06:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

more data (output.tar.bz2,3.23 KB, text/tbz)
2005-07-06 08:51 UTC, Marco Clocchiatti
extract from /var/log/kernel/current (ehci_hcd-64.txt,1.23 KB, text/plain)
2005-07-06 12:43 UTC, Marco Clocchiatti
second extract from /var/log/kernel/current (ohci_hcd-64.txt,529 bytes, text/plain)
2005-07-06 12:46 UTC, Marco Clocchiatti
third extract from /var/log/kernel/current (ehci_hcd-32.txt,528 bytes, text/plain)
2005-07-06 12:47 UTC, Marco Clocchiatti
lspci output (lspci.txt,15.81 KB, text/plain)
2005-07-06 12:49 UTC, Marco Clocchiatti
debug output form /var/log/kernel/current (ehci-vanilla.txt,2.82 KB, text/plain)
2005-07-07 07:17 UTC, Marco Clocchiatti
debug output form /var/log/kernel/current (ohci-vanilla.txt,5.66 KB, text/plain)
2005-07-07 07:19 UTC, Marco Clocchiatti

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Clocchiatti 2005-07-06 03:09:33 UTC
kernel doesn't load correctly usb 2.0 devices.  
I've tried a lot of different kernel configuration (e.g. whitout preempitible  
May it be a kernel problem, and not a gentoo problem, but I think usefull to  
advise gentoo developers, to have some suggestion, as the first step. 
On these threads: 
is there a lot of output from logs. 

Reproducible: Always
Steps to Reproduce:
1.modprobe -v ehci_hcd 
2.plug on usb 2.0 device failures on logs. 
Actual Results:  
my usb 2.0 devices doesn't work. 

Expected Results:  
to mount correctly usb 2.0 devices. 

s939 ~ # emerge info  
Portage (default-linux/amd64/2005.0, gcc-3.4.3,  
glibc-, 2.6.12-gentoo-r3 x86_64)  
System uname: 2.6.12-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3500+  
Gentoo Base System version 1.6.12  
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Jul  5 2005, 20:02:06)]  
ccache version 2.3 [enabled]  
dev-lang/python:     2.3.5  
sys-apps/sandbox:    1.2.9  
sys-devel/autoconf:  2.59-r6, 2.13  
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5  
sys-devel/libtool:   1.5.16  
CFLAGS="-march=athlon64 -O2 -pipe -fweb -frename-registers -ftracer"  
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"  
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"  
CXXFLAGS="-march=athlon64 -O2 -pipe -fweb -frename-registers -ftracer"  
FEATURES="autoaddcvs autoconfig buildpkg ccache distlocks sandbox sfperms  
LDFLAGS="-Wl,-O1 -Wl,--as-needed"  
MAKEOPTS="-j3 -s"  
USE="amd64 X aalib acpi alsa bash-completion berkdb bitmap-fonts bzip2 bzlib  
cddb cdr chroot crypt cspell cups curl dvd dvdr eds encode esd fam flac  
font-server foomaticdb fortran fpx gif gimpprint gnome gphoto2 gpm graphviz  
gstreamer gtk gtk2 gtkhtml hal ieee1394 imagemagick imlib java javascript jbig  
jp2 jpeg kde kdeenablefinal lcms ldap libwww lzw lzw-tiff mad mime mng mozilla  
mp3 mpeg nas ncurses nls nptl nvidia ogg opengl oss pam pam_chroot pam_console  
pam_timestamp perl php png posix ppds pwdb python qt readline rtc samba  
scanner slang smp ssl svg tcltk tcpd tiff truetype truetype-fonts type1-fonts  
unicode usb userlocales wmf xine xml xml2 xmms xpm xrandr xv zlib linguas_it  
userland_GNU kernel_linux elibc_glibc"  
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2005-07-06 06:31:35 UTC
Please post the full problem report (including logs as attachments) to this bug
so that everything is in one place.

Please also attach your kernel .config and the "lspci -vvv" output, and the
"lspci -n" output.
Comment 2 Marco Clocchiatti 2005-07-06 08:51:14 UTC
Created attachment 62777 [details]
more data

usb 2.0 devices don't work on my ga-k8nf-9 motherbord using ehci_hcd module.

They work only with ohci_hcd module on 64 bit installation or with ehci_hcd
module on 32 bit installation.
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2005-07-06 09:04:30 UTC
Sorry to be awkward. Please post everything in plain text format so that its
easy to read. If this means multiple attachments, no problem. (We really need
docs on this stuff...)
Comment 4 Marco Clocchiatti 2005-07-06 12:43:16 UTC
Created attachment 62796 [details]
extract from /var/log/kernel/current

first attachment.
Obtained using module ehci_hcd on a amd64 bit installation.
Comment 5 Marco Clocchiatti 2005-07-06 12:46:04 UTC
Created attachment 62797 [details]
second extract from /var/log/kernel/current

Second attachment.
Obtained on the same installation, after #modprobe -rv ehci_hcd.
All devices are well charged, but with ohci_hcd module.
Comment 6 Marco Clocchiatti 2005-07-06 12:47:54 UTC
Created attachment 62798 [details]
third extract from /var/log/kernel/current

Third attachment.
Obtained on the same machine, but with a 32-bit installation.
All devices are well charged, with ehci_hcd module.
Comment 7 Marco Clocchiatti 2005-07-06 12:49:58 UTC
Created attachment 62799 [details]
lspci output

lspci -n and lspci -vvv output.
If you need some other information, may you ask.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2005-07-06 13:36:54 UTC
Ok- thats better, thanks.

Any chance you could try and reproduce with vanilla-sources-2.6.13_rc2?
Comment 9 Marco Clocchiatti 2005-07-07 07:17:54 UTC
Created attachment 62835 [details]
debug output form /var/log/kernel/current

vanilla-sources-2.6.13_rc2 is not in portage.
So I've used vanilla-sources-2.6.13_rc1.

Same behaviour.
I attach other output with this kernel.
The flag for debug from usb is on.
Comment 10 Marco Clocchiatti 2005-07-07 07:19:01 UTC
Created attachment 62836 [details]
debug output form /var/log/kernel/current

Off course, ohci_hcd module works fine.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2005-07-08 09:19:24 UTC
Ok, looks like an upstream bug then.

Please file a bug report at and post the new bug URL

Comment 12 Marco Clocchiatti 2005-07-08 17:39:00 UTC
Opened bug on Kernel Bug Tracker: 
Comment 13 Marco Clocchiatti 2005-08-17 05:59:51 UTC
Solved upgrading bios to f4 version (see  
f7 version gives me another problem (may be a second bug?) 
Comment 14 Marco Clocchiatti 2005-08-17 06:01:12 UTC
Comment 15 Daniel Drake (RETIRED) gentoo-dev 2005-08-17 06:15:30 UTC
Feel free to file a bug for the new problem