Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97999 - mplayer plays OGG Theora video wrong
Summary: mplayer plays OGG Theora video wrong
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-05 05:48 UTC by Clock
Modified: 2006-06-22 08:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clock 2005-07-05 05:48:46 UTC
Video is not displayed at all and audio is replaced by a sharp hum in left
channel. Test video:
http://stream.fluendo.com/archive/6uadec/Mark_Shuttleworth_-_Partial_Keynote.ogg

Reproducible: Always
Steps to Reproduce:
1.mplayer Mark_Shuttleworth_-_Partial_Keynote.ogg
2. 3.

Actual Results:  
hum in left channel

Expected Results:  
display video and normal audio

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r9 i686)
================================================================= System uname:
2.6.11-gentoo-r9 i686 Intel(R) Pentium(R) M processor 1.50GHz Gentoo Base System
version 1.4.16 Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  4
2005, 16:17:52)] dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control" CONFIG_PROTECT_MASK="/etc/gconf
/etc/terminfo /etc/env.d" CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer
-pipe" DISTDIR="/usr/portage/distfiles" FEATURES="autoaddcvs autoconfig ccache
distlocks sandbox sfperms strict" GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo" MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage" USE="x86 X alsa apm arts avi
berkdb bitmap-fonts cdr crypt cups curl emboss encode esd fam foomaticdb fortran
gd gdbm gif gpm gtk gtk2 guile imagemagick imap imlib ipv6 jack java jpeg kde
ldap libg++ libwww mad mikmod mng motif mozilla mp3 mpeg mysql ncurses nls ogg
oggvorbis opengl oss pam pdflib perl png python qt quicktime readline ruby samba
sdl slang spell ssl svga tcltk tcpd tetex tiff tls truetype truetype-fonts
type1-fonts vorbis xine xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-07-05 08:00:26 UTC
Which mplayer version are you using? 
Comment 2 Clock 2005-07-06 03:29:15 UTC
MPlayer 1.0pre6-3.3.5-2005013
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-07-06 04:58:08 UTC
You should reopen the bug next time, otherwise no-one might notice...
Comment 4 Henrik Segesten 2005-10-17 08:19:52 UTC
It seems there must be something wrong with the video file you supplied or is
that another version of the codec?

ogg theora files at: http://share.sh.cvut.cz/Theora_demos/ works just fine.
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2006-06-22 08:05:19 UTC
Is this still an issue with newer versions of mplayer?