Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97942 - ivtv-0.2.0_rc3-r5 does not install the tuner module
Summary: ivtv-0.2.0_rc3-r5 does not install the tuner module
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Brian Jackson (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-04 16:50 UTC by sams2100
Modified: 2005-10-23 10:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
modified to install the tuner module (ivtv-0.2.0_rc3-r5.ebuild,3.89 KB, text/plain)
2005-07-04 16:53 UTC, sams2100
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sams2100 2005-07-04 16:50:09 UTC
The ebuild, media-tv/ivtv-0.2.0_rc3-r5, does not install the tuner module.  It
compiles it just fine along with everything else, but at the end it does not
install it.

Its an extremely easy fix of just adding an extra line to have the module installed.

Reproducible: Always
Steps to Reproduce:
1.emerge =ivtv-0.2.0_rc3-r5
2.
3.

Actual Results:  
Emerges successfully, but the tuner module is not installed with the other modules.

Expected Results:  
Everything it currently does, as well as install the tuner module.
Comment 1 sams2100 2005-07-04 16:53:08 UTC
Created attachment 62633 [details]
modified to install the tuner module
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-07-05 01:13:03 UTC
Please, post just the diff, not the whole ebuild next time so that it's easier
to review the required changes. Thanks.
Comment 3 Neil Katin 2005-07-31 23:39:10 UTC
I can confirm the bug, and the proposed fix works for me.
Comment 4 Rob Smith 2005-08-01 00:19:54 UTC
Some of the cards ivtv supports (m179 for example) need to use the in kernel
tuner module, it would be nice to have a use flag notuner or similar.
Comment 5 Rob Smith 2005-08-01 17:22:59 UTC
(In reply to comment #4)
> Some of the cards ivtv supports (m179 for example) need to use the in kernel
> tuner module, it would be nice to have a use flag notuner or similar.

Actually, most of the cards ivtv supports require the in kernel tuner.

The ivtv tuner is only for the pvr 150/500 and it's only until they stablize it
out and get it rolled into the in kernel one and then it shall go away.
Comment 6 Doug Goldstein gentoo-dev 2005-10-23 10:12:58 UTC
Please upgrade to version 0.4.0-r2.