I had a system with servletapi-2.4 and commons-beanutils-1.7, however when
trying to emerge commons-digester (depends on commons-beanutils-1.6) and struts
(depends on servlet-api-2.3) both failed their emerge.
When I did a emerge -p <commons-digester || struts>, it reported that I had all
my dependencies and it was ready to go (e.g. just the N and the new package).
I had to go back and emerge the old versions, and once I did this, both struts
and common-digester worked.
I'm using blackdown-jdk-1.4.2
Steps to Reproduce:
1. have only commons-beanutils-1.7 OR servlet-api 2.4
2. Try to emerge commons-digester 1.6 OR struts
3. Note error and lack of dependency check
It tried to emerge, both stated (in red font) the missing package, but continued
to try to build anyway.
It should have shown the dependencies needed and emerged in the slotted old versions
The slot where added later, so you probably didn't update to the latest version
So it wasn't slotted correctly. We can't depend on those version because portage
doesn't support version ranges(yet?).
you should use the -u -D options to keep everything up-to-date
emerge -puD world