Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97774 - Java packages (commons-digester and struts) do not recognize slotted dependencies
Summary: Java packages (commons-digester and struts) do not recognize slotted dependen...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Java team
Depends on:
Reported: 2005-07-02 18:26 UTC by Al Baker
Modified: 2005-07-03 02:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Al Baker 2005-07-02 18:26:42 UTC
I had a system with servletapi-2.4 and commons-beanutils-1.7, however when
trying to emerge commons-digester (depends on commons-beanutils-1.6) and struts
(depends on servlet-api-2.3) both failed their emerge.

When I did a emerge -p <commons-digester || struts>, it reported that I had all
my  dependencies and it was ready to go (e.g. just the N and the new package).  

I had to go back and emerge the old versions, and once I did this, both struts
and common-digester worked.

I'm using blackdown-jdk-1.4.2

Reproducible: Always
Steps to Reproduce:
1. have only commons-beanutils-1.7 OR servlet-api 2.4
2. Try to emerge commons-digester 1.6 OR struts
3. Note error and lack of dependency check

Actual Results:  
It tried to emerge, both stated (in red font) the missing package, but continued
to try to build anyway.

Expected Results:  
It should have shown the dependencies needed and emerged in the slotted old versions
Comment 1 Thomas Matthijs (RETIRED) gentoo-dev 2005-07-03 02:57:31 UTC
The slot where added later, so you probably didn't update to the latest version
So it wasn't slotted correctly. We can't depend on those version because portage 
doesn't support version ranges(yet?).
you should use the -u -D options to keep everything up-to-date
emerge -puD world